Forum Clubic

Multi-Boot Vista 64 + XP 32

Hello à tous,

Jusqu’à présent je tournais de manière stable sur ma config à base de Vista 64 (E8500, Striker II Formula, 4Go de RAM, etc,…) Vista 64 étant installé sur mon premier RAID0 (C:), sachant que la config comporte d’autres RAID0 et partitions logiques, dont les lettres de lecteurs avaient été remappées par souci d’organisation (à mon avis détail important pour la résolution de mon problème, voire plus bas).

Après m’être cassé les dents sur certains soucis de compatibilité sur mes softs de MAO, j’ai décidé de réinstaller une version d’XP Pro, qui ne servira qu’à faire de le ziq.

Mais après avoir suivi les étapes décrites plus bas, je me retrouve avec un système qui ne boot plus normalement, avec le message fatidique “NTLDR is missing…”

Voici les étapes suivies :

1 - Sous Vista 64, réduction d’espace de ma partition C: (unique partition de mon premier RAID0, 2 raptor de 74Go) via l’outil de gestion de disque Vista, pour pouvoir créer une petite partition de 25Go pour XP

2 - formatage de cette partition, mapping de la lettre X: et renommé en “XP”

3 - création suivant la même méthode d’une partition “XP_DATA” sur l’un de mes autres disques.

4 - Copie de bootsec.exe pour utilisation ultérieure.

5 - redémarrage pour lancer l’installation de XP. (avec changement dans le BIOS des priorité de périph pour le démarrage, donc passage sur Boot lecteur CD/DVD)

6 - setup d’XP, sans problème particulier, mais je remarque que ma partition XP est remappée en G: au lieu de X: défini sous Vista 64

7 - reboot

8 - je zappe de remettre les prios de dédmarrage dans le BIOS et donc reste sur le CD

9 - XP boot, après avoir bypassé le message de boot Cd donc

10 - sous XP, je fais Démarrer/Exécuter, et je tape : “E:[path]\bootsect.exe /NT60 All” puis touche Entrée. A priori les scripts s’éxecutent sans problème.

11 - reboot

12 - à ce moment précis, repassage dans le BIOS pour remettre “disques durs” en priorité de démarrage 1

13 - Vista 64 reprend la main bizarrement, sans me proposer de choix d’OS

14 - Sous Vista 64, je refais la procédure du bottsect.exe : “E:[path]\bootsect.exe /NT60 All” puis touche Entrée. A priori les scripts s’éxecutent sans problème.

15 - reboot

16 - toujours pas de choix d’OS et boot de Vista 64

17 - installation de VistaBootPro donc…

18 - je suis la procédure décrite ici le tout sans résultat.

19 - je passe donc à la “remarque 2” de cette procédure, remarquant que dans la liste des OS détecté mon Win XP n’était pas listé via l’onglet “Add new OS entry”. Je précise en lettre de lecteur G: (la partition d’XP donc qui s’était remappée sous XP en G: au lieu du X:, défini plus tôt sous Vista 64… Je pense que c’est là le problème)

20 - Reboot, “et là c’est le drame”…

21 - “NTLDR is missing…”

Merci par avance pour vos lumières les pros !!!

Excellente journée à tous
Edité le 19/08/2008 à 11:32

je sais que j’avais eu ce souci
car avec vistabootpro quand j’ai ajouter un 2eme OS, winxp en l’occurence je l’avais installer sur D et donc sous vistabootpro j’ai mis qu’il etait sur D et vista sur C
mais en fait ca marcher pas, aucun choix de boot
en fait il faut dire que les OS sont sur C:
en fait meme si tu installer un 2eme os sur le 2eme disque, en fait tu as le fichier de chargement de windows qui se met sous c: quoi qu’il arrive
d’ou le fait que tu n’as pas le choix au demarrage, et d’ou le fait que moi aussi ca avait planté au debut.
peut etre est ce une solution, je l’espere pour toi!

Donc si je copie le NTLDR sur C: manuellement, ça pourrait fonctionner ? ou alors je boot sur Vista grace au DVD, puis je lance VistaBootPro et modifie la lettre répertoriée pour le le boot de Win XP ?

Merci
Edité le 19/08/2008 à 13:16

pour ma part j’ai modifier la lettre dans vistabootpro directement
car en fait il y a 3 fichier de demarrage necessaire pour lancer un OS
Edité le 19/08/2008 à 13:56

Donc tu préconises de répertorier sous VistaBootPro la lettre C: comme volume de démarrage pour Win XP, même si il est installé sur G: ? Désolé des répétitions, je veux être bien sûr de mon coup ^^

Question additionnelle : c’est la couche Win XP qui gère le dual-boot ?

Merci

oui oui mets C: pour les 2 OS
c’est ce que j’ai fait
peu de gens savent que meme si tu installe un autre os sur un autre DD il copiera 3 fichiers de demarrage sous c:
tu ne les vois pas car ils sont cachés et pour les voir tu dois desactiver la case: “masquer les fichiers protégés du systeme d’exploitation” cette option se trouve quelques lignes en dessous de la ou tu selectionne si tu veux voir les fichier et dossiers cachés.

donc pour repondre clairement oui: tu mets xp sur c: dans vistaboot pro
par contre une fois la manip faite
n’oublie pas d’appliquer les changement, si tu as 1 ou 2 panneau d’erreur tu mets NON a chaque fois
ensuite tu vas dans l’onglet’ SYSTEM BOOTLOADER
tu coche: windows vista bootloard(uninstall legacy bootloader)
et tu coche aussi sur ALL DRIVES
et tout en bas tu clique sur install bootloader pour confirmer !!!

normalemen tout marche sans probleme :wink:

j’espere etre clair
je pars bientot en angleterre dans quelques heures pour 3 jours donc je ne pourrais repondre a d’autres questions sauf si tu reponds rapidement :wink:

merci pour ces précisions… je tenterai ça en live ce soir, une fois rentré chez wam…

D’ici là, bonnes vacances chez les roast-beefs :]

Bon, il y a du mieux, mais je sèche un peu là…

après avoir copié et édité le boot.ini + NTLDR + NTDETEC.COM sur ma partition XP, j’ai enfin le menu du dual-boot au démarrage.

Lorsque je choisi Vista 64, no souci tout roule…

Par contre, lorsque je porte mon choix sur XP, ma machine reboot et se retrouve à nouveau sur le menu dual-boot après le POST. A partir de là je peux tout de même lancer Vista.

Quelqu’un aurait une idée du souci ?

Merci encore

un petit up ça ne mange pas de pain j’espère… :wink:

Je poste un screen BCDEDIT :

http://img45.imageshack.us/my.php?image=gesoe2.jpg

http://img253.imageshack.us/img253/6934/bcdeditla7.0bc3e1c57a.jpg

http://img253.imageshack.us/img253/6934/bcdeditla7.th.jpg

ainsi qu’un screen du gestionnaire, partie disques :

http://img143.imageshack.us/img143/6540/gesdj2.6bd9791c3b.jpg

http://img45.imageshack.us/img45/4234/gesoe2.th.jpg

Merci pour votre aide
Edité le 22/08/2008 à 09:14

Snif… Je suis toujours en grosse galère sur ce sujet… Si une bonne âme passe par là… :arf:

Si t’as le Dvd de Vista, tente une réparation.
On sait jamais !