Forum Clubic

Mozilla : Installer le(s) plugins de machine Java virtuelle

Bonsoir,

J’ai un petit problème que je n’arrive pas à résoudre.

Je suis sous Windows 2000 et j’ai Mozilla (la version 1.7.3) installé (qui fonctionne très bien) et j’ai également le Java 2 Runtime Environment, Standard Edition 1.4.2_06 JRE d’installé (et qui fonctionne également très bien).
Par contre, lorsque je vais sur une page contenant un applet Java, Mozilla ne peut l’afficher (pas la page, seulement l’applet).

J’ai donc Mozilla et la machine Java installé de leur côté et qui fonctionnent très bien mais ils ne veulent pas bosser ensemble

Dans ma page des plugins Mozilla (about:plugins), il n’y a aucun plugin Java de detecté…

Comment faire ?

Bonsoir,

Désinstallez proprement la 1.4.2 et recherche dans explorateur si il reste d’anciennes versions.
Prendre la dernière version et mise à jour, allez sur la première ligne pour télécharger le minimum
[JAVA SUN]
Options Web Dans Moz config:[Java)
@+

Donc il est impossible de faire fonctionner la 1.4.2_06 JRE avec Mozilla ??

Bonjour,

Je ne sais pas, je n’ai pas essayé, de toute façon mettez à jour!
@+

:stuck_out_tongue: ça fonctionne chez moi mais avec FFox j’ai la mm version, par contre elle apparait bien dans about : plugins et dans Options
about : plugins — Java Plug-in (oups! édit p+: ça fait un smiley-tire-la-langue? …)
Nom de fichier : NPJava11.dllxxx.xxxxx
Java Plug-in 1.4.2_06 for Netscape Navigator

tu devrais regarder sur le Forum Mozilla/Gecko ça ne manque pas de question sur Java - ça m’étonne cette incompatibiité…
http://www.geckozone.org/forum/viewforum.php?f=12&sid=7ae33320b3c4cb9014f7b4a00d72463b

Si je peux faire marcher ma version actuelle de Java, je ne vois pas pourquoi je mettrais à jour :pfff:

westernunion > Tu as dû récupérer un fichier à part, spécialement conçu pour être un plugin FF/Moz ou bien est-ce que tu as, comme moi, installé le “Java 2 Runtime Environment, Standard Edition 1.4.2_06 JRE” (fichier .exe d’installation pesant 14,9Mo) et que FireFox l’a tout de suite integré dans ses plugins (pas comme moi là par contre) ?

Bjr,
Un fil de discut:JAVA
@+

:)- aucun problème de reconnaissance, j’ai d’abord désinstallé mon ancienne version de SUN, téléchargé la nouvelle 1.4.2_06 JRE et la prise en compte s’est faite après redémarrage

  • regarde si tu n’as pas un conflit de versionSet si dans tes options internet/avancé : “utiliser Java de SUN…” est bien coché et toutes les références Java Micrsosoft VM bien décochées

J’ai finalement trouvé un fichier “” dans le sous dossier bin/ de mon JRE 1.4.2_06 que j’ai mis dans le sous dossier plugins de Mozilla et j’ai les lignes suivantes dans “about: plugins” :[quote=""]
Nom de fichier : NPJava11.dll
Java Plug-in 1.4.2 for Netscape Navigator (DLL Helper)
application/x-java-applet;version=1.1.1 Java Applet Oui
application/x-java-bean;version=1.1.1 JavaBeans Oui
application/x-java-applet;version=1.1 Java Applet Oui
application/x-java-bean;version=1.1 JavaBeans Oui
application/x-java-applet Java Applet Oui
application/x-java-bean JavaBeans Oui
[/quote]

Mais je remarque qu’il n’y a pas de “application/x-java-vm” ?? :frowning:

:slight_smile: Nom de fichier : NPJava11.dll <-- tu n’as que ça??

le mien/Java Plug-in
Nom de fichier : NPJava11.dll<–ok
Java Plug-in 1.4.2_06 for Netscape Navigator (DLL Helper)
plus…je mets pas tout les détails
Nom de fichier : NPJava12.dll
Java Plug-in 1.4.2_06 for Netscape Navigator (DLL Helper)
Nom de fichier : NPJava13.dll
Java Plug-in 1.4.2_06 for Netscape Navigator (DLL Helper)
Nom de fichier : NPJava14.dll
Java Plug-in 1.4.2_06 for Netscape Navigator (DLL Helper)
Nom de fichier : NPJava32.dll
Java Plug-in 1.4.2_06 for Netscape Navigator (DLL Helper)
Nom de fichier : NPOJI610.dll
Java Plug-in 1.4.2_06 for Netscape Navigator (DLL Helper)
application/x-java-vm<–
Nom de fichier : NPJPI142_06.dll
Java Plug-in 1.4.2_06 for Netscape Navigator (DLL Helper)

désintalle la version et réinstalle-là - elle semble incomplète

En effet, je les avaient tous mis dans Mozilla, à l’exception de “NPOJI610.dll” que j’avais oublié :smiley:

Maintenant, j’ai bien " Nom de fichier : NPOJI610.dll
Java Plug-in 1.4.2 for Netscape Navigator (DLL Helper)
application/x-java-vm Java Virtual Machine for Netscape", mais malheuresement, les applications Java des sites Internet ne marchent pas plus, j’ai toujours le “Click here to get the plugin”…

:up: ?

ta essayé java 1.5 ?