Forum Clubic

Monter une partoche ext avec les bons droits pr 1 group ?

Salut, je merdoie sévère à configurer /etc/fstab pour que les users membres du bon groupe puissent lire/écrire dessus

Le gid du bon groupe = 500, donc je pars sur un ‘gid=500,umask=017’ ou dérivés genre :
[fixed]/dev/hda12 /la_partoche ext3 gid=500,umask=2,user 1 2[/fixed]
–> impossible de la monter avec le message qui va bien :
[fixed]mount: type de sys. de fichiers erroné, option erronée, super bloc erroné sur /dev/hda12, ou trop de systèmes de fichiers montés[/fixed]

SVP comment la monter pour que les users membres du bon groupe aient les droits rw dessus ?

Personnellement j’ai trouvé une méthode simple (pas prise de tête) :

[fixed]aloth@hammer ~ $ cat /etc/fstab | grep vfat
/dev/hda5 /mnt/dfat vfat defaults,users,umask=0 0 0
/dev/hda6 /mnt/efat vfat defaults,users,umask=0 0 0
/dev/hda8 /mnt/media vfat defaults,users,umask=0 0 0[/fixed]

Marche pas sur les partoches non-vfat, equi-Nox

[EDIT:] Y-a plus le message d’erreur mais les users (dont le mien) n’ont pas les bons droits (par ex créer/copier un fichier sur cette partoche (même à la racine))

Précision l’une des partoches en question est celle du serveur —> droits importants

Ah oui je croyais que c’était pour du vfat…

Dans ton cas il suffit un “chmod 770” sur le /la_partoche et d’un “chgrp /la_partoche”.

Mon /home est en reiserfs et j’ai aucune option “spéciale” qui y correspond dans le fstab.

vi, ça semble fonctionner
càd que ls -l indique les bons droits sur la partoche,
mais je peux pas y accéder bien que je fasse partie du bon groupe
Je vérifie ça (faut pas se délogger pour obtenir les droits de ses nouveaux groupes, si ?)

““faut pas se délogger pour obtenir les droits de ses nouveaux groupes, si ?””

Je crois pas (jamais essayé je dois dire).

T’es bien en 770 (drwxrwx—) sur ce dossier ?

(hum! parti dinner)

Ça marche après m’etre dé/reloggé

vivi, enfin 744 ou 754 (selon fichiers) exactement.

Et /etc/fstab doit comporter uniquement ‘default’, sans ‘user’ etc
because user: Allow an ordinary user to mount the file system. This option implies the options noexec, nosuid, and nodev (unless overridden by subsequent options, as in the option line user,exec,dev,suid) —> http://www.linuxfromscratch.org/lfs/faq.html#bad-interpreter-permission-denied