Forum Clubic

Monter une partition de données

Bonjour,

J’ai sur mon PC une partition Windows, une partition Ubuntu et une partition de données (“Disque Données” ; sda4). La partition de données est en ntfs et se monte sans problème sous Ubuntu en cliquant sur le Raccourci.
Cependant j’aimerais bien qu’elle se monte au démarrage:P
Après avoir lu de la doc j’ai compris qu’il fallait éditer le fstab, mais j’ai du mal avec les options à mettre et à quoi elles correspondent:(
J’ai tenté :
/dev/sda4 /media/Disque Données ntfs defaults 0 0
Mais ça ne marche pas, je ne pouvais même plus monter la partition après:(

Voici les infos sur mes partitions :

Mon fstab :

/etc/fstab: static file system information.

Use ‘vol_id --uuid’ to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

proc /proc proc defaults 0 0

/ was on /dev/sda5 during installation

UUID=012991fb-212a-44b4-9ddc-785d33994e65 / ext3 relatime,errors=remount-ro 0 1

swap was on /dev/sda6 during installation

UUID=230010e6-85a5-4ce4-9476-a8809de8095b none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

Infos sur le disque :

Disque /dev/sda: 164.6 Go, 164696555520 octets
255 têtes, 63 secteurs/piste, 20023 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Identifiant de disque : 0xbbc8bbc8

Périphérique Amorce Début Fin Blocs Id Système
/dev/sda1 * 1 13 102400 7 HPFS/NTFS
La partition 1 ne se termine pas sur une frontière de cylindre.
/dev/sda2 13 2678 21401600 7 HPFS/NTFS
La partition 2 ne se termine pas sur une frontière de cylindre.
/dev/sda3 2679 5354 21494970 5 Etendue
/dev/sda4 5355 20023 117825536 7 HPFS/NTFS
La partition 4 ne se termine pas sur une frontière de cylindre.
/dev/sda5 2679 5237 20555136 83 Linux
/dev/sda6 5238 5354 939771 82 Linux swap / Solaris
florian@PC-FLO:~$ sudo blkid
/dev/sda1: UUID=“3A3AFC313AFBE831” LABEL=“System Reserved” TYPE=“ntfs”
/dev/sda2: UUID=“604E4DB24E4D8230” TYPE=“ntfs”
/dev/sda4: UUID=“BE2CEA6D2CEA205F” LABEL=“Disque DonnM-ies” TYPE=“ntfs”
/dev/sda5: UUID=“012991fb-212a-44b4-9ddc-785d33994e65” TYPE=“ext3”
/dev/sda6: TYPE=“swap” UUID=“230010e6-85a5-4ce4-9476-a8809de8095b”

Commande Mount :

/dev/sda5 on / type ext3 (rw,relatime,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
lrm on /lib/modules/2.6.28-13-generic/volatile type tmpfs (rw,mode=755)
securityfs on /sys/kernel/security type securityfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/florian/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=florian)
/dev/sda4 on /media/Disque Données type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)

Ca ne fonctionne pas car le chemin /media/Disque Données n’est pas reconnu par GNU/Linux.
Le “fstab” croit que le mot “Données” est une option (à cause de l’espace dans le nom).

En fait, c’est une aberration de mettre des espaces et des caractères spéciaux dans un nom de fichier ou de dossier. C’est une très mauvaise habitude amené par Micros*ft et il faut maintenant, sous Ubuntu (et GNU/Linux en général), la perdre.

Je te conseille donc de renommer, sous w*ndows, ta partition de données en mettant un nom sans espace ni c.p… Puis de rééditer ton fichier /etc/fstab.


J'ai dit une demi-bêtise, je suis allé trop vite ...

Pas la peine de renommer ta partition sous w*ndows, il te suffit sous Ubuntu de recréer un nouveau point de montage où sera monté ta partition.
Toi tu l’avais mis dans le dossier /media/Disque Données, tu avais donc créé le dossier “Disque Données” dans le répertoire /media.
Je te conseille de le créer dans le dossier /mnt (nom sans espace ni cp toujours).

Pas d’intérêt à monter dans /mnt, les médias externes comme ton disque seront mieux dans /media (et tu auras comme ça un raccourci direct vers le disque dans ton gestionnaire de fichiers).

En fait, tu ne peux pas avoir de nom de dossier avec un espace dans le fstab, c’est *** mais c’est comme ça, donc tu peux le renommer sans espace (et si tu tiens à garder le nom “Disque Données”, monte ton disque vers /media/dd et fais un lien de dd vers “Disque Données” (ln -s dd “Disque Données”)).

un aberration de donner des noms clair dans notre langue aux fichiers/dossiers ? :heink:

moi, au lieux de me faire chier à codifier le nom de mes fichiers dans 8+3 caractères ascii, je met des quotes autour ou j’echappe les espaces dans les fichiers de config ou le shell.

Mais son problème n’est pas lié à ça, mais simplement parce que les partition “non système” sont gérées non pas par fstab, mais hal
d’ailleurs, le point de montage est créé à la volée dans /media en fonction du label de la partition.
Et je suis quasi certain qu’il peut se regler avec un clique droit sur son icone dans le poste de travail

Sors de ta grotte Gabe, on est en 2009 :icon_biggrin:
Edité le 06/07/2009 à 20:19

Sauf qu’il est parfois plus pratique de mount une partition au lancement du système qu’après le lancement de la session (exemple con : je lance FF au démarrage de ma session et FF utilise mon profil sur mon HDD NTFS, ou j’utilise un wallpaper sur un disque NTFS). Alors bon c’est sûr qu’il y a souvent mieux que d’utiliser un disque NTFS, mais c’est quand même bien à monter au lancement du système que sert fstab, non ?

J’ai renommé ma partition “DONNEES” et ça marche nickel! (par contre les logiciels sous Ubuntu qui accédaient à la partition sous l’ancien nom n’ont pas suivi automatiquement le nouveau nom, j’ai du changer certains paramètres)

Merci bien pour vos réponses:super:

D’où l’intérêt des liens symboliques pour tes anciennes applications :wink: fr.wikipedia.org…