Forum Clubic

Montage automatique - Ne marche plus apres nv noyau

Salut à tous !!

Je viens de recompiler mon noyau et tout marche super bien. A un détail pres.

Lorsque je veux monter un lecteur dvd ou cle usb pas de problème. Je peux accéder aux fichiers.

Mais des lors que je veux un montage automatique (c’est plus pratique quand meme ) je recois le message
Impossible de monter le périphérique.
L’erreur signalée est :
mount: ne peut repérer /dev/*** dans /etc/fstab ou /etc/mtab

autofs démarre avec le systeme.

Voici /etc/fstab :

/dev/hde2 / reiserfs acl,user_xattr 1 1
/dev/sda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sda5 /windows/D ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hde1 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/hda /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,user,exec,iocharset=utf8 0 0
/dev/dvdrecorder /media/dvdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,user,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0

voici /etc/auto.misc

$Id: auto.misc,v 1.2 2003/09/29 08:22:35 raven Exp $

This is an automounter map and it has the following format

key [ -mount-options-separated-by-comma ] location

Details may be found in the autofs(5) manpage

cd -fstype=iso9660,ro,nosuid,nodev :/dev/cdrom
dvd -fstype=auto,ro :/dev/dvd
usb -fstype=auto,rw :/deb/sdb1

the following entries are samples to pique your imagination

#linux -ro,soft,intr ftp.example.org:/pub/linux
#boot -fstype=ext2 :/dev/hda1
#floppy -fstype=auto :/dev/fd0
#floppy -fstype=ext2 :/dev/fd0
#e2floppy -fstype=ext2 :/dev/fd0
#jaz -fstype=ext2 :/dev/sdc1
#removable -fstype=ext2 :/dev/hdd

voici /etc/auto.master :

$Id: auto.master,v 1.4 2005/01/04 14:36:54 raven Exp $

Sample auto.master file

This is an automounter map and it has the following format

key [ -mount-options-separated-by-comma ] location

For details of the format look at autofs(5).

#/misc /etc/auto.misc --timeout=60
#/smb /etc/auto.smb
#/misc /etc/auto.misc
#/net /etc/auto.net
/media /etc/auto.misc

Je viens de recompiler mon noyau, manquerait il un module puisque cea fonctionnait sans aucun problème avant ?

Merci

Je viens de réinstaller autofs et il ne veut plus se lancer.

Il me dit :

Starting service automounter ("files nis" does not provide any mounts)skipped

voici ce que me retourne tail -f /var/log/messages quand je branche une cle usb :

Mar 5 19:53:41 linux hal-subfs-mount[8920]: SYMLINKS:: disk/by-id/usb-Packard_Portable_Player_0002F5C4DC6C8E8F disk/by-path/usb-0002F5C4DC6C8E8F:0:0:0
Mar 5 19:53:41 linux hal-subfs-mount[8920]: MOUNT_POINT:: /media/usbdisk
Mar 5 19:53:41 linux hal-subfs-mount[8920]: MOUNTPOINT:: /media/usbdisk
Mar 5 19:53:41 linux hal-subfs-mount[8920]: Collected mount options and Called(8192) /bin/mount -t subfs -o fs=floppyfss,sync,procuid,nosuid,nodev,exec,utf8=true /dev/sdb1 "/media/usbdisk"
Mar 5 19:53:41 linux hal-subfs-mount[8920]: By hald-subfs-mount created dir /media/usbdisk got removed.

salut, je n’ai pas la solution à ton problème mais juste deux questions :

  1. quelle "distribution" utilises tu ? (version, mises à jour, bureau (kde ? gnome ? xfce ? autre ?), autre particularité notable…)

  2. as-tu une raison particulière de vouloir utiliser autofs pour faire tes montages automatiques et pas hal (eventuellement + dbus + "desktop volume manager") qui est la méthode adoptée par les versions récentes de toutes les distributions "populaires" et qui va certainement devenir un standard sous linux quand les versions 1.0 de ces logiciels seront sorties.

en lisant ton log, il semble bien que se soit hal qui gère cela. mais n’étant pas un spécialiste, je ne serais pas te dire ce qui cloche.

Il doit manquer des options dans le noyau relatifs à automount, nis ou hal.

Ok mais lesquelles !!

Au lancement, Linux cherche le module device_mapper mais ne le trouve pas. Ou se trouve dans la configuration du noyau ?

Merci