Forum Clubic

Metro2033 veut tuer mon pc

Bonjour à tous,
Tout d’abord j’espère que je poste ma demande d’aide dans la bonne section.

Voila je vous explique mon problème: hier j’ai fait l’acquisition de Metro 2033 et je veux préciser LEGALEMENT, je l’ai acheté sur Steam.
3h30 de téléchargement, l’installation se fait sans soucis et c’est là que commence le “stut”

1)Premier démarrage du jeu: steam installe automatiquement les petites mises à jour dont il a besoin pour faire fonctionner le jeu mais déjà première chose qui m’intrigue c’est le “Nvidia Physx” c’est sympa mais j’ai une Radeon.

2)après la mise à jour le jeu se lance et immédiatement message d’erreur qui me dit en gros “vous n’avez pas physx.dll” la bonne blague. Là je me dis que ça doit etre notre bon steam qui bug et un simple redémarrage de l’application réglera tout ça.

3)Donc je redémarre Steam et en effet le jeu se lance immédiatement mais nouveau bug: je n’ai que le son l’écran est totalement noir avec un message qui me nargue en passant de gauche a droite disant “input not supported”… mouai. Après un ALT + F4 je suis de retour sur le pc.

4)Je vais sur Steam et j’appuie sur “Vérifier l’intégrité du cahe du jeu” après quelques minutes il me dit que tout est ok donc je relance le jeu et là c’est la cata: Je n’ai plus le son j’ai toujours ce putain d’écran noir avec le message d’erreur et plus aucun moyen de retourner sur le bureau: ALF+F4 , CTRL+ALT+DEL, les prières,… non rien à faire résultat redemarrage de mon pc “à la barbare”

5)Windows (seven) se rallume mais là je ne retourne pas sur le bureau mais directement sur l’écran noir avec le même message. Donc deuxième redémarrage violent.

6)Je redémarre Windows mais en “mode sans échec” et je fais restauration, celui comme par hasard va me restaurer mon pc juste avant l’installation de NVIDIA PhysX, ben tiens comme par zazard.

Donc me voila back, mon pc refonctionne mais chaque fois que je tente de relancer le game il redémarre l’installation de NVDIA PhysX et donc de mes problèmes.

Donc je viens a vous communauté Clubicienne, auriez vous une quelconque solution? histoire que je puisse enfin essayer ce jeu.

Bon comme j’imagine que la question “ton pc est il assez puissant?” sera mise sur le tapis je préviens immédiatement:
Mon pc a un mois et voici sa belle anatomie:

Windows Seven familial 32bits
ASUSTeK P7P55D
Intel Core i5 750 2666 Mhz
4go DDR3
Radeon HD 5870

Donc je pense que je peux faire tourner le jeu.

Voila je vous remercie d’avance pour l’aide.
Peace
Edité le 19/05/2010 à 14:53

As-tu ton drivers ati mis à jour ? Car ça peut toujours aider :wink:

C’est à cause de l’ATI je pense.

Il suffit de télécharger physxloader.dll www.search-dll.com… et de le mettre dans C:\Program Files (x86)\Steam\steamapps\common\metro 2033\

Edit: pour moi ça avait suffit.

Sinon je viens de lire ceci : faut installer le physix qui est dans C:\Program Files (x86)\Steam\steamapps\common\metro 2033\install

source: forums.steampowered.com…
Edité le 19/05/2010 à 12:27

Merci pour vos réponses très rapide:
Oui ma carte ATI et tout mon matériel est à jour (j’ai encore vérifié aujourd’hui avec maconfig.com)

Alors pour ton procédé regi00 il est exact: j’ai trouvé l’installer dans le fichier steam j’ai pu installer PhysX, j’ai donc redémarré mon pc lancé le jeu: là le jeu se lance et BOUM écran noir et ce message de merde: “Input not supported” avec toujours l’impossibilité de retourner sur le bureau donc:
Redémarrage a la barbare > Mode sans Echec > Récupération > et donc désinstallation du PhysX j’ai l’impression que c’est un cercle sans fin :slight_smile:
Donc maintenant j’ai le PhysX mais je suis toujours incapable de lancé le Soft.

Bon voila après bien des recherches j’ai pu régler mes problèmes avec le jeu, je vais noter ici ce qu’il faut faire pour que tout rentre dans l’ordre pour que les autres personnes ayant les mêmes soucis trouvent la marche à suivre.

Alors Metro 2033 rencontre 2 bugs et j’ai eu la grande chance d’avoir les deux bug:

1)PhysXloader.dll

Les possesseurs de cartes ATI peuvent rencontrer ce problème, comme l’a cité plus haut regi00 il suffit d’installer ce fichier manquant pour cela il suffit:
1)éteindre complètement STEAM
2)Allez dans le fichier source: Steam\steamapps\common\metro 2033\install
3)Installer NVIDIA PhysX
4)redémarrer le jeu tout fonctionne

2)Ecran noir au démarrage avec ou sans “input not supported”
Alors ce problème est due à certains écrans d’ordinateur, Metro2033 démarre à une résolution incompatible avec votre écran donc normalement il suffit de changer la résolution du jeu… In game. Alors comment faire?
Soit vous mettez un autre écran vous allumez le jeu changez la résolution et remettez votre ancien écran (ça je n’ia pas testé)

Soit la deuxième solution: forcer le jeu à s’ouvrir en mode fenêtre, voici la marche à suivre:
1)Éteignez Steam
2)Allez dans Steam\steamapps\common\metro 2033
3)Vous trouverez le fichier user.cfg ouvrez le avec le bloc note
4)Cherchez la ligne “r_fullscreen on” et remplacez le “on” par “off”
5)Ouvrez steam puis démarrer le jeu, le jeu va démarrer en mode fenêtre, allez dans les options vidéos puis passer en directx10 (ou 11 si vous pouvez) et changez la résolution du jeu, enregistrez le tout et quitter le jeu.
6)éteignez à nouveau Steam
7)ouvrez à nouveau le fichier user.cfg et remettez la ligne en “on” enregistrez.
8)Allumez Steam et appuyez sur “Vérifier l’intégrité du cache du jeu”
9)une fois terminé vous pouvez enfin jouer au jeu dans les meilleures conditions

Voila le sujet peut être clos merci pour l’aide et en espérant avoir aidé aussi
Edité le 19/05/2010 à 14:50

J’ai eu le problème du PhysXloader.dll ( et j’ai une carte ati ), j’ai désinstallé physx, passé un coup de Ccleaner et Glary utilities, redémarré, réinstallé physx ( fourni dans le dossier du jeu ) > et ça a marché
:slight_smile:

Merci Nikostarama pour les informations :jap:

Merci pour tes conseils… quand j’aurai le jeu :wink:

D’ailleurs, tu nous diras ce que t"en pense ! J’attends avant de l’acheter…

J’espère également qu’une mise àjour du jeu sera effectuée afin de corriger ce 2e problème, car c’est particulièrement nul comme bug (ils n’auraient pas pu tester plus de résolutions ?)

salut à tous, je ressort un peu les vieux dossier mais j’ai acheté Metro 2033 sur steam et , sans surprise, j’ai le problème d’écran noir au démarrage avec mon écran qui m’affiche " résolution non optimal 1600*900 conseillé " en se baladant en diagonale… J’entends le son des chargements et les bruitages lorsque mon curseur se promène (invisible évidemment ) sur les objets du menu.

J’ai fais comme tu as dis pour mettre le jeu en mode fenêtre mais impossible, dès que je relance steam et le jeu, il me met en full screen et impossible de modifier quoi que ce soit.

J’ai déjà fait pas mal de forum, certains donnant même des patchs mais dont l’effet est inexistant…

Je commence vraiment à m’énerver, surtout que sur le site officiel il n’en parle même pas… S’il y a bien quelque chose que je déteste c’est gaspiller mon argent… 35€ pour un écran noir ça commence à bien faire !!!

Je tourne sur windows XP par contre ( donc pas de direct x 11 )

As-tu essayé d’aller voire comment changer la résolution dans les fichiers même du jeu ?

C’est bizarre que cela ne fonctionne pas normalement la solution que je donne est celle préconisée sur le officiel:

Vérifie bien que tu as bien tout fait dans l’ordre, que tu as bien modifié la bonne ligne, que tu n’as pas fait une faute de frappe et surtout que tu as enregistré tes modifs!!!

Si jamais ça ne fonctionne tjr pas fait l’échange d’écran: emprunte un écran d’une autre marque et allume ton jeu normalement ça fonctionnera car le bug est du à une incomptabilité entre le jeu et certains écrans. Donc tu auras accès au menu et tu pourras changer ta config.

J’espère que tu pourras jouer à ce magnifique jeu

après avoir fait les manip de la 2eme solution proposées par Nikostarama. Dans les option de jeu il faut décocher “effet physX”.
sinon le problème revient. :wink:

Je crois que que le temps que tu répondes, Metro 2033 a eu sa peau… :jap: