Forum Clubic

Message d'erreur au boot lors du montage des disques

Bonjour,

Je vous décris mon problème : j’ai 5 disques durs dans ma machine : 3 en IDE directement connectés sur ma carte mere, et 2 sur une carte controleur IDE en PCI.

Tous les disques sont reconnus, et montés via un tout petit script de demarrage :

[cpp]#!/bin/bash
mount /dev/hdc1 /mnt/share/hd1
mount /dev/hdb1 /mnt/share/hd2
mount /dev/sdb1 /mnt/share/hd3
mount /dev/sda1 /mnt/share/hd4
mount /home/hd5 --bind /mnt/share/hd5[/cpp]

En analysant plus en profondeur :
[cpp]root@xxxxx # dmesg | grep warning
EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended
EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended
EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended[/cpp]

Comment palier à ce problème ? Le fait de faire un e2fsck avec correction automatique des erreurs (bad blocks) ne va pas engendré la perte de mes données sur les disques en question ?

Merci d’avance pour vos réponses attendues avec grandes impatience. Ah en fait, j’oubliais, je tourne avec un noyau 2.4.21

Bonne journée.

[fixed]maximal mount count reached, running e2fsck is recommended[/fixed]

Tous les 30 montages (valeur par défaut, cf “tune2fs --help”), Linux vérifie le contenu des disques quand ceux-ci sont montés par la procédure normale (c-à-d avec les scripts fournis par la distribution + fstab). C’est juste une vérification de routine et ne pas l’effectuer n’affecte en rien le bon fonctionnement du système. Si tu fais un e2fsck, et que tu n’as pas fait de bêtises avec tes disques (arrêt normal du système ou bien penser à démonter avant de débrancher), ça ne craint rien.

Il n’y a aucun problème dans ces messages. C’est écrit “Warning” et non pas “Kernel Panic” :stuck_out_tongue:

Je ne comprends cependant pas pourquoi tu as fait un script à part…

Tous simplement pcq lorsque j’ai renseigné fstab, une erreur apparaissait au demarrage : too much file system mounted

Du coup il ne montait pas 1, voir 2 disques. Il fallait que je le monte manuellement:
[cpp]root@xxxxx # mount /dev/sda1 /mnt/hd3
root@xxxxx # mount /dev/sdb1 /mnt/hd4[/cpp]

Du coup, j’ai préféré faire un script qui me monte tous les disques supplémentaires, et dans l’orde que je le veux.

Donc tune2fs permet entre autre d’allonger le nombre de fois ou les disques sont monté ? Un truc du style :
[cpp] tune2fs -l /dev/hdb1 -c max-mounts-count 70 [/cpp] ?? Le chiffre correspond à quoi ? un nombre de jours ?

Pour enlever les warning, qu’elles options faut-il donné à e2fsck ?
Voici ce que j’ai en faisant un tune2fs sur un des disques qui est “not clean”:

[cpp]tune2fs 1.32 (09-Nov-2002)
Filesystem volume name:
Last mounted on:
Filesystem UUID: cd8daf5b-0a33-437f-8278-6aec5080b11c
Filesystem magic number: 0xEF53
Filesystem revision #: 1 (dynamic)
Filesystem features: filetype sparse_super
Default mount options: (none)
Filesystem state: not clean
Errors behavior: Continue
Filesystem OS type: Linux
Inode count: 15007744
Block count: 30013428
Reserved block count: 1500671
Free blocks: 1520609
Free inodes: 15007550
First block: 0
Block size: 4096
Fragment size: 4096
Blocks per group: 32768
Fragments per group: 32768
Inodes per group: 16384
Inode blocks per group: 512
Filesystem created: Wed Feb 9 09:15:30 2005
Last mount time: Wed Feb 9 19:12:06 2005
Last write time: Thu Feb 10 21:07:09 2005
Mount count: 2
Maximum mount count: 32
Last checked: Thu Feb 10 20:58:48 2005
Check interval: 15552000 (6 months)
Next check after: Tue Aug 9 21:58:48 2005
Reserved blocks uid: 0 (user root)
Reserved blocks gid: 0 (group root)
First inode: 11
Inode size: 128[/cpp]

Tous les autres disques sont “clean”. Pour enlever les warning, qu’elles options faut-il donné à e2fsck ?

Tu es sûr que tu ne t’es pas planté en faisant ton fstab ? Parce que Fstab fonctionne avec la commande mount… Un erreur de syntaxe produit souvent ce genre d’erreur (es-tu sûr d’avoir indiqué les bons systèmes de fichiers ???)

Ca correspond au nombre de montage.

Les warning ne viennent pas de e2fsck mais du noyau. Ca n’a rien à voir. Et le seul moyen de les éviter est de faire les fsck. Mais que tu les fasse ou non, ça ne change rien au bon fonctionnement du systeme.

Ok, je comprends un peu mieux tout ca … je vais donc lancer des fsck et voir ce que ca donne au boot.

Bonne journée.

et pourquoi tu les mountes pas via le fstab ? normalement il gère tout seul ce genre de trucs (qui peut être parametré dans la ligne du disque ans le fstab)