Forum Clubic

Menu contextuel incomplet lors de l'exploration d'un DD externe

Bonour,

je viens de réinstaller vista sur mon laptop et je me rend compte que lorsque que “j’explore” mon DD externe, je n’ai plus accès aux principales fonctions du menu contextuel telles que “supprimer, couper…” (aucun problème lorsque je suis sur le DD interne)
Voici un screen si ce n’est pas très clair : img193.imageshack.us…

J’ai déjà regardé un peu partout dans les options des dossiers ainsi que sur le net, mais sans succès mis à part un sujet sur un site où un utilisateur avait conseillé à la personne qui avait ce problème de réinstaller Vista, ce que j’aimerais éviter.

J’accepterais volontiers toute aide que vous pourrez m’apporter.
Merci d’avance.

Romain

Bonsoir

Il y a de forte chance que ton disque (ou au moins le répertoire ou fichier) soit en lecture seule.

Koin-Koin

Salut merci pour ta réponse,

En fait le disque et ses dossiers sont bien en lecture seule (c’est la première chose à laquelle j’ai pensé aussi)mais je n’ai aucun moyen de changer cela. Lorsque je vais dans les propriété, l’option “lecture seule” est grisée et lorsque je change l’option tout se passe normalement (on voit la petite fenêtre de changement d’attribut ainsi que la barre de progression) mais lorsque je reclic sur le fichier, l’option “lecture seule” est de nouveau cochée et toujours grisée (screen :http://img12.imageshack.us/img12/1171/image2jv.jpg). J’ai déjà essayé la méthode qui consiste à passer par l’invite de commande DOS et à changer les attributs avec attrib -r, mais rien n’y fait.

De plus, sur un autre poste équipé de Vista, bien que cette option soit cochée et grisée, je peux tout de même accéder à ces options du menu contextuel ainsi que supprimer, couper et renommer mes fichiers sans aucun problème, même chose sous XP (toujours sans rien changer dans les propriété). J’ai d’ailleurs lu sur le site de Microsoft que Vista mettait plus ou moins tous seuls les fichiers en lecture seule et que cela n’était pas sensé poser le moindre problème. D’autant plus qu’en général lorsque un fichier est en lecture seule, les options ne disparaissent pas, Windows se contente de renvoyer un message d’erreur, non ?

En tout cas merci de te pencher sur mon problème

edit : je m’étais trompé dans l’adresse de l’image
Edité le 16/09/2009 à 01:13

Grisé comme ça, ça veut dire que certains fichiers du dossier sélectionné sont en LS, mais pas les autres.

Essaie de décocher cette case quand même, pour voir ce que ça donne…

Gné ? :heink:

Jamais entendu parler d’un truc pareil… Tu dois parler de certains fichiers systèmes (Registre), qui sont effectivement dans ce cas, mais ça ne vaut pas pour des fichiers persos !

Re,

Je rajoute 2 screens pour bien montrer que je peux sans problème réaliser cela sur une autre machine sans avoir besoin de changer quoique ce soit dans les propriétés : img44.imageshack.us… (la case est pleine au lieu d’être grisée car j’ai désactivé toutes les options d’affichage de vista sur mon laptop, mais cela revient au même).

J’ai également vérifié et je n’ai pas ce problème avec mes autres DD externes ainsi qu’avec mes clefs usb…

Je comprend de moins en moins :frowning:

Désolé j’ai mis trop de temps à écrire mon message et j’ai loupé ton message. J’ai surement mal compris ce que j’ai lu sur le site de microsoft mis ça ne change rien, cette case ne se décoche pas, quoique je fasse et elle reste cochée/grisée.
Edité le 16/09/2009 à 01:51

En fait ton problème est lié au fait de la gestion différente des droits de sécurité entre NT/2000/XP et Vista/7.

Vista et 7 propose de donner accès en lecture seule pour des données dont les droits sont définis pour des comptes n’existant pas sur la machine (disque externe)

Le plus simple serait de copier toute le disque sur un XP, de formater le disque externe, puis de tout recopier dessus sans aucun droits.

Le problème s’est réglé seul en désactivant puis en réactivant le port usb en question, j’ai de nouveau accès au menu contextuel… J’aurais pu essayer plus tôt. Il reste toujours cette lecture seule. Mais je vais effectivement faire un gros ménage sur mon dur puis le reformater depuis vista pour éviter un éventuel problème à l’avenir.

Merci à tous d’avoir participé. Bonne continuation.