Forum Clubic

Media Player Classic : sous titres incrustés

Bonjour a tous !

Voila, j’ai un ptit souci avec Media Player Classic. Hier, j’ai regardé un film (Mon Film Préféré), et en fait les sous-titres sont intégrés au film (enfin on dirait) et du coup c’était impec (mais ils étaient même en double :??: (problème que j’ai réussi à regler je sais plus comment).

Par contre aujourd’hui j’ai voulu le revoir, et pas moyen de remettre la main sur les sous-titres (que je pensais pourtant incrustés, car je n’ai PAS de fichier de sous titres a part)

Quelqu’un aurait il déjà rencontré ce PB ?
Quelqu’un a-t-il la solution pour re-afficher les sous titres ??

Merci beaucoup de votre aide,

Lideln

Salut,

Si ton film est un AVI, tes sous-titres n’étaient pas incrustés, sinon faisant partie intégrante de l’image il seraient toujours visible (recherche un fichier portant le même nom que ton film mais avec une extension .srt ou .ssa.
Mais ton film est peut-être un MKV ou un OGM et dans ce cas les sous-titres sont incorporés (on dit muxés) dans le container et activable ou non.

D’ailleurs, le fait qu’ils se soient affichés en double me fait penser à des sous-titres joints et affichés en même temps par MPC (qui les gèrent en natif) et par le filtre directshow Vobsub.

C’est exactement le probleme en effet, j’ajoute une chose tout de meme :
par une bidouille on peut mettre un srt dans un avi sans pour autant le hardcoder.

Mais je penche plutot vers un mkv et une couille avec le filtre matroska (ca arrive relativement souvent)

j’ai déjà eu ce problème +sieurs fois. tu cliques droit dans mpc et dans le menu tu vas dans VobSub et tu cliques sur disable

Salut !

Tout d’abord, merci pour vos réponses. :jap:
Le film est bien un .avi, et je n’ai aucun fichier .srt, .sub ou autre à côté.

En ce qui concerne matroska ou vobsub, j’ai bien essayé de faire bouton droit dans MPC, mais pas de vobsub à l’hroizon, pas plus d’ailleurs dans le menu “Options” (et “Filters”).

Ou faut il aller exactement pour désacter ce vobsub ?

Merci de votre aide,

Lideln

Eureka ! Enfin pas tout a fait, mais presque.

En fait, j’ai voulu charger des sous titres tcheques (qui se sont révélés etre francais… !!!), et ca a ajouté une icone (qui bien sur n’y était pas avant) en fleche verte dans la barre des taches (l’icone de vobsub). Ca a affiché, dans le film, DEUX fois les sous titres francais.

Donc en gros ce que j’en déduis, c’est que si je veux les sous titres incrustés, faut que je lance vobsub ? Ca je le savais pas, je pensais que c’était dans la vidéo…

Alors comment lancer vobsub svp ? je l’ai pas trouvé dans mon pack.
Si c’est possible de le lancer au démarrage de MPC, c’est encore mieux :slight_smile:

Merci a vous,

Lideln

Salut,

Il faut entendre par “sous-titres incrustés” des sous-titres qui font partie intégrante de ta vidéo (une partie de l’image elle-même). Donc ces st toujours affichés, il ne peuvent pas être enlevés.
Contrairement au MKV, l’AVI ne peut contenir de fichier de st séparé de la vidéo.
Pour avoir des st désactivables avec un AVI, ils doivent être présent dans le même dossier que la vidéo et portés le même nom que celle-ci (extension à part bien sur). Dans ce cas et si Vobsub est bien installé, l’icon de vobsub apparait dans la systray et les sous-titres sont affichés.
BSPlayer ou MPC peuvent charger à la demande des st à un autre endroit et portant un nom différent.
C’est se qui s’est passé chez toi:
1 - St incrustés dans ta vidéo (et donc toujours affichés)
2 - les st que tu a chargés et qui ont été affichés par Vobsub.

Salut !

Oui, on dirait que c’est un peu ca qui s’est passé, sauf que avant d’avoir les deux sous-titres (ensuite j’en ai désactivé un des deux en faisant clic doit), j’en avais aucun, donc ils étaient pas incrustés je pense ?

Si ca se toruve, le moment ou j’en avais deux et que je comprenais pas, c’est ptet que j’avais dl un .srt, et que mpc l’a chargé sans me demander… C’est ptet pour ca que je pensais ne rien avoir chargé…

Quoi qu’il en soit, j’ai maintenant un peu mieux compris les choses, grace a vous tous.

Alors merci encore !

Lideln