Forum Clubic

Mandriva Free 2007 + dongle XG 760a (livebox)

Bonjour,

J’ai suivit le tutorial de la page :
http://www.siteduzero.com/tuto-3-12447-1-installer-la-livebox-sagem-de-wanadoo-sous-mandriva-2007-de-linux.html

J’ai rencontrer quelques problèmes mais je les ai réglé (enfin je pense) !

Je me suis arrêter ici :

Quand je tape : “ndiswrapper -m”
on me dis :

[root@localhost Drivers]# ndiswrapper -m
module configuration contains directive install usb:v0CDEp0006d*dc*dsc*dp*ic*isc*ip* /sbin/modprobe ndiswrapper
;you should delete that at /usr/sbin/ndiswrapper line 864, <MODPROBE> line 190.
module configuration contains directive install usb:v0CDEp0008d*dc*dsc*dp*ic*isc*ip* /sbin/modprobe ndiswrapper
;you should delete that at /usr/sbin/ndiswrapper line 864, <MODPROBE> line 191.
module configuration already contains alias directive

Précèdemment si je tape : “ndiswrapper -l”
on me dis :

[root@localhost Drivers]# ndiswrapper -l
wlanuig : driver installed

Mais il manque “hardware …” il me semble :confused:

Sinon voici mon kernel :

[root@localhost Drivers]# rpm -qa | grep kernel
kernel-source-stripped-2.6.17.13mdv-1-1mdv2007.1
kernel-2.6.17.13mdv-1-1mdv2007.1
kernel-latest-2.6.17-13mdv

Je précise que rien n’est jour car pas de connexion à internet :stuck_out_tongue: sauf ndiswrapper bien sur ^^
Je précise aussi que je débute sous linux (expliquer ce que fait chaque commande merci) et que toute aide est la bien venus :wink:

J’espère avoir donner assez d’explications sinon demander !

PS :

[root@localhost Drivers]# lsusb
Bus 003 Device 002: ID 079b:004a Sagem
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 046d:08b2 Logitech, Inc. QuickCam Pro 4000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

Edité le 27/06/2007 à 16:19

Alors ??

SVP j’aimerai avoir ma connexion avant noël !

Merci d’avance …

pour savoir quel kernel tu utilises réellement tu peux aussi taper la commande : uname -a

Sinon si tu tape modprobe ndiswrapper, que se passe-t-il?
Peux-tu poursuivre avec la phase de configuration de l’interface réseau de ta carte wifi?

Déja merci pour la réponse ;),

Si je tape “modprobe ndiswrapper” ca me dis rien !
C’est normal non ? car dans le tuto on remarque que la commande n’ammène pas de ligne de code …

Si je continue, malgrès les erreurs qui apparaissent quand je tape “ndiswrapper -m”, je me retrouve à configurer le centre de controle mandriva :

“GlobespanVirata | USB Device” n’apparait pas (pas si grave dapres le tuto !)

Ensuite si je met “Utiliser le pilote ndiswrapper wlanuig” on me dis “Aucun matériel supportant trouvé” (un truc comme ca)

Merci pour la commande :wink:

D’après ce que je viens de voir pour une fedora, peux-tu mettre le contenu des fichiers /etc/modprobe.d/ndiswrapper et /etc/modprobe.conf
Normalement il te suffira de supprimer les lignes:

 install usb:v0CDEp0006d*dc*dsc*dp*ic*isc*ip* /sbin/modprobe ndiswrapper

du fichier /etc/modprobe.d/ndiswrapper pour que tout rentre dans l’ordre.
cf: forums.fedora-fr.org…

Sinon tu utilises quelle version de ndiswrapper? La 1.47 est sortie en ce mois de juin, donc peut être à tester si tu peux.

Et reinstalle peut etre le pilote, car le ndiswrapper -l, ne liste pas le hardware correspondant au pilote.
Edité le 28/06/2007 à 15:06

Moi ma distribution c’est Mandriva c’est pas grave ?
Sinon diswrapper c’est la derniere (1.47 stable) !

Oui ndiswrapper -l ne liste pas le hardware je pense que la est le problème !

Quel est la manip pour désinstaller proprement le pilote et celle pour le remettre ? Merci

EDIT : j’ai ces 3 lignes sous /etc/modprobe.d/ndiswrapper :

install usb:v0CDEp0006d*dc*dsc*dp*ic*isc*ip* /sbin/modprobe ndiswrapper
install usb:v0CDEp0008d*dc*dsc*dp*ic*isc*ip* /sbin/modprobe ndiswrapper
alias wlan0 ndiswrapper

Dois-je supprimer les 3 ou seulement la 1ère ?
Edité le 28/06/2007 à 16:32

Seulement les 2 premieres.

Pour désinstallé un pilote, il me semble que c’est : ndiswrapper -r monpilote

Sur la doc d’ubuntu, voila ce que j’ai trouvé:

Edité le 28/06/2007 à 16:54

Ok merci c’est fait …
Je fait quoi ensuite j’essais le centre de controle ?

Que donne ndiswrapper -l ?

Sinon c ok, regarde ce que permet de faire la suite du tuto en configurant l’interface wifi.

J’ai toujours :

wlanuig : driver installed

mais pas de hardware …

Je reprend où pour le tuto ? (dsl de la question bête mais j’évite les bétises :o))
Edité le 28/06/2007 à 17:04

Tu desisnstalle le pilote et tu le réinstalles, puis tu continues.

Ok merci j’essaye !

EDITE :

Je viens de remarquer que dans le tuto le driver se nomme WlanUIG alors que dans le tuto d’ubuntu et sur le cd (de la livebox) il se nomme WlanUZG …

C’est peut-être ça le problème ?

J’essaye l’installation avec celui là !

EDITE 2 :

ndiswrapper -i WlanUZG.inf
couldn't open WlanUZG.inf : Aucun fichier ou répertoire de ce type at /usr/sbin/ndiswrapper line 217

Ca s’annonce plutot mal je crois :o( …

EDITE 3 : C’est bon ça fonctionne (je sais pas pourquoi mais ça fonctionne :p) !!! Ce matin en laçant mon PC je me dis “On recommence encore !” j’ai donc viré tous les drivers de ndiswrapper puis j’ai remis le driver de mon cd et ops trouver le hardware … ensuite c’était facile :yeux4:

Merci pour les explications et l’aide que tu m’a apporté jeanrhum :wink:
Edité le 29/06/2007 à 12:26