Forum Clubic

Maj package sous ubuntu sans synaptic

voila j’ai besoin d’installer et de mettre a jour des packages sous une ubuntu mais le pb c’est que dans synaptic, soit elles n’y sont pas soit il me sort une vieille version comme derniere version alors que je mets a jour la liste

est ce qu’il y a un moyen pas trop complique (je debute dsl :s) de faire ca svp?

merci :slight_smile:

J’ai pas trop compris mais je crois que tu veux ça:

su
apt-get update
apt-get -y upgrade

ba en fait par exemple, je depackage un truc mais il me dit qu’il me faut libidn11 >= 0.5.2 mais lorsque je lance synaptic il me sort que j’ai la version 0.4.1-1 d’installee et qu’il n’en trouve pas de nouvelle sur le server donc il faudrait que j’installe la derniere manuellement quoi mais je ne sais pas comment faire :frowning:

tu mets bien à jour les sources (bouton “recharger” en haut à gauche dans synaptic) ?

tu utilises quels miroirs ? ceux par défaut ?

C’est quoi que t’essayes 'installer? un deb téléchargé?
Ou un logiciel dans synaptic?

Ptet que ton package est fait pour hoary?

un deb que j’ai telecharge et oui j’ai fais recharge j’ai une warty et je voulais installer pan le truc pour les newsgroups et il depend de pas mal de choses dont les dernieres version ne sont pas dans synaptic (meme des fois ils sont carement absent dans la liste)

sous linux on utilise les packages de sa distrib… on va pas chercher des trucs n’importe ou comme sous windows…

pourquoi faire simple quand on peut faire complique ? :sarcastic: :smiley: :wink:

Si tu le fais, c’est que tu connais donc tu es cense savoir resoudre les problemes de dependances.
Si la distrib que tu as choisie n’inclut pas les outils que tu souhaites alors peut etre qu’elle n’est pas adaptee a tes besoins donc il faut en changer.

Il n’y a qu’avec windows et mac os que tu n’as pas le choix… :wink: