Forum Clubic

Mad max - bug - dxgi_error_device_hung

Hello,
J’ai acheté le jeu sur Steam mais malheureusement, je ne sais pas y jouer, car je me fais éjecter vers Windows après quelques minutes avec toujours le même message “Error DirectX DXGI-ERROR_DEVICE_HUNG”.
J’ai windows 10 64 bits mis à jour, un proc. I7 4770 K, 2X8 GB RAM, avec une carte Nvidia GTX 770 OC 2 GB, et les derniers pilotes 359.06 + les mises à jour de Mad Max. Je ne comprends pas car je sais jouer à 90 % de mes jeux (le problème se pose tout de même avec les jeux Battlefield, 3, 4 et Hardline).
J’ai désactivé Steam Overlay, j’ai relancé le fichier “DXSETUP.EXE” du jeu, je l’ai aussi lancé en mode administrateur avec mode de compatibilité windows 7 ou 8, j’ai diminué la résolution, … mais rien n’y fait …
J’ai interrogé les supports de l’éditeur, WB, Nvidia et MSI, mais je n’ai toujours aucune solution.
Si quelqu’un a une idée, merci pour l’aide …

le tout premier truc a faire avec un jeu steam (ou gog) c’est de faire vérifier les fichiers du jeu
pour steam : bouton droit sur le nom du jeu -> propriétés -> dans fichiers locaux faire “vérifier l’intégrité du cache du jeu”

avec cette erreur particulière, en plus de tes tests déjà fait:

  • vérifier si poussière sur cpu et carte graphique diminue la ventilation // monitoring température cpu/gpu pour voir si truc anormal

  • se débrouiller pour limiter la vitesse du jeu pour limiter la puissance sur la carte graphique (limitation de fps max dans fichier ini/cfg du jeu ou avec outil tiers, synchro verticale ON avec limitation des fps…)
    -> en gros, a faire en 2 phases , monitoring de tes FPS quand le jeu marche, puis limiter les FPS à une valeur bien en dessous de ces FPS normaux -> si cela génère moins d’erreur remonter la limite de FPS jusqu?à en avoir a nouveau

  • baisser la fréquence du matos, en particulier sur le matos OC, quand tu utilises un jeu qui fait cela, des baisses de 50 ou carrément 100MHz pour tester si différence

a mon avis cette erreur provient du moteur du jeu (attention avec just cause 3 si tu le prends), comme le moteur de celui des battlefield il doit pousser un peu trop loin l’optimisation/rapidité en virant qq tests/conditions et envoie une action a faire alors que le gpu fait autre chose ou donne une tache qui arrive trop tot/tard par rapport a ce que fait le gpu a ce moment la, le but c’est de trouver le moyen que cela n’arrive plus ou moins souvent
-> en baissant les FPS sous les FPS normaux on donne du temps mort/de repos sur la carte graphique et baisse sa conso
-> en baissant la fréquence on change le rythme et la conso

avec un peu de chance limiter les fps suffira mais j’y crois moyen en fait
Edité le 14/12/2015 à 09:40

A mon avis ca viens du DirectX qui pose problème, tu as pensé de réinstaller ?

@Feunoir : Ok, j’avais déjà bien sûr vérifier l’intégrité du cache du jeu mais je vais essayer le conseil de limiter les FPS ou de baisser la fréquence de la carte graphique (OC d’usine) avec MSI Afterburner. Je pense plutôt à la pertinence de ton dernier avis sur le moteur du jeu. Je me trompe peut-être, mais Mad Max avec Windows 7 fonctionnerait sans doute parfaitement bien, alors que sous Windows 10 en mode compatibilité windows 7, ça ne va pas …
J’ai aussi essayé de changer dans le panneau de configuration de nvidia, les paramètres 3D, configurer Surround et PhysX, en choisissant “Processeur” pour “paramètres PhysX” et non “autosélection” mais mais …
@kaelkael : oui, comme dit dans mon premier message, j’ai relancer le DirectX dans le répertoire du jeu…

Je confirme, il fonctionne très bien chez moi (à part les nombreux bugs du jeu, mais c’est une autre histoire ^^ )

Le problème est peut-être lié à Windows 10…mais j’ai trouvé quelques sujets et il semble que cette erreur était déjà répandue en 2014 sur Battlefield 4 avec des cartes Nvidia, donc ça provient peut-être des pilotes graphiques :neutre:

battlelog.battlefield.com…

@ blackalf, en effet, le problème semblait exister avant, j’ai interrogé le support de windows 10 aussi à ce sujet et nvidia, ils ont juste la même réponse : “désinstaller les pilotes avec DDU en mode sans échec et réinstaller les nouveaux pilotes en mse aussi”. De mon côté, ça n’a rien donné.
En fait, tout est peut être lié : le moteur du jeu, les pilotes graphiques, Windows 10 et DirectX …:frowning:
Sur les forums, même avec des cartes non overclockées, le problème existe aussi …
C’est énervant, car on pourrait déceler d’où vient le problème, soit les pilotes, soit windows 10, soit …mais ce n’est pas évident.
De toute façon, merci pour les idées :slight_smile: mais résoudre ce mystère n’est pas facile !

Juste au cas où puisque le message d’erreur implique DirectX, que dit le rapport dxdiag ? pas de problème signalé ?

sur les forum il y a un commentaire qui dit qu’avec une autre carte graphique cela marchait (et son voisin/ami avait récupérer le bug donc cela venait bien de la carte graphique)
on l’oublie mais nos processus industrielles ne sont pas infaillibles, les tests en fin de chaine non plus.
Il suffit d’un truc un tout petit plus fin qu’il devrait et dans certain cas bien spécifique on aura une erreur car ce truc trop fin ne tiendra pas la fréquence.

La cause matériel est donc possible, mais c’est ce moteur de jeu et celui des battlefield qui exploitent le point faible de ces CG, ils appuient la ou cela fait mal. sur les + d’1milliard de transistor certains peuvent avoir une faiblesse face a ce moteur de jeu, manque un poil de voltage ou la fréquence est trop élevée pour eux. Je ne pense pas que les 5.4milliards de transistor de mon gpu soient tous testés, c’est un échantillonnage en plusieurs points + un test de fonctionnement basique.

bon attention quand même, je ne dis pas que dans ton cas c’est absolument ça, mais cela doit être une des hypothèses.
baisser la fréquence peut agir la dessus (certains disent qu’ils augmentent le voltage pour garder les fréquences, mais c’est moins dangereux de les baisser juste pour un jeu)
suffit de passer les fréquences a 50 ou 100MHz sous les fréquences de base d’une GTX 770 et tu seras fixé, suffira alors de trouver la bonne frequence pour les jeux qui font cela.

Ce message d’erreur est une plaie, pas assez précis, aucune solution définitive et les acteurs peuvent facilement se rejeter la faute les uns sur les autres donc personne ne fait rien pour le corriger.

avant de baisser la fréquence, il y a aussi cela a tester
forums.geforce.com…
en gros passer physx autrement
j’ai lu aussi ailleurs, message plus precis, il passe physx sur le cpu :
Open the NVIDIA Control Panel and under “3D Settings > Configure Surround, PhysX”, set the “PhysX settings Processor” to “CPU” and click “Apply”.
Edité le 15/12/2015 à 11:44

@ Feunoir : oui, c’est possible aussi que ça vienne de la carte graphique :frowning:
J’ai demandé à ce niveau une intervention de mon distributeur (un grand nom de la distribution en France qui commence par L…) et j’ai demandé juste avant les deux ans à dater de la facture. Ils m’ont répondu que ce n’est pas la date de facture qui compte, mais la date de fabrication de la carte. Une carte peut donc être facturée plusieurs mois après la date de frabrication ? Légal tout cela ?
Ceci dit, pourquoi la carte fonctionne avec 90 % des jeux et pas ceux cités …
J’ai aussi essayé le dernier conseil que j’avais trouvé, mais hélas, en vain…
Merci tout de même, je continue mes investigations :slight_smile:

Selon moi c’est la date d’achat qui compte, du moins c’est comme ça que ça se passe en Belgique :heink:

Exemple : une automobile Toyota peut avoir été fabriquée en France en Janvier 2015, son PVA d’homologation (délivré par l’importateur belge) porter la date de Mai 2015, mais si on achète la voiture en Septembre 2015…c’est 5 ans de garantie à partir de Septembre et point :neutre:

Pour ton souci, je ne sais pas s’il est possible de désactiver l’usage de PhysX, histoire de tester ? perso je ne l’ai pas puisque carte Amd ^^
Edité le 15/12/2015 à 18:13

En effet, même mieux, la garantie européenne prévoit 2 ans dès la RECEPTION du matériel, y compris celui acheté sur internet…

Pour PhysX, je sais choisir 1. AUTO - 2. GTX 770 - 3. PROCESSEUR, mais désactiver, euh, je ne vois pas ?
Edité le 15/12/2015 à 23:53

Ok, et j’ai vu plus haut que tu avais déjà essayé de passer PhysX sur le cpu, ce qui devrait décharger la carte :confused:

A tout hasard, as-tu essayé des pilotes graphiques plus anciens ?

Tu n’as peut-être pas vu ma question ^^ :

Sinon c’est moche, ça devient de plus en plus compliqué de jouer :riva:

Et à propos de Mad Max : à ma première partie, quasiment aucun souci…et puis quand ils ont déployé le patch 4 censé régler un paquet de bugs et que j’ai commencé une deuxième partie, hé ben c’est à ce moment que j’ai eu tous les bugs de la liste du correctif :nexath
Edité le 16/12/2015 à 00:47

Oui Blackalf, j’avais vu ta demande ;), mais impossible de joindre mon rapport DXDIAG sur cette discussion ou en MP (fichier joint). Comment faire ? Il est prêt …Si tu peux l’analyser, ça serait cool :slight_smile:

Sinon, oui, c’est moche, on passe plus de temps à essayer de résoudre les problèmes que de jouer, la poisse :-(:

Sinon, essayer des pilotes plus anciens pose problème car il est important de mettre à jour avec les derniers, optimisés justement pour les derniers jeux sortis, mais en effet, je parie bcp que ça pourrait fonctionner avec un ancien driver.
Et là, tu imagines, OK Mad Max ne pose plus souci, mais c’est GTA V ou Assassin’s Creed Syndicate qui en posent, bref, pas simple …:nexath
Edité le 16/12/2015 à 18:52

Il n’y a pas grand-chose à analyser ^^ si tu as l’indication “aucun problème n’a été détecté” dans les champs “remarques” de chaque onglet, c’est bon

Perso je ne me soucie pas trop des “optimisations”, je n’ai jamais vu grande différence dans un même jeu avec différents pilotes censés l’améliorer :neutre:

Il y a eu aussi des cas catastrophiques, genre les Catalyst 11.9 “spécialement optimisés” pour Rage et qui se sont révéles être les pires, ou encore Metro 2033 qui crashait méchamment avec d’autres pilotes que les 10.8…mais globalement ces cas ont quand même été assez rares, il y a même eu une période pendant laquelle je suis resté sur les mêmes pilotes pendant + d’un an ^^

Je pense avoir trouvé la solution, grâce aux judicieux conseils de Feunoir. En restant prudent toutefois, car je n’ai pas assez de recul.
J’ai baissé la fréquence du GPU OC d’usine (GTX 770 Lightning) de 20 % avec MSI Afterburner, en créant un profil uniquement pour Mad Max, et cela semble fonctionner.
Je peux y jouer en 3D grâce au fix de “Helixmod” et c’est trop génial :slight_smile:
Merci à tous :wink:
Edité le 24/12/2015 à 10:46