Forum Clubic

Ma page est différente sous IE et FF - En fait la SOURCE html change O_o

C’est super zarb comme truc !

Ma page, de forum, a un bug d’affichage sous IE, et j’avais remarqué que c’était à cause d’un tag mal fermé </tr<tr

Sous FF ma source est :

<td align="center" nowrap class="TitleCells">Board</td>
<td align="center" nowrap class="TitleCells">Posté le</td></tr><tr valign="top"><td width="18" class="MsgBG1"><img border="0" src="posticons/post.gif"></td>

Sous IE

<td align="center" nowrap class="TitleCells">Board</td>
<td align="center" nowrap class="TitleCells">Posté le</td></tr<tr valign="top"><td width="18" class="MsgBG1"><img border="0" src="posticons/post.gif"></td>

C’est quoi ce délire ? Comment une page peut être téléchargée différement sous les deux navigateurs ??

Le lien : -http://forum.generations-starwars.com/search.php?action=viewtoday

EDIT : ouh c’est tordu ca !!

Mon template de forum :

<td align="center" nowrap class="TitleCells"><!txt_DatePosted></td></tr>
<!part_loop>
<tr valign="top"><td width="18" class="MsgBG1"><img border="0" src="<!MessageIcon>"></td>

Il semble que collée à un tag html, l’entité <!part_loop> crée une sorte de bug, là comme vous voyez le code elle est sur une ligne séparée, avant tout était compacté (gain de place)… mais pourquoi cette différence de parsing sous IE et sous FF ? Encore plus que ca c’est côté serveur que ca se passe Oo

Non, y a pas de problèmes.

Firefox te renvoie la source après passage au QuirkMode. Enfin, le moteur Quirk (ou la méthode, je sais plus) permet une tolérance des erreurs et là, tu as le code réécrit.

Dans Firefox 1.5, ça ne devrait plus être le cas.

Ah ok, donc il a corrigé tout seul.

Donc c’est le moteur de parsing du forum qui a un mini bug :slight_smile:

Merci ^^