Forum Clubic

Lire OGG 5.1 dans un MKV - Comment ?

Bonjour ! :hello:

Mon problème est le suivant : j’ai un fichier MKV contenant de la vidéo en RV9 ainsi que deux pistes son en OGG 5.1.
Il m’est impossible de lire ce fichier dans Windows Media Player alors que d’autres MKV encodés aussi en RV9/RV10 et en OGG (non 5.1) passent parfatement grâce à l’Haali Media Splitter et au CoreVorbis.
Il est donc certain que le problème vient bien de la piste OGG 5.1… :frowning:

Quelqu’un pourrait-il me dire comment faire pour le lire dans Windows Media Player ?

Merci d’avance. :jap:

lit le avec Média player Classic ou VLC.

Merci pour ta réponse ! :jap:

Ca marche avec MPC ! :oui:

Néanmoins, j’aimerais quand même savoir comment les lire sur WMP ; en effet, une connaissance arrive à lire ce fichier dans son WMP et je me demande vraiment comment il fait… :grrr:

Désolé d’être chiant mais c’est par principe… :ane:

En fait à ma connaissance WMP et une bouse incapable de lire quoi que ce soit, méme avec les filtres OggDS celui-ci n’a jamais voulu lire un ogg… Il est désinstallé sur ma machine au profit de MPC depuis son apparition sous Win98… Donc là je peux pas t’aider…

Il y a une fonctionnalité de MPC que peux de gens utilisent, il s’agit de modifier la priorité du codec à charger en premier, il suffit de faire : touche O --> Filtres externes --> d’ajouter le codec OggDs et de cocher à “préférer”, cela va influer sur tous les players compatibles directshow.
Ca c’est pour ceux qui souhaitent utiliser OggDs car il faut savoir que ffdshow supporte l’ogg vorbis en 5.1, utilise une implémentation plus récente (OggDs date de 2002) et il n’y a pas besoin de faire une quelconque manipulation.

Ah tiens faut passer par là pour avoir du ogg sous WMP…arf.bon de toute façon WMP n’existe plus sur ma bécane…Et en effet leogg chez est gérer par ffdshow audio et plus OggDS que j’ai laissé tomber également…

MPC+ffdshow et une excélente base…

Marceau :

Perso j’aime autant le Satsuki pack, il est complet et mis ç part quelques options de ci de là à modifier éventuellement tous les filtres son déjà associés résultat 99,999% des format fonctionne.
Sinon VLC intégre c propre filtre…mais encore des soucies sur le X264

Merci pour vos réponses ! :jap:

Je ne savais pas que ffdshow reconnaissait l’OGG, je me suis donc empressé d’essayer.
J’ai donc mis “Libavcodec” sur le codec Vorbis.

Et maintenant… ça fonctionne !!! :bounce:

Merci pour votre aide! :jap: