Forum Clubic

Linux et le S-ATA... - Ca fonctionne ?

:hello:

Je prévoie d’installer Mandriva 2006 sur mon PayCay, mais j’ai deux disques en S-ata ( 1 et 2 ) je me demandais si Nunux les détecterait … ^^

Voili voilou c’"est tout pour aujoud’hui!

si le chipset est silicon ou promise, aucun pb

pour intel, je suis vraiment pas sur et j’aurais plutot tendance a te dire non…

Ah cool! J’ai un silicon =)

Donc il le détectera à l’install normal?

ouaip ca devrais pas poser de problème sur les version récentes de linux :slight_smile:

Merci :slight_smile:

NForce 4, ça passe aussi impec.

sur un chip silicon avec le raid activé, ça passerait aussi?
jusqu’à présent, je n’ai pas réussi à détecter mes disques à cause de ça.

Pour les chipset intel, pas de problème non plus. (Intel PIIX/ICH SATA support )

Pour le RAID, je ne sais pas

Les options possibles sont :

Edit : Avec linux 2.6.14 :super:

Oui a condition d’utiliser dmraid pour utiliser ces disques

Pour installer linux sur le raid la ça devient compliqué ( utilisation de dmraid également )

Sinon RAS chez moi non plus 4 disques Sata aucun soucis.

mcfly: des liens pour le montage des raid de cartes méres ?
ca m’interesse j’ai souvent ces questions la

donc il vaut mieux que je désactive le raid
va falloir que je fasse du vide sur mes disques avant de passer à linux :whistle: :whistle:

Avec mandriva 2006, ça passe bien sur certaines cartes mères, mais sur une KT6 par exemple, il faut utiliser l’option “linux noapic” au boot. D’ailleurs, c’était pareil avec la 2005LE.

Sorry du retard pour le raid j’ai testé avec ceci :

http://tienstra4.flatnet.tudelft.nl/~gerte/gen2dmraid/

Donc booter sur l’iso et ensuite de mémoire les disque sont montés dans /dev/mapper/device123456

Le device est le raid en fait :slight_smile: si vous n’avez rien dans /dev/mapper c’est que vos disques ne sont pas supportés :frowning:

je cherchais depuis longtemps et ton lien semble indiquer que le raid est bien supporté comme je le veux
merci mcfly et les autres
y a plus qu’à tester sur une knoppix dans un premier temps

voila j’ai un kernel panic - not syncing Fatal exception in interrupt [4294712.271000]
quand je redémarre aprés install sur un vaio sur tout le disque que ça soit avec debian, ubuntu dapper, simplyMepis, même avec le noyau linux 2.6.15
j’arrive jusqu’à l’écran de session et puis kernel panic
au secours quelqu’un peut-il m’aider ? est-ce SATA ou vga 791 ou chipset NVDIA GeForce Go 6400 ? ou bios ???
celà fait deux ans que je suis sous debian, je ne vais quand même pas commettre le crime de retourné en microsowinmachin ?
aucun prob en livecd quelquesoit la distro :wink:
au secours
quand je vois vos réponse ça me donne de l’espoir, j’ai même participé à l’installparty de parinux il n’ont rien fait (pas de temps)
au secours pathétique !! merci d’av
chek chek chek

:pt1cable:

une solution serait d’installer d’installer ta knoppix qui marche, c’est basé sur debian et tu ne devrais pas trop être dépaysé !

Sinon si tu ecris et lis bien l’anglais, tu peux essayer de poster ton problème sur une liste de diffusion debian.

Dernière idée : aller en parler sur le channel #debian de irc, mais c’est au petit bonheur la chance, il faut que quelqu’un qui s’y connaisse en raid lise le channel pas trop longtemps après que tu ais posté. Je miserai plus sur la liste de diffusion, même si la réponse est plus longue à venir (deux à trois jours en moyenne)

merci pour la rep le prob vient peut-être de là :
Be carefull: there seems to be a bug in grub package; each time you install a new kernell, he replaces /dev/sda* by /dev/hda* in the first section of /boot/grub/menu.lst, so you have to edit it manually.
mais si je peux même pas éditer ni terminer un boot je ne vois pas comment faire ?
je vais quand même réessayer une debian etch 2.6.15 sinon j’essaye avec la der knoppix

A mon avis je crois pas que ça vienne de grub. S’il trouvait pas le disque, il te le dirait, et ça s’arrêterait là (le noyau ne serait même pas démarré). Or ici c’est le noyau qui plante, et je dirais même que tu as un conflit d’IRQ. Les balèzes en IRQ te diront peut-être ce qu’il faut faire au niveau du BIOS ou des options du noyau pour régler tout ça… Je suis pas sépcialiste (à vrai dire j’y connais rien).
Tu peux quand même tenter d’éditer, pour la forme, ton fichier /boot/grub/menu.lst avec un livecd.

Si c’est vraiment un problème de grub, tu peux éditer la ligne au boot : touche ‘e’ au lieu de ‘entrée’ pour démarrer, tu modifies ta ligne et du boot avec ‘b’ (y’a l’aide sur les touches en bas de l’écran normalement)