Forum Clubic

Lignes vides dans publipostage Word et Excel

Bonsoir,

Petite question : je fais un publipostage sous Word avec des données extraites d’un fichier Excel (nom, complément, rue, case postale et localité).

Dans le résultat (nouveau document issu de la fusion), certaines lettres ont une ligne vierge et d’autres pas. Comment “dire” que je veux ignorer les lignes vierges ? Si je coche l’option, on dirait qu’elle ne s’applique pas à tous les enregistrements.

Merci de votre aide et bonne soirée :wink:

Giorgio

Peut être que les lignes qui te gênent ne sont pas vides ?
Par exemple avec un espace dans une des cellules ?

Merci de ta réponse. En fait j’ai cherché encore un peu sur le Net et l’on disait comme toi, que des caractères invisibles pouvaient être présents dans les cellules.

Mais voilà, j’ai essayé de voir cela ce matin (sur mon PC au boulot) et je n’ai rien vu. Y a-t-il une option permettant d’afficher les espaces, retour à la ligne, tabulations comme dans Word ? Précision : je suis sous Office 2000.

J’ai des champs qui sont ignorés lorsqu’ils sont vides et d’autres qui ne sont pas ignorés.

Merci de votre aide et bonne soirée à tout le monde.

Allo,
Essayez d’effacer les caractères invisibles en placant le curseur de la souris dans chacune des cellules en question .
Ensuite, entrez la touche ¶ / supprimer…
Edité le 07/05/2010 à 16:41

Pas à ma connaissance, mais tu peux ruser :
1- tu exportes le tableau excel en version csv, séparation tabulateur, et avec word tu vérifies qu’il n’y a pas d’espace entre les tabulations dans les lignes “vides”
2- sous excel, à partir du moment où toute la ligne doit être vide, tu la sélectionnes, et tu fais effacer Edition > Supprimer > Contenu. Mais là il faut le faire ligne par ligne, tout dépend combien tu en as (ou alors par macro)

Je vais essayer aujourd’hui la solution que tu proposes. Viendrai redire les résultats des opérations.

Merci ;).