Forum Clubic

Lecteur réseau sous debian et caractère spéciaux

Bonjour,

J’ai monter pour une association une système de de backup des donnée avec un petit Debian et la commande rsync.

Tous fonctionne bien mais j’ai un petit souci de carractères spéciaux et accentué.

Le serveur de donnée est sur Windows 2008 R2

Je monte mon lecteur réseau avec la commande suivante dans le FSTAB :

Partage Fichiers

//192.168.15.244/Partage /home/mount/kyubi cifs ro,username=Administrateur,password=password 0 0

Mais lorsque j’explore le dossier monté dans /home/mount/kyubi , tous les fichiers ou dossier avec des caractère spéciaux ou accentué apparaise bizarement, ce qui n’est pas pratique en cas de restauration de Debian vers Windows.

Cordialement.
Edité le 18/03/2013 à 08:49

vérifie tes locales, il est probable que ton client sous Debian soit en unicode (fr_FR.UTF-8) et ton serveur Windows en iso-8859-15 (fr_FR@euro).
Normalement il n’y a pas besoin de changer tes locales, tu dois pouvoir régler ça avec les options du montage, mais j’ai la flemme de fouiller la manpage de mount là :slight_smile:

Bonjour,

J’ai de nouveau vérifier mes locales j’ai forcer de nouveau la commande DPKG-RECONFIGURE LOCALES et j’ai bien mes locales en fr_FR.UTF8

Mon serveur 2008 R2 est bien en iso-8859-15.

J’ai ajouter à mon FSTAB la commande iocharset=utf8

Mais toujours le même problème

Sur le coup j’ai essayé d’ajouter les locales iso-8859-15 sur mon debian et de forcer le iocharset sur le fstab sur iso8859-15

Ce qui me donne:

Partage Fichiers

//192.168.15.244/Partage /home/mount/kyubi cifs ro,username=Administrateur,password=password,iocharset=iso8859-15 0 0

Et là miracle j’ai mes accents :slight_smile:

En tous cas merci pour l’aide