Forum Clubic

La mémoire ne peut pas être "written"

Bonjour,
depuis quelques jours il est impossible d’ouvrir les fichiers du bureau sur le pc de ma fille.
Je reçois le message suivant "l’instruction à 0x…(le code change pour chaque icone)emploie l’adresse mémoire 0x00000000 La mémoire ne peut pas être “written”.
La seule façon d’ouvrir les raccourcis bureau est de cliquer droit sur l’icone et choisir “explorer”
Pc sous xp sp2 et passé à l’anti virus et sous microsoft anti spyware.
Pas de nouvelle installation de logiciels sur le pc.
Au démarrage, les 2 barettes mémoire sont bien reconnues.
Merci de m’aider et A+

Si tu créé un nouveau raccourci vers le même fichier sur le bureau, est-ce que le problème survient ?

Si tu déplace un raccourci du bureau vers un autre répertoire (genre c:\temp) est-ce que cela est pareil ?

Avec tous les racourcis du bureau ?

Il peut s’agir d’un bug de Windows XP. En effet, Windows “calcule” la durée de toutes les vidéos sur le disque, ce qui provoque une utilisation à près de 100% des ressources CPU ou mémoire par le processus Explorer.exe.

Afin de remédier à ce problème il s’agit dans un premier temps de désactiver les aperçus :

Démarrer / Exécuter / regsvr32 -u shmedia.dll

Il faut ensuite éditer la base de registre (Démarrer/Exécuter/ regedit), puis supprimer l’entrée suivante :

"HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850D C73E}\InProcServer32"

Sous certains systèmes, la clé se trouve à l’emplacement suivant :

HKEY_CLASSES_ROOT\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}

Il suffit alors de la renommer en la faisant précéder d’un signe moins (-) :

-{87D62D94-71B3-4b9a-9489-5FE6850DC73E}

Lorsque vous démarrez l’ordinateur, le Bloc-notes démarre et un ou plusieurs documents texte qui contiennent les lignes suivantes apparaissent sur le Bureau de Windows :

[.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787

Retour au début Retour au début
Cause
Ce problème peut se produire si les conditions suivantes sont remplies :
• Il existe un fichier Desktop.ini dans l’un ou plusieurs des dossiers suivants, où lecteur est le lecteur sur lequel Windows est installé :
• lecteur:\Documents and Settings\All Users\Menu Démarrer\Programmes\Démarrage
• lecteur:\Documents and Settings\All Users\Menu Démarrer\Programmes
• lecteur:\Documents and Settings\All Users\Menu Démarrer

  • et -
    • Le fichier Desktop.ini contient les lignes suivantes :

[.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787

Retour au début Retour au début
Résolution
Pour résoudre ce problème, appliquez l’une des méthodes suivantes :
Retour au début Retour au début
Méthode 1 : Suppression du fichier Desktop.ini

  1. Démarrez l’Explorateur Windows.
  2. Dans le menu Outils, cliquez sur Options des dossiers, puis sur l’onglet Affichage.
  3. Dans la zone Paramètres avancés, désactivez les cases à cocher Masquer les extensions des fichiers dont le type est connu et Masquer les fichiers protégés du système d’exploitation (si elles ne le sont pas déjà), puis cliquez sur OK.
  4. Supprimez toutes les occurrences du fichier Desktop.ini qui contiennent les lignes mentionnées précédemment dans la section « Symptômes » de cet article. Pour cela, procédez comme suit :
    a. Recherchez chacun des dossiers suivants, cliquez avec le bouton droit sur le fichier Desktop.ini (si le fichier existe dans ce dossier), puis cliquez sur Ouvrir :
    • lecteur:\Documents and Settings\All Users\Menu Démarrer\Programmes\Démarrage
    • lecteur:\Documents and Settings\All Users\Menu Démarrer\Programmes
    • lecteur:\Documents and Settings\All Users\Menu Démarrer
    où lecteur représente le lecteur d’installation de Windows.
    b. Vérifiez que le fichier contient les lignes suivantes :

[.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787

Si le fichier contient ces lignes, cliquez avec le bouton droit sur le fichier, cliquez sur Supprimer, puis sur Oui lorsque vous êtes invité à confirmer la suppression.
5. Redémarrez votre ordinateur et vérifiez que le problème est résolu.

bonjour,
j’ai trouvé ce post aujourd’hui.
j’ai le même soucis : mais c’est lorsque je passe ma souris sur un fichier vidéo en affichage Miniatures.

j’ai fais un test memtest et pas de souci sur ma mémoire. j’ai donc effectué la méthode de cphoenix17 afin de résoudre mon problème.
Mais le bloc note ne s’ouvre pas au démarrage de windows et donc pas de résultat.
Par contre le fait d’avoir désactivé les aperçus a réglé mon problème. Mais afin de le résoudre d’une façon plus complète, comment puis-je réactiver les aperçus ?

Bon, finallement, après moultes recherches, j’ai trouver ça :
regsvr32 -i shmedia.dll à taper dans executer.
Bizarement, après avoir réinitialisé tous les paramètres comme avant ma première modif, je n’ai plus de message d’erreur ?!
vive windaube :slight_smile:

bonjour,

et bien moi j’avais mêmes prob que le0n34. alors il est vrai qu’en suivant la méthode de cphoenix17 (en désactivant les apercus) ca a resolu le probleme. mais je n’ose pas aller plus loin (supprimer HKEY etc…) car je n’ai pas bien tout saisi. je suis allé voir dans regedit et ce, jusqu’a la ligne qui se termine par “inprocserver32” mais je ne sais ce qu’il faut supprimer et ensuite s’il faut intervenir apres le redemarrage du serveur… je veux bien mais en suivant pas à pas alors. car juste avec le début de la méthode ca résouds mon problème alors faut-il aller plus loin??
merci a l’avance pour une réponse…
P.S. la proposition finale de le0n34 ne marche pas avec moi et me remets le message d’erreur initial…

J ai appliqué la méthode cphoenix17 je vous dirais si cela à réglé mon problème.
Toujours pareil.
Edité le 11/07/2009 à 14:23