Forum Clubic

L2tp avec ppoe

J’ai un problème au niveau du tunnel L2TP entre un LAC et LNS.

Une session PPPoE est crée à l’aide d’un client XP, su le lac je vois bien la session PPoE. Le problème c’est que j’arrive plus à créer le tunnel L2TP

* Con figuration du lac:

LAB-2821-JURA#sh run
Building configuration…

Current configuration : 3497 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname LAB-2821-JURA
!
boot-start-marker
boot-end-marker
!
logging buffered 50000 debugging
no logging console
enable secret 5 $1$kVkV$C6j/9DbPZMDwCOzZEMi5f/
enable password 7 104D000A0618
!
aaa new-model
!
!
aaa authentication login default group tacacs+ local
aaa authentication enable default group tacacs+ enable
aaa authentication ppp default none
aaa authorization config-commands
aaa authorization commands 1 default group tacacs+ local
aaa authorization commands 14 default group tacacs+ local
aaa authorization commands 15 default group tacacs+ local
aaa authorization configuration default group tacacs+
aaa accounting send stop-record authentication failure
aaa accounting exec default start-stop group tacacs+
aaa accounting commands 1 default start-stop group tacacs+
aaa accounting commands 14 default start-stop group tacacs+
aaa accounting commands 15 default start-stop group tacacs+
aaa accounting connection default start-stop group tacacs+
!
aaa session-id common
!
resource policy
!
ip subnet-zero
!
!
ip cef
!
!
vpdn enable
!
vpdn-group lac
request-dialin
protocol l2tp
domain free.fr
initiate-to ip 192.168.2.2
source-ip 192.168.1.2
local name lac
no l2tp tunnel authentication
!
!
!
!
!
username rueil password 7 03085A095F5D741C1E
!
!
!
!
bba-group pppoe global
virtual-template 1
!
!
interface Loopback0
ip address 2.2.2.1 255.255.255.0
!
interface GigabitEthernet0/0
description === chawki - lien vers user pppoe ===
mtu 1600
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
no snmp trap link-status
pppoe enable group global
!
interface GigabitEthernet0/0.50
encapsulation dot1Q 50
ip address 192.168.4.2 255.255.255.0
no snmp trap link-status
!
interface GigabitEthernet0/1
description === chawki - lien vers LNS ===
mtu 1600
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.100
encapsulation dot1Q 100
ip address 192.168.2.1 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
description === LAB - Switch Management VLAN-105 ===
switchport access vlan 105
duplex full
speed 100
!
interface Virtual-Template1
ip unnumbered Loopback0
ppp mtu adaptive
ppp authentication chap
!
interface Vlan1
no ip address
!
interface Vlan10
no ip address
!
interface Vlan105
description === LAB - Management ===
ip address 10.192.5.32 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.2
ip route 10.192.2.0 255.255.255.0 10.192.5.1 name VLAN102_PROD
ip route 10.192.6.0 255.255.255.0 10.192.5.1 name VLAN106_PROD
ip route 192.168.4.0 255.255.255.0 192.168.1.1
!
ip http server
no ip http secure-server
!
!
tacacs-server host 10.192.5.50
tacacs-server directed-request
tacacs-server key 7 02050B4D0A010A
!
control-plane
!
!
!
line con 0
session-timeout 60
exec-timeout 30 0
timeout login response 300
password 7 04570A045673191E59
logging synchronous
history size 256
line aux 0
line vty 0 4
exec-timeout 60 0
password 7 141B130955567F7B74
logging synchronous
history size 256
transport input telnet ssh
line vty 5 15
exec-timeout 60 0
password 7 082D4D4C504B504742
logging synchronous
history size 256
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp source Vlan105
ntp server 10.129.1.27
!
end

[h2]
Configuration LNS:[/h2]

2821_CME_CUE#sh run
Building configuration…

Current configuration : 7186 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2821_CME_CUE
!
boot-start-marker
boot system flash:c2800nm-adventerprisek9-mz.124-11.XJ4.bin
boot-end-marker
!
enable password covage
!
aaa new-model
!
!
aaa authentication ppp default none
!
!
aaa session-id common
clock timezone GMT+1 1
clock summer-time GMT+1 recurring last Sun Mar 3:00 last Sun Oct 3:00
!

!
vpdn enable
!
vpdn-group LNS
accept-dialin
protocol l2tp
virtual-template 1
terminate-from hostname lac
source-ip 192.168.2.2
local name lns
no l2tp tunnel authentication
!
!
voice-card 0
no dspfarm
!
!
!

!
!
!
!
!
!
!
!
!
!

!
!
!
!
!
!
interface Loopback0
ip address 20.20.20.1 255.255.255.0
!
interface GigabitEthernet0/0
ip address 192.168.3.1 255.255.255.0
duplex auto
speed auto
!
interface Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/1
description === chawki - lien vers LAC ===
mtu 1600
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.100
encapsulation dot1Q 100
ip address 192.168.2.2 255.255.255.0
!
interface Virtual-Template1
ip unnumbered Loopback0
ppp authentication chap
!
ip route 0.0.0.0 0.0.0.0 10.192.5.1 name For_Internet_Access
ip route 10.192.2.0 255.255.255.0 10.192.5.1 name mgm_intranet
ip route 10.192.6.0 255.255.255.0 10.192.5.1 name mgm_wifi
ip route 172.19.2.0 255.255.255.0 10.192.5.1 name For_Remote_Access_VPN_Mgt
ip route 192.168.1.0 255.255.255.0 192.168.2.1
!

T’es sur que sur le rtr LSN tu dois configurer to vpdn avec le virtual-template 1
et n’as pas besoin de monter un groupe pppoe ?

En outre, j’ai pas tou controlé mais est-tu certain que les 2 routers aient une route l’un vers l’autre ?

oui ,parceque la session pppoe est monté entre le client et le rtr LAC.
pour vpdn avec le virtual-template 1, chui pas sure , mais si je lemat pas, il y a rien qui change
??

Jutement je ne suis pas convaincu que placer le virtual-template dans le vpdn soit correct pour ce que tu veux faire
J’avoue ne pas en être certain car en général je travaille plus avec d’autres protocols de type IPSec ou GRE mais je suis un peu perplexe sur comment ton tunnel est sencö monter…
Je n’ai pas remarqué de connectivité physique entre les 2 sites, comme je n’ai pas remarqué de mode de négotiation du tunnel…

En faisant un debug vpdn tu trouves quoi ?

en faite les rtr sont connecte à travers les interface gi 0/1
LEs sous interfaces s’occupe de tous qui est pppoe et l2tp
J’ai remarque un truc bizards , si je fais sh intvirtual-template => status down, meme j’arrive plus à changer en up??


comment faire pour la négotiation des tunnel, si je fais debug vpdn jai rien obtenu

alors tes tunnels ne nögocient rien…
tu sembles avoir un problème de communication entre rtrs…
essaie la connectivité sans tunnel en premier

Je n’ai pas compris se que tu as dit.
en faite je ping depuis mon routeur LAC, le routeur LNS même LE client, mais seulement pour le tunnel L2TP il me donne “NO ACTIVE TUNNEl L2TP”.
Est-ce qu’il y a une commande pour l’activé ???
Merci

Non pas de commande il doit s’activer directement dès que les paquets sont échangés et que la négotiation a été effectuée…

Ce qui me fait penser que tes paquets sont dropés…
D’où un MTU vraisemblablement trop grand…

Si je me rappelle bien, le header du VPDN est de 40 byte…

Donc, en supposant que tu as laissé tous les paramètres standard… configure un “ip mtu 1460” dans ton interface “Virtual-Template1”

Est-ce que je dois configurer le mtu 1460sur les interface physiques et les sous interfaces logiques aussi???

En faite il faut configurer mtu 1600 et pas 1460 ???

MTU est une chose et tu peux le laisser à 1600
IP MTU est une autre variable et dans ton cas… comme toutes les valeurs sont standard… il faut baisser la taille des IP MTU de 40 bytes (le header du VPDN) sinon tes paquets IP seront passés à la poubelle

J’ai changé le ip MTU en 1460, mais tjs ca marche pas???
Je ne sais pas si j’ai oublié quelque chose???
dsl pour le dérangement ?

ta une autre idée???

je regardais un peu cette page : www.cisco.com…
et je me suis demandé si tu ne t’es pas un peu mélangé les pinceaux entre LAC et LSN

Dit en passant un e jolie petite page pour le debugging : www.cisco.com…

Je suis un peu limité dans l’aide que je peux t’apporter en cette période car je suis un peu débordé :frowning: