Forum Clubic

[KUBUNTU LiveCD] Probleme de montage [FIXED]

Bonjour a tous.

Je teste cette distribution (la Hoary avec KDE v3.4.1) et j’ai un souci : il m’est impossible d’acceder a mes partition NTFS.

J’ai edite en tant que root le fichier “/etc/fstab” pour ajouter le ligne suivante :

Puis (toujours en root) je cree le repertoire “/mnt/hda1”. Les droits d’acces sont “rwxr-xr-x” avec comme proprietaire et groupe : “root.root”.

Suite a cela je peux monter le volume en tant qu’utilisateur “ubuntu” avec un click droit dans Konqueror. Un “$mount” dans la console me retourne :

Le souci est que les permissions de “/mnt/hda1” ont changees entre-temps : elles sont passees a “r-x------”.
Et donc, quand je click sur l’icone du volume j’obtiens ce message : “Could not enter folder /mnt/hda1.”:
Quand je demonte le volume, les permissions reviennent a “rwxr-xr-x”.

Le comportement est identique quand je fais toutes les operations dans la console.
De meme, ajouter l’utilisateur “ubuntu” au groupe “users” (avec l’utilitaire KUser) ne change rien.

Des suggestions pour corriger cet etrange comportement ?

Merci d’avance.

le ntfs n’est pas accessible en ecriture, c’est tout :slight_smile:

C’est bien pour cela que j’ai utilise l’option “ro” dans “/etc/fstab”.

Pourquoi passes-tu par le fstab ? Si tu fais un mount /dev/hda1 /mnt/hda1 en root, tu devrais quand même pouvoir y avoir acces en utilisateur normal.
Essaye de voir avec chmod -R a+r /mnt/hda1 mais bon… :confused:

c’est ce que j’utilise pour ma partition fat32, donc pour du ntfs ça doit pas être très loin :smiley:

=> tu devrais essayer avec uid et gid (ton numéro d’utilisateur et de groupe) :wink:

PS : bon d’accord l’iocharset utf-8 c’est pas recommandé pour du fat, mais bon :stuck_out_tongue:

Ca marche, merci :wink:

C’est quand meme curieux qu’il faille ajouter ce parametre…

j’ai jamais compris non plus. En fait, user/users autorise un/des utilisateurs à monter/démonter la partition… mais pas apparemment à accéder au système de fichiers :??:. C’est pour ça que je rajoute à tout les coups uid,gid, pour que les fichiers m’appartiennent :smiley: