Forum Clubic

[Kernel 2.6.12-rc5] Problème de carte son & alsa 1.0.9 !?

Bonjour à tous :slight_smile:

J’ai un petit soucis avec ma carte son audigy ainsi que mon usb maintenant :ouch: sur le noyau 2.6.12-rc5

Mes 2 cartes fonctionnent au poil sous une version plus ancienne mais depuis le 2.6.12 c’est la galère …

Je viens de remarquer qu’apparament on utilise alsa en version 1.0.9 sous ce noyau et même après un alsaconf j’obtiens ceci :

[cpp]bash-2.05b# lsmod
Module Size Used by
snd_seq_midi 10144 0
snd_emu10k1_synth 8960 0
snd_emux_synth 39936 1 snd_emu10k1_synth
snd_seq_virmidi 9344 1 snd_emux_synth
snd_seq_midi_emul 8576 1 snd_emux_synth
snd_emu10k1 120196 1 snd_emu10k1_synth
snd_rawmidi 27296 3 snd_seq_midi,snd_seq_virmidi,snd_emu10k1
snd_ac97_codec 84344 1 snd_emu10k1
snd_util_mem 5632 2 snd_emux_synth,snd_emu10k1
snd_hwdep 10656 2 snd_emux_synth,snd_emu10k1
nvidia 3925116 12
bash-2.05b# cat /dev/sndstat
Sound Driver:3.8.1a-980706 (ALSA v1.0.9rc2 emulation code)
Kernel: Linux Linux-Gentoo-2005 2.6.12-rc5 #2 SMP Thu May 26 16:41:20 CEST 2005 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
Audigy 1 or 2 [Unknown] (rev.3, serial:0x531102) at 0xa000, irq 18

Audio devices:
0: ADC Capture/Standard PCM Playback (DUPLEX)

Synth devices:
0: Emu10k1

Midi devices:
0: Audigy MPU-401 (UART)

Timers:
7: system timer

Mixers: NOT ENABLED IN CONFIG
[/cpp]

Normalement je n’utilise pas l’outil de config alsa je passe directement dans le fichier pour paramétrer mes 2 cartes sons et ca fonctionnent très bien ici au chargement de alsa je n’ai pas d’erreur :

[cpp]bash-2.05b# /etc/init.d/alsasound restart

  • WARNING: you are stopping a boot service.
  • Storing ALSA Mixer Levels… [ ok ]
  • Unloading ALSA… [ ok ]
  • Unloading ALSA modules… [ ok ]
  • Loading ALSA modules…
  • Loading: snd-card-0… [ ok ]
  • Loading: snd-emu10k1-synth… [ ok ]
  • Loading: snd-seq-midi… [ ok ]
  • Restoring Mixer Levels… [ ok ]
    [/cpp]

Voila je ne sais pas quoi essayer faut-il émerger le nouveau alsa ou que sais-je :??:

Apparament il ne prends rien en compte que ce soit config ou quoique ce soit Mixers: NOT ENABLED IN CONFIG sous le 2.6.11 il est bien actif, je pense qu’il faut changer un autre fichier mais je ne sais du tout le quel …

Merci pour d’avance votre aide :jap:

T’as vérifié la config d’alsa dans le menuconfig ?

[cpp]<> Advanced Linux Sound Architecture │ │
│ │ <
> Sequencer support │ │
│ │ < > Sequencer dummy client │ │
│ │ <> OSS Mixer API │ │
│ │ <
> OSS PCM (digital audio) API │ │
│ │ [*] OSS Sequencer API │ │
│ │ [ ] Verbose printk │ │
│ │ [ ] Debug [/cpp]

J’ai laissé comme d’habitude,

Xmms n’est pas trop content en fait j’utilise l’option OSS Driver pour ma carte son externe dans xmms mais la il ne l’a reconnait plus :frowning: Ni l’audigy ni l’usb.

Par contre avec l’option alsa l’audigy fonctionne, j’utilisais oss jusqu’à maintenant car si je lançais firefox avec xmms ouvert il se fermait :o

Apparament ce bug est résolu mais çà ne m’avance pas trop car alsa ne voit pas mon usb maintenant :confused:

EDIT: bug pas corrigé maintenant ca le fait avec gaim :smiley: xmms se ferme direct si un son est émis par le système.