Forum Clubic

KDE-3.3.x : avoir la peau des warnings "kbuildsycoca"

Pour utilisateurs d’applications KDE seulement.

Heu dites, ke vous dit la console lorsque vous lancez une appli KDE, quelque soit votre WM ?

Je trouve rien là-dessus pour le moment sur OSA ou gogol/linux.

La dernière fois que j’ai ajouté les infos manquantes dans kcontrol, j’ai fini par bugger l’attribution des “Ouvrir avec quoi” qui est devenu 100% bloquée. En plus ça m’avait pris 2 plombes… Bof !

Vous avez (pas) ça ?
Comment vous l’avez réglé ?

Alors ma config

  • Mandrake Linux 10.1
  • kernel 2.6.8.1-10mdk
  • Qt: 3.3.3
  • KDE: 3.3.2
  • Konqueror: 3.3.2
  • Blackbox 0.65.0

Exemple, Sous blackbox, après un rm -Rf ~/.kde :
je lance $ konqueror man:/mkvmerge
Alors voilà ce que j’ai (ai enlevé 90% des lignes, redondantes) :

[fixed] $ QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used (x3)
kbuildsycoca running…
Reusing existing ksycoca

kbuildsycoca: WARNING: ‘/home/koz/.local/share/applications/menu-xdg/X-Mandrakelinux/.hidden/k3b-iso.desktop’ specifies undefin ed mimetype/servicetype ‘’

kbuildsycoca: WARNING: ‘/home/koz/.local/share/applications/menu-xdg/X-Mandrakelinux/Multimedia/Video/mplayer.desktop’ specifie s undefined mimetype/servicetype ‘application/x-matroska’

kbuildsycoca: WARNING: ‘/home/koz/.local/share/applications/menu-xdg/X-Mandrakelinux/Multimedia/Video/kaffeine.desktop’ specifi es undefined mimetype/servicetype ‘application/x-mplayer2’


‘/home/koz/.local/share/applications/menu-xdg/X-Mandrakelinux/Multimedia/Video/MPlayer.desktop’ specifie s undefined mimetype/servicetype ‘video/msvideo’[/fixed]

[fixed][18:18][jcp@phoenix]
[~] > konqueror man:emerge
konqueror: ERROR: Error in BrowserExtension::actionSlotMap(), unknown action : searchProvider

[18:19][jcp@phoenix]
[~] >
[/fixed]
Rien de spécial quoi :wink: (et encore, je compile koffice en même temps :p).

NB : pour l’erreur que tu vois chez moi, je sais ce que c’est, rien d’important ;).

NB2 : on dirait que ton thème passe mal.

NB3 : c’est KDE 3.2.3 sur MDK 10.1 ;).

NB > bon donc g de quoi faire pour avoir si peu de warnings que j_c_p !

NB2 > où ça le thème ?

NB3 > tu parles de quel système le tien ou le mien ?
En fait je doute que tu aies kde 3.2.3 donc tu dois parler du mien, dans ce cas non non c bien les versions indiquées dans mon post (Thac’s), mais il me semble que le problème était le même avant, bien queje le vois maintenant que je lance les applis depuis un shell.