Forum Clubic

Installer un package .deb

hello

si je DL un package deb, y a t il une commande pour installer le package que j’ai mis ds un dossier, sans avoir a modifier le fichier source.list ?

genre : apt-get install /home/mondossier/monpackage.deb

merci

dpkg -i package.deb

merci ca marche par contre ca gere pas les dépendance :

dpkg -i /home/alex/amsn_0.94-1_i386.deb
dpkg: l’opération demandée requiert les privilèges du super-utilisateur
alex@bluesboy:~$ sudo dpkg -i /home/alex/amsn_0.94-1_i386.deb
Sélection du paquet amsn précédemment désélectionné.
(Lecture de la base de données… 59064 fichiers et répertoires déjà installés.)Dépaquetage de amsn (à partir de …/home/alex/amsn_0.94-1_i386.deb) …
dpkg : des problèmes de dépendances empêchent la configuration de amsn :
amsn dépend de imlib1 ; cependant :
Paquet imlib1 n’est pas installé.
amsn dépend de sox ; cependant :
Paquet sox n’est pas installé.
amsn dépend de libpng10-0 ; cependant :
Paquet libpng10-0 n’est pas installé.
amsn dépend de docker ; cependant :
Paquet docker n’est pas installé.
amsn dépend de tcltls ; cependant :
Paquet tcltls n’est pas installé.
dpkg : erreur de traitement de amsn (–install) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l’exécution :
amsn

j étais sous fedora avant, et la j essaye l’ubuntu hoary

Si les dépots sont bien paramétrés, essaye un ‘apt-get install amsn’

les dépots c’est le fichier sources.list ?

pke je voulais pouvoir installer sans le modifier justement,j’ai pas le choix ?

sudo apt-get install amsn
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Aucune version du paquet amsn n’est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu’il est devenu obsolète
ou qu’il n’est disponible que sur une autre source
E: Aucun paquet ne correspond au paquet amsn

Amsn se trouve dans le dépot Universe, il faut que tu l’active avec Synaptic.

par contre j 'ai fé un apt-get install xmms, la ca a marché

Sinon, puisque tu est sous Ubuntu tu as Gaim qui doit être déjà installé :slight_smile:

ouaip mais je prefere amsn, et puis c pour manipuler un peu aussi

merci ! :slight_smile:

je suis allé ds synaptic, j ai ajouté “universe” ds les dépots et la il a l’air de m’installer amsn ! :slight_smile:

Berk , du TCL/Tk >_<

Je prefere GAIM bien qu’il faut un peu s’y habituer