Forum Clubic

Installation du module bonding

bonjour,j’ai installer une distribution de linux “Debian” est je veut installer le module bonding mais quand je tape la commande apt-get install bonding il y a une lecture de la liste des paquets ensuite la repense est: bash:impossible de trouvé le paquet bonding ,alors j’ai chercher sur google est j’ai trouvé que le module existe dèja dans mon OS,j’ai essayer de le charger avec la commande: bonding miimon=100 mode=4 mais la repens est : bash:bonding comande not found,quelqu’un a une solution svp.
Merci d’avance.

Euh … tu veux directement te lancer dans des choses compliquées (?) sans connaitre les bases du système d’exploitation. Je trouve cela assez étrange. Tu suis des tutos trouvés au hasard sur le net sans savoir ce que ça va provoquer …

Commence par comprendre le système ( www.debian.org… ) avant de te lancer. Tu arriveras plus facilement à faire ce que tu as envi.
Edité le 13/12/2008 à 21:51

bonjour,merci pour les conseils est le lien.

-Est pour le module bonding il existe deja dans le noyau (pour les versions récentes) on peut le charger différentes méthodes:
Pour le charger automatiquement: #vi /etc/modules.conf est ajouter
alias bond0 bonding
options bond0 mode=0 miimon=100
(mode0 c’est pour le loade blancing)
Pour le chargement manuelle: #modprobe bonding
ensuite procédé a la configuration du 'interface virtuelle bond0 (moi j’utilise 3cartes réseau):
ifconfig bond0 192.168.0.1 netmask 255.255.255.0 up
ifconfig eth0 192.168.0.1 netmask 255.255.255.0 up
ifconfig eth1 192.168.0.1 netmask 255.255.255.0 up
ifconfig eth2 192.168.0.1 netmask 255.255.255.0 up

pour les @ physiques on peut les laissées.
ifenslave bond0 eth0
ifenslave bond0 eth1
ifenslave bond0 eth2

ensuite vérifier que le maitre est bond0 et les esclaves eth1 est eth2 on regardent le fichier /etc/proc/net/bond0:
#vi /etc/proc/net/bond0
jusqu’ici j’ai fait que le mode loade blancing entre les interfaces réseau et il faut trouvé eth0,eth1,eth2 come esclaves de bond0.
on peut aussi changer le mode en faillover mais il faut que le paquet nett-tools soit installer:
#mii-tool eth0
#mii-tool eth1
#mii-tool eth2

#mii-diag eth0
#mii-diag eth1
#mii-diag eth2

-Est comme ça le problème est résolu.
-J’espère que ça va aidé quelqu’un dans le future.
-Un grand merci a gabe.