Forum Clubic

Installation clé wifi netgear Debian

Bonjour a tous,
J’ai récupéré un vieux pc portable hier. Evidement il n’y a pas de carte wifi integré donc j’ai essayé de mettre ma clé wifi netgear wpn111.
Mais je n’arrive pas à l’installer. J’ai essayé la méthode avec le truc (je me souviens pas du nom) qui se sert du fichier .inf du pilote windows, or je n’avais pas de fichier .inf seulement un .ini.
Donc je demande votre aide parceque la je seche.
Merci

Salut,

Ta carte est apparemment supportée par Linux. Il te faut bien utiliser Ndiswrapper pour installer le pilote.

Tu as deux possibilités :

  • Utiliser le logiciel graphique (installation via synaptic par exemple) : ndisgtk
  • Soit passer par la ligne de commande : gabestock.free.fr…

Je te remercie beaucoup par contre l’interface ndisgtk n’est pas disponible dans Synaptic donc je vais essayer avec ton lien. Je tiens au courant

Le problème c’est que je n’ai pas de fichier inf dans mon driver …
Donc je fait comment ??

Étrange, j’utilise GNU-Linux Debian Unstable et j’ai ce logiciel dans mes dépots.

Et bien il faut que tu ailles sous w*ndows (si tu en a un) et que tu récupères le fichier “.inf” de ton pilote ([i]C:\Windows\system32\drivers[/i] en général). Utilise le gestionnaire de périphériques et notamment le bouton “Détail du pilote” pour identifier le bon fichier.
Edité le 16/11/2008 à 15:06

OK je vais essayer sa

Je crois que je vais pa y arriver. J’est effectivement le fichier WPN111v.sys (dans c:\windows\sys32\drivers). Mais impossible de trouver ce fichier .inf.
Help me

Fait alors une recherche sur tout ton disque :

  • avec le mot clé : wpn111
  • puis si pas de résultat, avec .inf et fait une recherche visuelle :smiley:

Autrement : ubuntuforums.org…
Mais les pilotes semblent assez ancien, mais apparemment fonctionnels.

Bon gabe je te remercie beaucoup pour le pilote parceque mon .inf est introuvable sous vista (quelle merde). Alors j’ai essayé de faire avec le lien que tu ma donné : Le lien que tu ma donné . En suivant les étapes je bloque déjà sur la deuxième :

cd /home/utilisateur

ndiswrapper -i fichier.sys

Je fait la deuxième ligne nikel et il m’indique :

$ couldn’t get manufacturer section - installation may be incomplete

Comme c’est écrit “may be” je continue

ndiswrapper -l

Et la j’ai :

$ installed drivers:
setup.ini invalid driver!
wpn111.sys invalid driver!

Je ne sais plus quoi faire.

Salut,

Simplement que tu t’es trompé de fichier. Regarde, lors du ndiswrapper -l :
setup.ini invalid driver! <<== là

Commence par désinstaller le pilote :

ndiswrapper -e setup.ini

Puis installe le bon pilote :

ndiswrapper -i wpn111.inf

C’est le fichier “.inf” qu’il faut utiliser, je ne suis pas sûr, mais je crois que le .sys ne sert à rien …

Ensuite, un petit ndiswrapper -l qui, je l’espère, te sortira “… device present !”.

Bonne chance !

Tu vas pas le croire mais sa marche toujours pas.
L’installation a fonctionné (merci beaucoup) mais on continuant avec le lien je fait :

depmod -a

Là pas de problème

modprobe ndiswrapper

et mon pc réplique :

FATAL: Module ndiswrapper not found.

Que répondre a ça et pourquoi ??

Salut,

Ce message indique que le module ndiswrapper est absent du noyau.
Essaie ça :

apt-get install build-essential kernel-headers-$(uname -r) module-assistant
apt-get install ndiswrapper-source
cd /usr/src
m-a prepare
m-a a-i ndiswrapper

modprobe ndiswrapper

Si vraiment ça ne fonctionne pas, tu vas : - supprimer le pilote avec [i]ndiswrapper -e ...[/i] - lancer synaptic et désinstaller tout ndiswrapper - récupérer les sources de ndiswrapper : [sourceforge.net...](http://sourceforge.net/projects/ndiswrapper/) - lire le fichier INSTALL une fois décompressé dans un dossier pour compiler et installer ndiswrapper - refaire les manip pour installer le pilote.

Pour compiler il te faut :

  • les kernel-headers spécifiques à la version de ton noyau ($ uname -a)
  • make
  • gcc
  • cpp

Je te remerci pour tout Gabe la compilation a super bien fonctionné mais la clé wifi ne fonctionne pas. La del ne s’éclaire pas comme le tuto le précisait. Je suis désespéré et je croi que je vais m’acheter un switch et garder le bon vieu fil.
Enfin sauf si ta pas un autre truc magique pour me sauvé.
Dsl de pas avoir répondu avant mais je suis en bac blanc donc je met un peu de temps.
Merci beaucoup

Que donne :

# ndiswrapper -l

netwpn111 : driver installed

J’en déduit qu’il n’y a pas de problème de ce coté là …

Ok, mais rien qui dit que la carte est présente et détectée ?

Non que sa. Et d’après le tuto la carte devrait théoriquement s’allumer.
Après il me semble qu’on fait iwconfig et j’ai :

Tommytom-Debian:/home/tommytom# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

Salut,

C’est étrange, j’ai refait chez moi ce petit exercice et ça fonctionne.

Maintenant :

# iwlist scan

Si ça te retransmet les réseaux wi-fi environnent tu seras sur la bonne voie.