Forum Clubic

Instal plug in flash firefox pr all users (ubuntu)

hello :slight_smile:

je viens d’installer une Ubuntu sur mon ordi (Xubuntu pour être précis). Vraiment nickel pour l’instant cette distrib.

J’ai un petit souci au niveau de l’instal du plug in flash pour firefox : je dois l’installer manuellement pour chaque user. j’ai lu que je devais faire l’install en root pour qu’elle soit valable pour tout le monde.

Or il n’y a plus de root avec Ubuntu. Je fais comment ?

merci de votre aide

sudo apt-get install flashplugin-nonfree

Ça te téléchargera la dernière version disponible de flash sur le site de macromedia et l’installera. Tous les utilisateurs auront ce plugin dispo dans leur firefox (sauf ceux qui ont déjà flash dans leur profil, je ne sais pas ce que ça va donner :D)

bah je vais te dire ca toute de suite :smiley:

mince ca me dit ca :

cyp@cyp-desktop:~$ sudo apt-get install flashplugin-nonfree
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
E: Impossible de trouver le paquet flashplugin-nonfree
cyp@cyp-desktop:~$

pourtant je crois avoir les bonnes sources d’installer

T’as activé les dépôts Universe/Multiverse ?
http://doc.ubuntu-fr.org/applications/apt/…e_et_multiverse

voila mon fichier sources.list :


deb [url=http://fr.archive.ubuntu.com/ubuntu/]http://fr.archive.ubuntu.com/ubuntu/[/url] dapper main restricted
deb-src [url=http://fr.archive.ubuntu.com/ubuntu/]http://fr.archive.ubuntu.com/ubuntu/[/url] dapper main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb [url=http://fr.archive.ubuntu.com/ubuntu/]http://fr.archive.ubuntu.com/ubuntu/[/url] dapper-updates main restricted
deb-src [url=http://fr.archive.ubuntu.com/ubuntu/]http://fr.archive.ubuntu.com/ubuntu/[/url] dapper-updates main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the [Ubuntu](http://www.clubic.com/telecharger-fiche15525-ubuntu.html)
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb [url=http://fr.archive.ubuntu.com/ubuntu/]http://fr.archive.ubuntu.com/ubuntu/[/url] dapper universe
deb-src [url=http://fr.archive.ubuntu.com/ubuntu/]http://fr.archive.ubuntu.com/ubuntu/[/url] dapper universe

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb [url=http://fr.archive.ubuntu.com/ubuntu/]http://fr.archive.ubuntu.com/ubuntu/[/url] dapper-backports main restricted universe multiverse
deb-src [url=http://fr.archive.ubuntu.com/ubuntu/]http://fr.archive.ubuntu.com/ubuntu/[/url] dapper-backports main restricted universe multiverse

deb [url=http://security.ubuntu.com/ubuntu]http://security.ubuntu.com/ubuntu[/url] dapper-security main restricted
deb-src [url=http://security.ubuntu.com/ubuntu]http://security.ubuntu.com/ubuntu[/url] dapper-security main restricted
deb [url=http://security.ubuntu.com/ubuntu]http://security.ubuntu.com/ubuntu[/url] dapper-security universe
deb-src [url=http://security.ubuntu.com/ubuntu]http://security.ubuntu.com/ubuntu[/url] dapper-security universe


et ca me met pourtant le meme message d’erreur.

est ce que ca peut petre du au fait que j’ai déja installé pour certain user (notemment l’user principal) le plugin flash officiel ?

Il te manque la section multiverse :

:slight_smile:

oki je te remercie ! ca a l’air de marcher

(par contre c’est normal que le plug in marche pas correctement ?? (enfin genre ca marche bien mieux sous windows))

Oui :smiley:
Ce n’est que la version 7, alors que sous windows ça doit être la 8.5 ou la 9 :confused:

ok c’est donc pour ca.

des nouvelles versions sont en projet ??

En projet, oui :ane: (mais on sait pas si ça sortira un jour :paf:)

lol d’accord je prend note ! :smiley: