Forum Clubic

Impossible jouer a cube - tres tres tres lent

bonjour tout le monde
bon voila ma config
céléron 2.4@2.88
2*256 de pc 2700
p4pe-x de chez asus
ati radeon 9250se (128mo)
et je suis dans l’impossibilité de faire tourner un jeux comme cube (meme NFS underground II tournait bien sur ma config)
Bon d’accord c’est detre une config de gamer mais la c’est vraiment dur de faire pire
j’ai l’impression d’avoir 8mo de ram avec un pentium 133 et une carte graphique intégré c’est pour vous dire
auriez vous une idée SVP
cordialement
XerXeSis

Tu as bien mis les drivers Ati?

non j’ai laissé telquel il me semblait qu’il me la reconnaissait directement donc que ça allait bien fonctionner

Lance glxgears -printfps dans une console et dis-nous combien de FPS ça fait…

Si tu es sous Ubuntu Hoary ou Dapper, il faut installer le driver ATI en suivant la démarche ici :
https://wiki.ubuntu.com/BinaryDriverHowto/ATI

la commande que tu m’as donné ne correspond pas apparement mais je vais essayé de suivre le wiki merci de m’avoir répondu aussi rapidement
je vous tiens au courant
cordialement
XerXeSis

Bizarre pour glxgears :??:

j’ai essayé de faire ce que le lien que tu m’as donné m’a dis de faire mais j’ai eu droit a un plantage du serveur X j’ai donc été obligé de faire un dpkg-reconfigure -phigh xserver-xorg
et apres toujours aucun changement quelqu’un a t-il une idée
sinon quand je dois faire dpkg-reconfigure xserver xorg je dois doit mettre quoi ATI ou fglrx apres je dois choisir le port je dois mettre quoi je suis en AGP je ne vais pas taper ça sa métonnerais qu’il comprenne :ane:
cordialement
XerXeSis

Il faut choisir fglrx :oui:

Ma section device du fichier /etc/X11/xorg.conf si ça peut t’aider (avec une ATI mobility radeon 9700) :

Section "Device"
    Identifier                          "ATI Graphics Adapter"
    Driver                              "fglrx"

    Option "no_accel"                   "no"
    Option "no_dri"                     "no"
    Option "mtrr"                       "off" # disable DRI mtrr mapper, driver has its own code for mtrr

    Option "DesktopSetup"               "clone"
    Option "ScreenOverlap"              "0"
    Option "GammaCorrectionI"           "0x06419064"
    Option "GammaCorrectionII"          "0x06419064"

    Option "Capabilities"               "0x00000000"
    Option "CapabilitiesEx"             "0x00000000"

    Option "VideoOverlay"               "on"

    Option "OpenGLOverlay"              "off"

    Option "CenterMode"                 "off"

    Option "PseudoColorVisuals"         "off"

    Option "Stereo"                     "off"
    Option "StereoSyncEnable"           "1"

    Option "FSAAEnable"                 "no"
   Option "FSAAScale"                  "1"
    Option "FSAADisableGamma"           "no"
    Option "FSAACustomizeMSPos"         "no"
    Option "FSAAMSPosX0"                "0.000000"
    Option "FSAAMSPosY0"                "0.000000"
    Option "FSAAMSPosX1"                "0.000000"
    Option "FSAAMSPosY1"                "0.000000"
    Option "FSAAMSPosX2"                "0.000000"
    Option "FSAAMSPosY2"                "0.000000"
    Option "FSAAMSPosX3"                "0.000000"
    Option "FSAAMSPosY3"                "0.000000"
    Option "FSAAMSPosX4"                "0.000000"
    Option "FSAAMSPosY4"                "0.000000"
    Option "FSAAMSPosX5"                "0.000000"
    Option "FSAAMSPosY5"                "0.000000"

    Option "UseFastTLS"                 "0"
    Option "BlockSignalsOnLock"         "on"
    Option "UseInternalAGPGART"         "yes"
    Option "ForceGenericCPU"            "no"
    BusID "PCI:1:0:0"    # vendor=1002, device=4e50
    Screen 0
EndSection

Ah attends, à la fin tu as bien rebooté le PC ?
Parce que si tu as seulement relancé X il n’a pas chargé le module fglrx.

oui oui biuen sur je l’ai fait mais je crois que c’est parce que mon xorg.conf n’est pas au meme endroit que vous donc je suis bloqué je sais pas comment faire merci beaucoup quand meme

xorg.conf n’est pas dans /etc/X11 ?
Ça me semble très bizarre, ça :confused:

en fait c 'est pour cette raison

Ah d’accord. Bah perso entre breezy et dapper j’ai été obligé de réinstaller le système : kernel panic au démarrage après l’upgrade :neutre: Donc je n’ai pas eu ce problème, forcément.

Mais le xorg.conf est au même endroit, et celui que tu utilisais sous Breezy devrait marcher sous Dapper :oui:

Perso j’utilise ce tuto pour installer les pilotes ati proprio : http://forum.ubuntu-fr.org/viewtopic.php?id=2487

Je l’ai essayé sous hoary (enfin je suis plus tres sur), breezy et dapper et a chaque fois ça à bien marché.

Comment ça, on cite mes posts sans me prévenir ? :ane: Je vais porter plainte :o

Juste une idée comme ça : il a une radeon 9250… t’es sûr qu’elle est supportée par les pilotes proprio fglrx ? Car je crois qu’elle fonctionnera mieux avec les pilotes libres ati :smiley:

Si tu n’as pas /etc/X11/xorg.conf (et glxgears), tu dois avoir quelques petits soucis, non ? [:ippon]

non en fait j’en sais rien du tout je pense que oui car dans al documentation de ubuntu il dise que 9200 est compatible mais il ne parle pas de la 9250se donc je me suis dis que ça devais quand meme etre bon

si je te cite c’est juste parce que tu as donné une réponse a un de mes probleme :smiley:
j’ai bien un xorg.conf dans /etc/x11 mais je ne trouve pas le glxgears

je dois avoir une carte graphique tres bizarre car moi ça ne fonctionne pas du tout j’ai encore eu droit a un plantage du serveur X

nan nan nan :o :ane:
je ne pense pas que glxgears soit dans /etc (c’est pour les fichiers de configuration /etc/) :wink:
Pour trouver où est réellement glxgears, tu peux faire “whereis glxgears”

Quoi qu’il en soit, ouvre un terminal et lance “glxgears -printfps”, et donne nous le score :smiley:

Normalement le driver proprio supporte les radeon >=8500 :slight_smile:

depuis la version 7.0, xorg ne maintiens plus une copie de glxgears, il faut installer le package mesa-utils pour l’avoir :wink:

au passage, tu pourras remarquer que la vitesse des roues est chronomètrée maintenant, c’est à dire qu’elles tournent toujours à la même vitesse, quels que soient les fps.
Aussi, glxgears n’affiche plus par défaut les fps, il faut utiliser l’option -printfps ou -iacknoledgethatglxgearsc’estpasbienpourlesbenchjesaispluslasuite

pour ce qui est des drivers, sous ubuntu, si tu as activé les dépots universe et multiverse, tu as les packages linux-restricted-module ou un truc dans le genre (fais une recherche) qui t’installe quelques drivers proprios précompilés pour le kernel ubuntu.
Si tu as compilé ton propre kernel, ubuntu a hérité du merveilleux outils module-assistant de chez debian, il faut d’abord l’intaller

apt-get install module-assistant

puis

module-assistant auto-install frglrx

ou pour les fainéants :

m-a a-i frglrx

puis bien évidement,

dpkg-reconfigure xserver-xorg

là tu choisi frglrx comme driver, et tu laisses toutes les options que tu ne connais pas par défaut (même le bus de la carte) car dans la plupars des cas, il n’y en a pas besoin (indiquer le bus sert par exemple si tu as plus d’une carte ou dans le cas de certaines cartes très exotiques ou buggées)

glxgears -iacknowledgethatthistoolisnotabenchmark [:athena]

Bon je préfère mettre un alias glxgears="glxgears -printfps" dans mon .bashrc :smiley: