Forum Clubic

Impossible d'utiliser apt-get

Salut tout le monde !

Un problème se pose à moi. J’ai un serveur linux qui tourne depuis 6 mois sans aucun problème avec une distribution ubuntu (je sais c’est pas fait pour à la base mais ça marche bien…).
En réalité je tourne sous une ancienne version d’ubuntu (la version ‘Breezy’). Le choix de cette ancienne distribution est justifié par le fait que mon point d’accès wifi ne fonctionne qu’avec cette version précise d’ubuntu, bref.

Là je souhaite installer mldonkey-server afin d’avoir un serveur de téléchargement. Je lance donc un apt-get update vite fait avant de faire le apt-get install mldonkey-server et là j’ai :

Impossible de localiser la liste des paquets sources [archive.ubuntu.com...](http://archive.ubuntu.com) breezy/multiverse Packages (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_breezy_multiverse_binary-i386_Packages) - stat (2 Aucun fichier ou répertoire de ce type)

En réalité j’en ai plusieurs comme ça qui se répète.

Le fichier sources.list est pourtant en règle et est copié de ce tutorial : doc.ubuntu-fr.org…

Quelqu’un pourrait m’aider à résoudre le problème ? Merci de m’avoir lu.

En effet, il n’y a pas Breezy sur le dépot.

une piste : Il faut trouver un autre dépot :frowning:

Han ouais en effet :o

Mais comment faire ? :-/ Ca veut dire que maintenant je peux plus rien installer sur le PC ? J’ai pas envie de mettre à jour la distrib, ça marche bien là…

Trouver un autre dépot ? Il n’existe que les dépots ‘officiels’ non ? Enfin je sais pas où chercher là…

effacé
Edité le 28/06/2007 à 16:48

Salut,

Breezy est probablement en cours d’etre degage. tout simplement…
En fait Ubuntu edite 2 sortes de distribs : les long terme support (Dapper) et la version “normale”
Breezy fait partie des versions “normales” qui sont mises a jours tous les 6 mois et que tu dois mettre a jour tous les 6 mois au risque de te retrouver dans la situation actuelle = plus de support = plus de paquets.
Si tu veux stagner sur une version pendant plusieurs annees alors tu dois choisir une long terme support (Dapper Drake).

C’est etonnant que ton AP fonctionne seulement avec Breezy et pas avec les versions suivantes. Les regressions de ce genre sont extremement rares. Tu devrais peut etre re-essayer et eventuellement faire un rapport de bug aupres d’ubuntu.
As tu regarde sur www.ubuntu-fr.org… pour une solution ?

oui j’ai passé plusieurs jours à chercher une solution et rien n’y fait, d’autant plus que les gens qui utilisent hostapd ne courent pas les rues.

En réalité le problème viendrait justement d’une soi disante avancée avec Ubuntu Dapper (et l’utilisation des pilotes madwifi-ng par défault) ce qui rend mon point d’accès wifi inutilisable (connexion mais aucun paquet qui transite sur le réseau).

Alors qu’avec Ubuntu Breezy il y a les anciens pilotes madwifi normaux qui marchent à merveille pour ce que je veux faire.

Bref, je pense donc passer par la compilation du logiciel mldonkey, je ne veux pas prendre le risque de ne plus savoir faire ce que j’ai pris tellement de temps à réaliser (php, mysql, samba, ftp, point d’accès wifi, partage d’imprimante…).

Je savais pas cette histoire de support long/court terme :frowning:

Edit : j’avais même réalisé un topic : www.clubic.com…
Il se trouve que j’avais tenté d’installer les madwifi-old mais que même là le problème n’était pas résolu.
=> Le problème vient donc d’ailleurs et est bien lié à la distrib Dapper :frowning:

Merci beaucoup de m’avoir répondu en tout cas :slight_smile:
Edité le 28/06/2007 à 17:51

generalement, tu copies les fichiers de conf puis tu les remets en place sur ta nouvelle install et c’est termine…

C’est tout à fait normal que tu ne trouves plus de dépôts avec apt-get Breezy n’étant plus pris en charge depuis le April 13, 2007 :slight_smile: (Released October 13, 2005). Les versions LTS (Dapper Drake) sont, il me semble, supportées pendant 5 ans en version server.
Depuis Dapper il y a eu Edgy Eft et Feisty Fawn tu as essayés celles-ci pour voir si tu as toujours un problème de wifi? Sinon il y aussi les Debian Stable, là tu en as pour 2/3 ans sans bouger :D.

Bon là j’ai compilé mldonkey et ça roule bien.

Mais bon je devrais faire quelque chose car je doute de la durée de vie et de la continuité de mon système si je reste sur cette version obsolète :frowning:

Je vais donc me prendre un peu de temps lorsque je serai davantage motivé.

merci beaucoup pour votre aide.

marrant, moi j’utilise le pilote madwifi aussi avec hostapd sur une debian et j’ai pas de soucis particulier.

c’est quoi exactement ton probleme ?

Regarde ici : www.clubic.com…

(j’avais aussi essayer avec une debian sarge ou je sais pas quoi, même problème qu’avec la ubuntu dapper !)

Mise à jour de Feisty ce matin:

:smiley: