Forum Clubic

Impossible d'accéder à mes partition Windows - autrement que par Système,Administration

Tout est dans le titre, si j’accède à une partition NTFS depuis Système, Adminstration, Disque puis Parcourir je peux accéder à mes fichiers mais je clique sur Raccourcis, hda5 ou depuis un lecteur audio ou video ça me dit que je n’ai pas “les permissions nécessaires”.

De quoi cela pourrait-il venir?

Les options définies dans le fichier /etc/fstab ne doivent pas être suffisantes pour t’accorder les parmissions de lecture de cette partition.

Autrement je viens de penser: tu n’as pas créé ces racourcis en root? si c’est le cas il suffit de faire un chmod sur ces même raccourcis (man chmod pour la doc).

En fait je n’ai rien fait, ces raccourcis ont été créér à l’installation du système. Par contre je n’ai pas très bien compris comment rendre ces raccourcis fonctionnels. J’utilise Ubuntu 5.10.

salut

la commande chmod ne marchera pas sur tes partitions ntfs, tu ne peux pas changer les droits sur une partition en lecture seule

tu dois modifier ton fichier fstab

logge toi en root

edite ton fstab
il faut rajouter uid=x, ton nom d utilisateur pour qu il t attribu les droits sur ta partition, pour exemple la ligne de mon fstab qui concerne ma partition xp

/dev/hda1 /mnt/winxp ntfs defaults,uid=julien 0 0

, il faut juste que tu reperes le /dev/* qui correspond a ta partition et que tu remplaces le julien par ton nom

voila jespere que c est clair et n hesite surtout pas a faire une sauvergarde de ton fichier fstab avant de faire des manips !!!

Euh salut :D.

Tu ne saurais pas rendre mes partitions lisible sous Ubuntu par hasard?

y avait juste eu un bug lors de mon 1 er poste lol

:paf:

tiens nous au courant !! :bounce:

Pour la copie de mon fichier fstab je ne sais pas comment on fait, j’ai essayé copier/coller comme dans Windows mais ça ne fait rien. :smiley:

Et je ne sais pas comment me logger en root, vu que dans Ubuntu il n’y a pas vraiment de compte root (apparament), il faut juste entrer son mot de passe de session.

La commande “cd” pour rentrer dans les répertoires semble ne pas être exactement la même que celle du “cmd” de Windows. Je sais que pour éditer un fichier il faut utiliser “gedit” mais je ne vois pas comment l’associer au fichier “fstab” (überboulet inside).

J’ai essayé :

sudo gedit /dev/hda5 /mnt/winxp ntfs defaults,uid=heinrich 0 0

et :

sudo gedit /dev/hda5

mais aucune n’est valide :’(.

J’avoue que je patauge complètement. Ça me rappelle au début de mon utilisation de Windows quand j’essayais de comprendre comment fonctionnaient les installations/désinstallations Installshield, les éditions de fichiers *.ini, la base de registre etc… :smiley:

tu fais juste :

sudo gedit /etc/fstab

Si tu veux récupérer des fichiers linux depuis windows, tu peux utiliser l’utilitaire explore2fs.

la marche a suivre :

sudo gedit /etc/fstab

tu dois avoir une ligne du style

/dev/hda5 /mnt/winxp ntfs defaults 0 0

tu la changes en

/dev/hda5 /mnt/winxp ntfs defaults,uid=heinrich 0 0

pour la copie de ton fstab, ouvre une console superutilisateur depuis le menu application de gnome, ou alors je crois que tu peux le faire en ouvrant une console et en tapant sudo su ou sudo su- ( a verifier, je ne suis pas sous ubuntu)

puis tu tapes :

cp /etc/fstab /etc/fstab2 ou fstab2 sera la sauvegarde de ton fichier fstab

ou alors

sudo cp /etc/fstab /etc/fstab2

:wink:

Bon j’ai au moins réussi à lire le fichier fstab et voilà ce qu’il contient :

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hdb1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hdb5       /home           ext3    defaults        0       2
/dev/hda1       /media/hda1     ntfs    defaults        0       0
/dev/hda5       /media/hda5     ntfs    defaults        0       0
/dev/hdb6       none            swap    sw              0       0
/dev/hdd        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/hdc        /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0

J’ai également suivi ce tutorial mais rien n’y fait :/. http://doc.ubuntu-fr.org/installation/part…_windows?s=ntfs

—EDIT—
Erf ne jamais répondre avant de raffraichir la page :D.

modifie cette ligne :
/dev/hda1 /media/hda1 ntfs defaults 0 0

en

/dev/hda1 /media/hda1 ntfs defaults,uid=heinrich 0 0

si heinrich est ton nom d utilisateur
et redemarre ta machine

Un grand merci à vous, je peux désormais accéder à ma partition NTFS.

J’ai rajouté deux petits trucs, car je veux m’assurer que mes partitions ne soient que read only et que les accents ne soient pas convertis en %xx ce qui donne :

/dev/hda1 /media/hda1 ntfs defaults,ro,uid=heinrich, nls=utf8 0 0

Maintenant il ne me reste plus qu’à comprendre pourquoi Easy Ubuntu ne me trouve aucun des paquets qu’il est sensé m’installer et trouver un player audio qui plante moins que Rhythmbox lors du chargement de répertoires de plusieurs Go :).

Dans le genre référence il y a amarok.

Sinon dans le genre un peu plus basic et ressemblant a winamp 2 : xmms ou beep media player.

Merci, même si je suis sous Gnome j’ai choisi Amarok :).