Forum Clubic

[ HTML ] Bordures des tableaux - La couleure

Bonjour !

J’ai un petit souci que je n’arrive pas a resoudre ! J’ai crée des tableaux sur une page web, et j’ai di que je voulais que la bordure soit noir ! Et le probleme c’est quel est grise en relief un peu ! c’est super moche… ca vien de quoi ?

http://flavieflament.free.fr/cprod/index.htm

Allez sur la rubrique C-VIDEO puis sur la rubrique UNE NUIT DE REVES

et sinon dans la rubrique C-TEAM c’est pareil… :frowning:

merci d’avance !

Ce message n’était pas conforme aux règles d’utilisation du nouveau forum :

Bonjour,

Je te prierai de mettre le langage informatique dans le titre, tel que requis par la charte du forum programmation - pour une meilleure compréhension les uns des autres.

A lire :
http://www.clubic.com/forum/charte-du-foru…on-t306797.html

Pour éditer:
Suffit de cliquer sur ce bouton, dans ton message : http://www.clubic.com/forum/style_images/persoclubic/editer.gif

(note : ce message est un gros copier coller, ne pas répliquer derrière)

alors pour commencer il faudrait améliorer tes graphiques : du style entrecaler les images (c mieux pour les petites connexions)

pour tes bordures : style=“border:1px solid black”
(c’est du CSS)

Ici pour les références complètes ! :smiley:
http://www.w3schools.com/css/css_border.asp

Ou là !
http://www.w3schools.com/css/css_reference.asp

Site important à avoir en tête pour avoir tous les CSS possibles, parce que c un peu lourd à tout retenir. :kaola:

Bonjour !
utilse l’attribut bordercolor dans la balise <table> :slight_smile: :
<table bordercolor=“0000”>

Merci pour vos tuyaux, mais ca ne change rien sur Mozilla !

impossible !

donne nous ton code et ta feuille de style

parce que bordercolor n’existe pas en html.

<table style="border: 1px solid black">

</table>

Cet attribut n’est pas référencé ailleur que sur la platforme internet explorer. Ouvblie le tout de suite car il ne passera sur aucun autre navigateur.
Je te conseille grandement d’utiliser a la place du CSS (cf post de luigifab)

edit : Ou celui de Sans nom qui m’a grillé : )

Et pour ne pas mourrir con : http://www.w3.org/TR/html4/

Merci a tous pour vos reponse, c’est vraiment super sympa !!!
Je sais pas si je peux poser une autre question dans ce topic, sinon je changerai le titre !

J’ai mi une redirection www.choucroute-prod.com et quand je vais sur le site a partir de cet adresse, il n’affiche plus le titre de la page mais MOZILLA FIREFOX; on peux changer quelque chose dans les code pour quil affiche le titre que j’ai mi ?

Merci d’avance encore !

Bonjour,
apparement tu utilise des frameset, et il y a des chance que le titre soit celui de la page contenant les frameset. Donc tu est obligé de recopier le titre de la page à ce niveau

En plus, tu n’as pas besoin de frameset pour ce que tu fait, donc fait soit une redirection au niveau Apache si tu y a accès, soit en HTML avec une balise meta:
<meta http-equiv=“refresh” content=“nombre; url=http://nouvelle.adresse.ca” />

soit en javascript avec un "window.location= "+éventuellement ton frameset dans la balise noscript.

Si le meta marche bien, c’est encore le mieux.

J’ai mi le titre sur les 3 pages principale !

index.html
accueil.html
gauche.html

et il ne prend pas le titre !

c’est normal, seule le titre de la page contenant les cadres est afficher
http://fr.selfhtml.org/html/frames/index.htm

Je vais pe etre avoir l’air idiot, mais c 'est quel page qui contient les cadres ?

celle qui contient ton frameset
http://fr.selfhtml.org/html/frames/definir.htm#jeu_cadres

lit ca ^^
après tu saura tout

Voilà, c’est le index.html de
http://www.choucroute-prod.com/index.html

qui n’a pas de titre pas le index.html de flavie.flament

regarde le source (affichage-code source de la page sous Firefox)
[codebox]
<HTML>
<HEAD>
<META http-equiv=“content-type” content=“text/html; charset=ISO-8859-1”>
<script LANGUAGE=“Javascript”>
<!–
function hideStatusBar() {
window.status=’’;
window.setTimeout(hideStatusBar,10);
}
hideStatusBar();
//–>
</SCRIPT>
</HEAD>

<FRAMESET COLS=‘0,*’ border=0>
<FRAME NAME=‘blank’ border=0 marginwidth=0 marginheight=0 top=0 left=0 NORESIZE>
<FRAME NAME=‘redir’ SRC=“http://flavieflament.free.fr/cprod/index.htm” marginwidth=0 marginheight=0 top=0 left=0 NORESIZE>
<NOFRAMES>
<BODY>
</BODY>
</NOFRAMES>
</FRAMESET>
</HTML>
[/codebox]
Ce que tu appelle une “redirection” n’en n’est pas une, c’est juste un inclusion de la page dans un frameset: tu peux donc faire une “vraie” redirection avec une balise meta ou un javascript window.location=“newurl”.
:slight_smile:

Qu’est ce que tu nous a pondu la ???

Déjà dans l’entête de ta page il manque plein de chose : le tritre, la balise robots…

Ensuite tu spécifie un NOFRAMES mais tu ne met rien dans BODY pour spécifier que ton site utilise des cadres si le navigateur ne les prends pas encharges. Autent ne rien mettre.

Pour finir : <FRAME NAME=‘blank’ border=0 marginwidth=0 marginheight=0 top=0 left=0 NORESIZE>
ne sert strictement à rien, et ce n’est pas valide, il n’y a pas d’url de la page…

Lit un peu le site selfhtml ensuite tu saura comment faire ce que tu veux. La page que tu nous as codé ne sert strictement à rien !

Le code que tu a mi, c’est quoi ? je connais pas cet page ! :expressionless:

lit cette doc entièrement : http://fr.selfhtml.org/html/frames/definir.htm#jeu_cadres

la page qu’il ta montré 'est celle qui contient la définition de tes cadres !