Forum Clubic

Hal.dll

Bonjour, voilà je suis un peu embarrasser j’ai des ordinateurs chez moi et dont un sous windows 98 et moi j’aimerais bien le mettre sous windows XP professionnel mais cela mais impossible car à la moitié de l’installation il me dit que le fichier hal.dll est manquant ou endommagé :frowning: !
Mais ce que je ne comprend pas c’est que je peux tout de même accéder à windows 98 : en faite quand mon ordinateur s’allume j’ai le choix de continuer sur windows 98 ou de finir l’installation de windows XP professionnel .
Merci d’avance à ceux ou celles qui pourraient m’apporter de l’aide parceque ça fait 2 à 3 jours que je navigue sur tout plein de forums pour essayer de réparer ça mais personne n’a vraiment eu ce problème alors voilà … .
Merci d’avance .

Salut
regarde la
translate.google.fr…

Merci beaucoup à toi de m’avoir répondu mais j’ai oublié de préciser que hal.dll je l’ai télécharger et ensuite graver sur un CD et enfin mis dans le système32 comme dit dans tous les forums mais aucune différences :(, si toi ou quelqu’un d 'autres à une idée je suis tout ouïe :slight_smile:

installe le en mise a niveau
demarre sur 98 insère ton cd et installe xp en mise a niveau

Pardon du retard :wink: .
Voilà c’est fait aussi mais l’ordinateur en question se bloque dès que je met le CD XP il faut que je le renlève et là tout se débloque :wink: !!
Mais pas d’installation XP :frowning:
Une autre idée ?? :slight_smile:

c’est le fichier hal.dll qui te manque ?

Oui et non car ce fichier je l’ai bien remis dans le système 32 mais il me dit toujours fichier manquant ou endomagé :frowning:

comment ton dd est partitionné ?

normalement

c: win 98 en fat32 avec fichier boot .ini

d; win xp

j’ai trouvé ça

démmarer l’ordinateur sur une disquette de démarrage (si vous n’en possèdez pas vous pouvez en avoir une sur www.bootdisk.com)
et accédez à l’invite de commande. Entrez les commandes suivantes :
C:
edit boot.ini

Vous accéderez à BOOT.INI, par défaut il ressemble à:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Microsoft Windows XP Professionnel” /fastdetect

L’erreur provient dans la plupart des cas du numéro de la partition qui est indiqué (ça survient souvent après une installation d’un 2e système d’exploitation). Changez partition(1) pour partition(2), et si ça ne fonctionne toujours pas, changez encore de chiffre jusqu’à ce que vous soyez tombé sur le bon. Si vous ne voulez pas avoir à rééditer BOOT.INI plusieurs fois, recopiez la ligne complète après [operating systems] et changez le chiffre dans chaque, vous n’aurez qu’a essayer les différentes options qui s’offriront à vous lors du prochain démarrage.

Autre astuce:
copiez encore la ligne complète après [operating systems] et ajoutez après /fastdetect : /safeboot:minimal /sos /bootlog
Changez le nom de l’option pour “Mode Sans Échec”
Vous avez maintenant une option dans le menu qui vous permet d’accèder au mode sans échec sans avoir à peser sur F8 lors du démarrage.

sinon tu peux faire apparaitre les fichier cachés et refait un copier/collé et remplacer