Forum Clubic

Grub multiboot avec 2 * 2 disques sata raid 0

Bonjour à tous :slight_smile:

Je m’apprete a installer une gentoo sur ma machine mais je veux être sur de mon coup car j’ai des problèmes avec 2 de mes disques.

J’ai donc en config :
2* 36 Raptors (raid 0) => non reconnu par linux !
2* 120 go en (raid 0) seagate qui eux ne posent pas de problème, reconnus et accessible.

L’objectif :
Les 2 premiers disques seraient windows xp
Les autres gentoo.

Pour le multiboot je me pose la question vu que linux ne reconnait pas mes 2 raptors comment ca va se passer :confused: ?

Est-ce que linux doit reconnaitre les disques ? ici j’ai sda & sdb donc je ne vois pas ce que je devrai mettre pour booter sur les 2 premiers disques …

Ou alors est-ce que je peux gérer le multiboot via windows ? et faire un lien vers les 2 disques linux ?

Merci d’avance pour vos réponses :wink:

si ils sont en raid alors du point de vue de l’os il n’y a que 2 disques.
donc si linux voit sda et sdb alors c’est bon.

t’es ouf de mettre des disques en raid 0… si y’en a un qui foire, les donnees des 2 disques jumeaux sont perdues…

Moi, je serais toi, j’utiliserais les disques normalement et je mettrais une couche de LVM pour les coller tout en conservant une “independance materielle”.
Ainsi tu as les avantages du raid 0 (y en a t il reellement ?) sans les inconvenients (en cas de panne t’as plus rien)

Je suis depuis 2 ans en raid 0 je n’ai jamais eu de soucis …

Bon de toute façon c’est perdu d’avance c’est beaucoup trop de chipotage pour faire tourner gentoo sur du raid 0 software je laisse tomber je vais l’installer sur un ide, je crois avoir tout essayé j’abandonne …

Je me servirai du menu de la carte mère pour switcher du serial sur l’ide.

Merci quand même :slight_smile:

tu peux recapituler la ??? :ouch:
t’as du raid soft sous windows?

je comprends rien a ton montage… si tu pouvais expliquer un peu plus, on pourrait peut etre t’aider un peu plus…

c’est sur que le raid 0 quand ca marche, c’est bien… c’est quand ca marche plus que t’es dans une merde noire… toutes les donnees sont dans les choux et y’a plus rien a recup…

Je sais mon installation est un peu spécial :lol:

C’est un raid pseudo hardware, c’est bien le controleur de ma carte mère qui le gère, windows a déjà assé de mal comme ca :pt1cable:

Je suis entrain d’installer gentoo j’ai séparé mes 2 seagate donc plus de raid pour ces 2 disques :sweat: mais je crois que j’aurai bcp plus facile a m’en sortir de cette façon :slight_smile:

Sinon je préfère quand même travailler sur du raid c’est quand même beaucoup plus rapide … malgré les risques que ca comporte :frowning:

Bon emerge --sync , il y a encore du chemin a faire :frowning: