Forum Clubic

[GRUB]Config Splash - nombre limite de couleur?

Ben voila,

J’ai mis une image Splash dans mon Grub, mais je me demandait si on etait vraiment limiter à 14 couleurs comme j’ai trouver sur un site… Ce serait bien avec quelques couleurs de plus quand même (genre 256 couleurs) qui permettrait deja de mettre d’assez jolie images…

Est-ce que quelqu’un sait si la limite à été augmenter dans les dernières versions ou si il y a moyen de l’augmenter?

Merci d’avance :jap:

A ce que je vois c’est toujours la limite. C’est un peu normal quand on pense aux peu de choses dont on dispose à ce moment là du boot.
Par contre, on peut faire des imags plutôt jolies avec 14 couleurs : Google est ton ami :wink:

on ne peux pas appeler de modes vesa à ce stade du boot ?

Du temps où j’utilisais Lilo j’avais une belle nimage en 1024x768 et couleurs en 16 ou 24 bits jsais pas, mais plus que 14.

Or grub est censé être plus évolué que Lilo, je suis donc aussi étonné que toi par ces limitations :frowning:

Si cette histoire de 14 couleurs est maintenant périmée, elle a la vie dure car toutes les docs en parlent…

c’est vrai, fakbill à raison. sur mon serveur au boulot sans X j’ai un très beau splash en 24millions de couleurs :neutre:

il y avait un howto pour le splash dans une des gwn

Ben est ce que qlqn a essayé avec plus de couleurs??
C’est étange car la doc de grub est muette sur la question (ou alvors le pdf est très mal foutu…)
Le support splashimages semble ne pas être dans la baseline de grub (mais toutes les distribs utilise ce patch).

Bon, essais tantot pour voir ce que ça donne :paf:

Au pire, Grub aurra des problèmes :paf:

C’est confirmer, en 800*600 ça foire ^^

J’essaie en 640*480 avec plus de couleurs ^^

Edit:

640480 en 256 couleurs ne réussi pas… Bref, on reste en 14 couleurs et 640480… Faudra que je trouve une image en N&B ^^

Est ce que ça a qqch à voir avec l’option vga=??? ou rien du tout?? (je me le demande.)

vga= c’est quand même pour le boot du Kernel? Ou je me trompe?

je suis sur que tu peux le faire, je l’ai lu quelque part, en fait il faut juste ajouter la taille de ton image et le nbre de couleur
attends je vais te trouver ça :stuck_out_tongue:
http://www.linuxquestions.org/questions/sh…goto=nextnewest
http://www.linuxforum.com/forums/index.php?showtopic=13501

et les valeurs :
771 800×600 256色
773 1024×768 256色
775 1280×1024 256色
788 800×600 65,536色
791 1024×768 65,536色
794 1280×1024 65,536色
789 800×600 1677万色
792 1024×768 1677万色
795 1280×1024 1677万色
m’enfin je suis pas certain de ce dernier truc

que nenni :MDR , l’option vga est une option que tu mets dans ton kernel pour modifier la resolution de ton framebuffer…
un vga=0x360 ou vga=795 te permettra dans le premier cas d’avoir un fb en 1280x800 (16bits – à verifier ) et le second un fb en 1280x1024 (16bits – à verifier)
De plus, j’ai vu sur une mandrake “ennemie” que tu pouvais des bootsplash via lilo en 24bits… et d’ailleurs, ça s’appele bootsplash le soft en question… kbootsplash je crois pour le soft de config pour kde…

Oui oui vga= c’est pour régler le framebuffer une fois le noyau lancé.
Mais bon, l’affichage de l’image par grub montre bien qu’il fait aussi utliser le framebuffer.
C’est just epour ça que j’évoquais l’option vga=.
Le pb c’est que la gestion du frame buffer oar grub semble très limitée.

http://www.minet.net/spip/article.php3?id_article=121
http://www.bootsplash.org/
Ca à l’air cool mais à ce que je vois ça gère “the graphical boot process for the linux kernel” donc c’est pas ça qui va permettre de mettre une belle image dans grub. Par contre, pour la suite du boot, ça peut faire joli.

Pour grub la question reste donc ouverte.

Faudrait essayer http://www.trustonme.net/didactels/286.html#deb pour voir…

bootsplash sous debian et fbsplash/gensplash sous gentoo, etc, c’est APRES le chargement du noyau donc pas du tout pour grub ou lilo

http://ruslug.rutgers.edu/%7Emcgrof/grub-images/

mouais, il me semblait bien l’avoir vu kek part tout de même

Conclusion… On est toujours en 640*480 en 14 couleurs ^^

les “{grub,lilo} splash howto” c’est pour que {grub,lilo} charge correctement ce qu’il faut pour avoir un beau splash en console, pas pour modifier leur apparence à eux :wink:

Bien que, je répète, avec lilo on peut avoir des images dans la résolution qu’on veut… ça viendra sans doute avec grub

Oui ça doit donc être la gestion du framebuffer de grub qui est limité à ça.
ps : le frambuffer est la façon la plus simple d’afficher qqch : on écrit directement dans le bon buffer de la carte graphique.

Grub 2 qui est disponible dans vos paquets peut changer sa résolution d’écran en quelque chose d’autre que du 640*480. Le fichier Grub.cfg qui remplace le fichier menu.lst permet de changer sa résolution d’écran (Je vous conseille par contre de chercher des tutos pour l’installer sans problèmes:

[i]#

DO NOT EDIT THIS FILE

It is automatically generated by /usr/sbin/update-grub using templates

from /etc/grub.d and settings from /etc/default/grub

BEGIN /etc/grub.d/00_header

set default=0
set timeout=5
set root=(hd0,5)
if font (hd0,5)/usr/share/grub/unicode.pff ; then
set gfxmode=1280x1024
insmod gfxterm
insmod vbe
terminal gfxterm
fi

END /etc/grub.d/00_header

BEGIN /etc/grub.d/05_debian_theme

set menu_color_normal=cyan/blue
set menu_color_highlight=white/blue

END /etc/grub.d/05_debian_theme

BEGIN /etc/grub.d/10_hurd

END /etc/grub.d/10_hurd

BEGIN /etc/grub.d/10_linux

menuentry “Ubuntu, linux 2.6.24-19-generic” {
linux (hd0,5)/boot/vmlinuz-2.6.24-19-generic root=UUID=c82b182d-2009-48db-8615-b63032ff39f3 ro quiet splash
initrd (hd0,5)/boot/initrd.img-2.6.24-19-generic
}
menuentry “Ubuntu, linux 2.6.24-19-generic (single-user mode)” {
linux (hd0,5)/boot/vmlinuz-2.6.24-19-generic root=UUID=c82b182d-2009-48db-8615-b63032ff39f3 ro single
initrd (hd0,5)/boot/initrd.img-2.6.24-19-generic
}
menuentry “Ubuntu, linux 2.6.24-16-generic” {
linux (hd0,5)/boot/vmlinuz-2.6.24-16-generic root=UUID=c82b182d-2009-48db-8615-b63032ff39f3 ro quiet splash
initrd (hd0,5)/boot/initrd.img-2.6.24-16-generic
}
menuentry “Ubuntu, linux 2.6.24-16-generic (single-user mode)” {
linux (hd0,5)/boot/vmlinuz-2.6.24-16-generic root=UUID=c82b182d-2009-48db-8615-b63032ff39f3 ro single
initrd (hd0,5)/boot/initrd.img-2.6.24-16-generic
}

END /etc/grub.d/10_linux

BEGIN /etc/grub.d/20_memtest86+

menuentry “Memory test (memtest86+)” {
linux (hd0,5)/boot/memtest86+.bin
}

END /etc/grub.d/20_memtest86+ ###[/i]