Forum Clubic

Gentoo x86_64 compatible avec tout ? - ou pas ?

Salut :hello:
J’ai commencé mon install de gentoo x86_64 sur mon amd64 3800+ X2 :love: :love: mais un copain me dit que ca pose pas mal de problèmes genre driver video tout ca tout ca.
Sur le site de cedega il disent qu’ils faut “32-bit Linux environment”

Donc vous en pensez quoi ? Je continue mon installation en 64bits ou je recommence tout en 32bits ? :neutre:

Si tu n’es pas sur de ce que tu fais, fais le en 32 bits !
(Au passage, si tu nes pas sur de ce que tu fais, gentoo n’est peut-être pas la meilleur distribution pour toi…)

Sache qu’il est tout à fait possible de faire fonctionner cedega sur un système 64 bits (je le fais chez moi ainsi que d’autres programmes…), mais ce dernier, comme tout programme 32 bits qui tourne sur un systeme 64 bits, a besoin d’un version de TOUTES les librairies ET leurs dépendances dont il se sert en 32 bits (le fameux “32 bits linux environment” de cedega)

Il y a plusieurs façon de faire cela, et je pense que ça doit être expliqué en détail sur les forums de gentoo.

edit : pour ce qui es des drivers, tu auras peut-être des problèmes si tu veux utiliser des trucs proprios qui ne fournissent qu’une version compilée en 32 bits.

:hello:,
je suis sous une Gentoo x86_64 au quotidien, pas de souci de nos jours (je n’ai pas de chroot), le profil 2005.* étant multilib (cad que via les paquets emu-** instalables ensuite, les bonnes libs sont utilisées pour les programmes qui demandent ces libs spécifiques 32 bits).

Bref, pour résumé, pas de souci et c’est transparent pour l’utilisateur.

Pour cedega, ça fonctionne très bien.

Si tu as d’autres questions, pas de souci, demande ;).

edit : je te conseille un 2.6.15.* aussi comme noyau.

edit2 : tu as des programmes spécifiques à faire tourner (+ exemples, le cas échéant) ?

Par exemple les codecs pour le wmv ?

Bon vous m’avez rasuré tous les deux :smiley: merci bien.
je vais donc pouvoir faire mon emerge --resume en rentrant chez moi et j’irais fouiner le forum de gentoo pour voir comment faire marcher cedega :slight_smile:

a+ :whistle:

Tu dois installer mplayer-bin pour avoir ces codecs actifs.

Pour cedega, pas de souci via le binaire et les paquets emu ;).

Tout ce que tu cites fonctionne très bien (quoique je ne vois pas ce qu’est Ha :D).

Pour Firefox, je te conseille le firefox-bin, pour une question de plugins (note que la version 64 bits fonctionne, mais il est préférable de prendre la 32 bits, pour une question de cohérence avec mplayer-bin).
Sinon, Konqueror 64 bits fonctionne très bien, tous plugins actifs (cf le forum Gentoo, pour le flash, il y a un ebuild qui va bien).

C’est le navigateur que j’utilise au quotidien.

nb : ln -s /usr/bin/mplayer-bin /usr/bin/mplayer à faire pour activer le plugin mplayer dans les navigateurs 32 bits.

nb2 : opera fonctionne bien également (c’est un binaire 32 bits).

edit : pour OO, c’est aussi ok, avec le binaire (la version finale 2.0.2 devrait être compilable en 64 bits)

http://img400.imageshack.us/img400/6687/oo9tc.th.png

Ok ok
J’espère que j’aurais le temps de voir ca ce soir mais c’est pas gagné avec le kde a finir d’emerge et le X a configurer + la sieste + le squatte des potes (une bande de pro-windows indécrottables) :ane:

Quand je pense à la liste des trucs qu’il me reste à faire pour avoir un joli truc tout customisé qui marche du feu… oulalalala :paf:

Par contre, si tu as une carte nvidia, attends toi à du sport pour faire marcher le framebuffer en x86_64. Si quelqu’un a des infos là-dessus, je suis preneur :smiley:

Bah le framebuffer à part pour avoir des belles console … (bon j’avoue que ca claque)

Le support du framebuffer en console n’est pas un problème, le seul mode actif en 64 Bits est le vesafb.

Pour ce qui est des applications 32 Bits, il y a moyen de creer dans le système 64Bits, un environnement 32Bits chrooter pour y faire tourner les applicatiosn ne fonctionnant QUE sous 32Bits (openoffice par exemple).

Et pour information, les derniers drivers Nvidia résolvent pas mal de problèmes. Ils sont masqués ~amd64…version —> 1.0.8-x

Si tu connais un moyen de faire marcher le framebuffer avec une 6600GT en 64 bits, je suis preneur! J’ai personnellement essayé les pilotes vesa, vesafb, vesafb-tng, rivafb, aucun ne marche…

Pis aussi je pense que le chroot a peu d’intérêt maintenant, vu que les développeurs gentoo amd64 sont de plus en plus nombreux, et le nombre d’applis dispo a été grandement multiplié l’année dernière. C’est du tout bon.

je n’arrive pas à cerner ton problème…tu as des erreurs en particulier ? le pilote vesafb sous 64 et rien d’autres. Chez moi, je n’ai aucune configuration spécifique…Tu as mis quoi dans ton noyau au niveau des Drivers --> Graphics ?

Nag.

Je les ai tous essayés, un par un, j’ai droit à un belle erreur à chaque fois, puis le noyau continue son boot avec des polices tailles 24 :smiley:
Sérieusement, je pense que c’est peut-être un problème de ma carte vidéo. Il parait qu’il faut utiliser vesafb-tng pour les nvidias récentes…

Peux tu coller tes erreurs et tes configs ?

Ah non, je reéssaie pas :smiley: Ca m’a pris trop de temps… Sérieusement j’ai pas du tout envie de m’y remettre, j’ai fait le deuil du framebuffer…

J’utilise le vesafb pour le framebuffer avec une 6600GT, et je n’ai rien fait de plus dessus qu’avec la geforce4 MX de mon portable 32 bits…

Parcontre, le nvidiafb, ils disent clairement que ça marche pas.

Et le fbsplash marche impec, toujours sans rien faire de plus qu’en 32 bits.

Ben t’en as de la chance :smiley: Au bout d’un moment, ça m’a tellement pris la tête que j’ai laissé tomber. Tu utilises lilo, ou grub? Si tu as lilo, tu peux me mettre ton fichier lilo.conf?
Merci d’avance
ET

Chuis moderne moi, j’utilise Grub :o