Forum Clubic

[Gentoo] pentium-m (et nptl en bonus)

Coucou les gens :slight_smile:

Je suis en train de finaliser l’install d’une 2005.0 et je me suis vachement galéré pour faire marcher xorg (ATI en force…).

Apres avoir pris le noyau 2.6.10 ca baigne donc je suis content (compil de E17 en ce moment même).

Et la c’est le drame, je flane sur le forum fr de gentoo et je vois un guide pour faire une install avec gcc-3.4 et donc le flag pentium-m dispo (moi j’avais simplement mis pentium3 et sse2 puisque gcc-3.3 connait que ca), et aussi NPTL que c’est plus mieux même si j’ai pas compris tous les tenants et aboutissants.

Alors en gros, si maintenant je suis leur truc (unmask gcc-3.4, migration et changement des cflags en consequence, et nptl dans mes USE), je vais aboutir a la même chose au gré des MAJ (ou alors avec un ptit emerge -e world nocturne a la rigueur) ou je vais tout peter ?

Voilà, ce que c’est de mal ou de ne pas se renseigner avant de faire l’installation :o.

Sinon, je pense que l’emerge du system devrait suffir :wink: (ensuite, j’ai pas regardé les pentium m, je suis avec un amd64 là :p).
Enfin, ça recompilera au fur et un mesure (bon, tu peux faire l’emerge world si tu veux aussi, ça dépend de ton temps quoi).

edit : et avec une ATI en plus :grrr:.

Promis la prochaine distrib que j’installe je lis l’intégralité du forum officiel :paf:

Ou pas en fait :ane:

Pour gcc, donc, a priori, si j’emerge un toolkit 3.4 et que je le re-emerge avec lui-meme et des cflags adaptés, a priori j’aurai donc plus qu’a attendre ou faire un emerge -e world…

Et pour NPTL si je l’ajoute aux USE, pareil les applis migreront au gré des recompiles (ou lors d’une recompil complete) ? Ou faut s’y prendre autrement si on a … oublié :ane:

P.S. : l’ATI spa ma faute ils faisaient pas le XB7 avec nVidia :whistle:

–newuse est ton ami aussi ;).