Forum Clubic

Gentoo installe probème de boot

Bonjour à tous, voilà, j’ai réessayé l’install de gentoo !J’ai bien essayé de m’appliqué ! Je pense avoir tout fait correctement, mais je rencontre un problème lors du boot !

Démarrage avec grub -> “Filesystem couldn’t be fixed”

Il me demande alors d’entrer mon mot de pass pour maintenance ou crtl-D pour démarrer normalement !

le démarrage normale ne donne rien évidemment, et une fois en ligne de commande, que dois je faire …

Mes partitions:

hda1 * /boot (en ext2)
hda2 swap
hda3 / (en Reiserfs)

kernel-2.6.11-gentoo-r3

Qui pourrait éclairé ma lanterne ? je pensais d’abord que j’avais un soucis dans mon /etc/fstab
mais après avoir réussi à l’éditer, il me semble correct …

Je ne peux pas donner son contenu maintenant car là je suis au boulot !

sur /dev/hda1 :

e2fsck -c /dev/hda1

sur hda3 :

reiserfsck -c /dev/hda3

Ton système a dû être arrêté de manière brutale et il semble que ça ne lui ai pas plus. A moins qu’il ne manque une option pour reiserfs dans le fstab…

Mezrci j’essaye ça ce soir et je dis quoi !

En gros pour mon/etc/fstab, j’ai ça

[fixed]/dev/hda1 /boot ext2 defaults,noatime 1 2
/dev/hda2 none swap sw 0 0
/dev/hda3 / reiserfs noatime,notail 0 1

none /proc proc defaults 0 0
none /dev/shm tmpfs nodev,nosuid,noexec 0 0

/dev/cdroms/cdrom0 /mnt/cdrom auto noauto,user 0 0
none /proc/bus/usb usbfs defaults 0 0 [/fixed]

ça vous semble ± correct ?

Je précise que j’ai fais un stage 3, avant de me lancer plus loin pour voir si j’y arrive !

Y a t’il d’autres choses à faire qui ne soient dans la doc gentoo ?

Moi, ça me paraît correct.
Après, j’pense pas qu’il y a ai des trucs “non documentés” à faire (on n’est pas sous Windows là ! :D). Pour ma part, j’ai commencé mes 2 Gentoo depuis l’étape 1

C’est bon, c’est réglé … :slight_smile:

Donne la solution :stuck_out_tongue:

[:calbar] En faitr j’ai recommencé l’install , il y a de ça 2 jours déjà [:ane_rit] , j’avais du oublier des trucs dans mon make menuconfig …, et depuis d’autres soucis, notament au niveau de ma config grub ! Mais bon, c’est du passé …loool

J’ai fini l’emerge de KDE et de firefox … j’ai mis tout ça en français. Reste la suite !

t’avais du oublier de mettre le module reiserfs en dur