Forum Clubic

Framework 2.0

Bonjour,

Après quelques difficultés de nettoyage d’un pc portable infesté de programmes inutiles et autres virus, je souhaite désinstaller et réinstaller proprement les frameworks et les bibliothèques C++.

j’ai reussi à réinstaller la version 1.1, mais j’ai un problème pour la 2.0

Dans programmes et fonctionnalités, apparaissent les versions 1.1 et la version 4 (client profile) des framework.
Lorsque je veux installer la version 2.0, l’installeur me dit qu’elle est deja présente dans le systeme, et lorsque je souhaite installer la 3.5, l’installation s’arrete aores quelques minutes, avec un message d’erreur sans informations.

J’ai essayé de lancer le logiciel “dotnetfx cleanup tool” qui ne me detecte que les versions 1.0, 1.1, 3.5 et 4.
Pourtant, le registre de l’ordinateur contient des clés relatives au framework 2.0.

Comment puis je faire alors pour effectivement supprimer cette 2.0, alors qu’elle n’est pas visible dans programmes et fonctionnalités?

Je fais tout ceci pour remédier au probleme de l’erreur 1935, qui fait que le pc refuse d’installer un nombre important de programmes (ad aware entre autres), avec un message d’erreur citant quelque chose comme “an error occured during the installation of assembly microsoft.VC90.ATL”, suivi de “public key token” avec une serie de chiffres et lettres et “processor architecture=amd64, type=win32”

J’ai consulté des tonnes de forums, mais pas de réponse satisfaisante.

Merci au(x) génie(s) capable(s) de m’apporter une solution!

Je suis sur un pc HP Pavilion tournant sous windows vista 32 bits.

Bon courage et merci encore!

Bonjour.

Ouvrir le registre , puis déployer cette branche :
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CuurrentVersion\Uninstall
Cliquer sur chaque clé commençant par le caractère “{”
Sur le volet de droite , regarder si la valeur DisplayName contient .NET Framework 2.0

microsoft.VC90 c’est pas plutot juste un besoin de vcredist 2008 ce type de fichier ? (vc80 = 2005, vc90= vcredist 2008, vc100=2010)

net framework 2 est inclus par defaut dans vista me semble, tu devrais le voir dans programmes et fonctionnalité -> activer ou desactiver les fonctionnalites windows
faire des modifications sur net framework 2 n’est donc pas chose aisée du coup, peut etre faire une reparation systeme? , mais si il y a eu plein de mise a jour c’est peut etre pas recommandé
Edité le 05/07/2012 à 13:19

Merci de vos réponses.

Foxburry, dans le dossier que tu indiques, aucune entrée ne contient le nom de .NET Framework 2.0

Feunoir, j’ai essayé de reinstaller toutes les versions de vcredist, mais lorsque je lance l’installation, j’ai a nouveau un message d’erreur 1935, avec au choix VC80 ou VC90…
Je précise également que windowsupdate ne parvient pas a installer les mises a jour KB951847 et KB 973688 relatives entre autre aux frameworks.

Je n’avais jamais rencontré ce problème avant et ça commence à me rendre fou^^