Forum Clubic

Formule EXCEL pour lier 2 colonnes

Soit la colonne A comprenant un chiffre par cellule de 1 à 2 et la colonne B comprenant un nombre d’heures.
Avec quelle formule je pourrais faire correspondre les 2 colonnes de façon à ce que si par exemple dans la cellule A1, A2,A3,etc… il y a le chiffre 2 alors dans la cellule C1 il y aura la somme des cellules B1, B2, B3, etc…

D’avance merci

Salut,

Il me semble que pour faire ça il va te falloir faire une macro donc de la programmation en Visual basic. Je ne pense pas qu’avec des formules tu puisses y arriver.

tu pourras trouver une aide ici : pagesperso-orange.fr…

Si j’ai bien compris la question, il s’agit de faire la somme des cellules de la colonne B qui ont en regard un 1 (ou un 2) dans la colonne A
Pas besoin de macro, il y a la fonction sommeprod() qui est faite pour ca

C’est exactement ça gcc. Où puis-je trouver cette formule? La connais-tu?

OK j’ai trouvé . Ca fonctionne avec =SOMME.SI(plage;critère;somme_plage)

effectivement dans ton cas, somme.si() convient mieux que sommeprod()
Sinon, pour connaître le fonctionnement d’une fonction, il suffit de regarder dans l’aide en ligne d’excel (touche F1)