Forum Clubic

Formule Excel NB.SI ? - Formule Excel NB.SI ?

Bonjour à tous,

J’ai un petit pb. Dans un tableau, dans le colone A, j’ai une liste de référence allant de 1 à 10000, dans la colonne B, j’ai le mot OUI ou NON.
je souhaiterais savoir combien de référence ont le mot OUI, mais en spécifiant des bornes. C’est à dire, que je souhaite savoir combien de référence ont le mot OUI entre la référence 5 et la référence 150.

Quelqu’un peut-il m’aider ? J’ai pensé à NB.SI, mais sans succés.

Merci d’avance.

Si les références sont 1,2,3,4,5…10000
tu peux utiliser cette formule
(D4 et E4 contiennent les 2 bornes)

=NB.SI(INDIRECT("B" & TEXTE(D4;"0") & ":B" & TEXTE(E4;"0"));"OUI")

Ps: Si tes références commencent par exemple à la ligne 5, tu mets bien sûr dans la formule D4+4 et E4+4

En fait mes références, ne sont pas 1,2,3,4,…10000, mais sont du genre 050425, 050426, jusqu’a 198028638 par exemple, et toutes les références ne sont pas incrémenté de 1 a la fois. les références passent de 050426 à 050435 par exemple.
Ce que je souhaiterais, c’est d’indiquer directement les références servant de bornes dans la formules.

Je continue de chercher de mon coté.
Merci quand même pour ta réponse.

tu vas être obliger de passer par une macro si tu veux faire cela…

Je pense que Joueur67 ne parlait du contenu des cellules mais du numéro de ligne en fait (donc de B1 à B10000), avec le numéro de ligne de début en D4 (par exemple : 1 pour B1) et le numéro de ligne de fin en E4 (par exemple : 10000 pour B10000).

En revanche je n’ai pas compris pourquoi ajouter 4 dans son exemple puisqu’il devrait suffir de modifier les bornesdont les numéros de lignes sont contenus dans D4 et E4 (si j’ai bien compris…).

Alors il faut que tu trouves le rang des bornes.

=NB.SI(INDIRECT("B" & TEXTE(RANG(050425;A1:A10000;1);"0") & ":B" & TEXTE(RANG(19000150;A1:A10000;1);"0"));"OUI")

Si ta liste ne commence pas à la première ligne tu dois modifier un peu la formule