Forum Clubic

Formule conditionnelle dans excel

Bonjour,

Je voudrais créer une formule conditionnelle pour que l’année soit extraite par colonne c’est à dire : j’ai une colonne A avec des années (2013,2014, 2015 etc…) et je voudrais extraire 2013 dans la colonne B, 2014 dans la colonne C,2015 dans la colonne D etc…

Merci d’avance

Donne de plus amples explications, ou mets le fichier sur http://cjoint.com/ en y incluant tes explications (de quoi tu démarres==>ce que tu voudrais). C’est plus facile pour ceux qui voudront t’aider

T’as pas deja posé la question dans http://www.clubic.com/forum/logiciel-general/formule-si-dans-excel-id880747-page1.html ??
a laquelle tu n’avais pas donné de retour ??
Edité le 22/06/2013 à 17:06

En fait ce n’est pas tout à fait la même chose que ce que j’avais demandé. Dans le cas présent j’ai une colonne avec des dates : exemple cellule A1 : 14/07/2013, cellule A2 : 15/07/2014, etcc…mais je voudrais avoir mes dates dans des colonnes différentes. Soit si c’est 2013 je le voudrais dans la colonne B, 2014 dans la colonne C, 2015 dans lacolonne D etc.
Merci !

Bonjour,

Il y a une solution qui fonctionne avec une “formule conditionnelle” comme tu le demandes :

  • en B1 tu entres la formule =SI(ANNEE($A1)=COLONNE()+2011;$A1;"")
  • tu mets la cellule B1 en format date
  • tu recopies cette formule de C1, D1, E1, F1, etc.
  • tu recopies les cellules B1, C1, D1, E1, F1, etc. sur les lignes suivantes.

Parfait ! un grand merci !

Bon week end !:slight_smile:

:super:

Merci et bon week-end à toi également. :wink: