Forum Clubic

Fichier index.htlm en index d'une page de mon site

Bonjour;

Pour résumer le plus simplement et plus clairement possible : j’ai un site , je voudrai créer un dossier photo et lorsque l’on rentre dans ce dossier, le fichier index.htlm soit l’index de ce dossier.

mon site : ********.free.fr/photo/CE_DOSSIER

A l’intérieur de CE_DOSSIER j’ai :

  • swfobject.js
  • viewer.swf
  • index.html
  • readme.html
  • gallery.xml

Je voudrai qu’en entrant dans CE_DOSSIER , le fichier index.htlm s’ouvre en premier, parce que lorsque j’ouvre CE_DOSSIER, c’est la liste des fichiers cités auparavant qui apparait et non le fichier qui s’ouvre.

Merci D’avance.:yeux1:

Essaye index.html…

evidement c’etait une erreur de a part sur le forum qui n’est pas effective.

Quelqu’un pour m’aider svp

Si ton site tourne sous Apache, regarde du côté de la directive “DirectoryIndex” :super:

Vérifie que index.html est bien écrit tout en minuscules
pas Index.html ou index.HTML, par exemple.

As_tu le même problème pour les autres répertoires de ton site ?

c’est bient en minuscule.Pour ce site je n’est actuellement que 2 repertoires, et le premier c’est un index.php qui fonctionne parfaitement.Je me pose une question, peut etre les html ne sont pas pris en compte par l’hebregeur?question peut etre bete je ne sais pas je ne suis pas un expert.C’est un site heberger par free…Quelqu’un aurait une solution?.
Edité le 04/07/2009 à 11:46

Normalement, avec free, c’est bien index.html qui devrait être pris par défaut.
Essaie de créer un répertoire supplémentaire avec dedans un index.html voir si cela fonctionne.
Ou mets in index.html au même niveau que ton index.php, il devrait être pris prioritairement.
Tu pourrais aussi donner l’adresse de ton site, au cas où …
(avant, tu migres quand même provisoirement tes photos vers un autre répertoire , et tu ne laisses que des choses “consultables”)

J’ai fait comme tu m’as dit mais le php agit toujours comme si le html n’était pas la,par contre le html ne s’affiche pas dans la liste comme dans son dossier d’origine. Et le html qui ne fonctionne pas comme il le faudrai se trouve dans le dossier phoro / Keylia_Leyna.
C’est l’index.html de “SimpleViewer” qui ne s’execute pas, par contre il fonctionne car en cliquant dessus, le viewer se lance bien et fonctionne. (La j’ai retiré les photos mais j’en avait mi auparavant)
Edité le 12/08/2010 à 19:42

Pourquoi as-tu créé un répertoire qui s’appelle index.php à la racine de ton site ?
index.php c’est en principe un nom de fichier, et qui plus est un fichier contenant du code php, donc de la programmation (ce qui suppose au passage que tu aies auparavant activé le php sur ton serveur, ce qui n’est pas fait par défaut chez free)

et pas de trace du dossier phoro / Keylia_Leyna
Déjà, ce ne serait pas Photo ?
Avec un t, mais aussi un P majuscule, le serveur est sensible à la casse

et puis je ne pense pas qu’il y ait des espaces autour du “/”

Tu as du te connecter au site au moment ou je faisais des essais alors voila j’ai remi exactement comme je l’avais decris dans mon dernier message.Là Tout est d’origine, j’ai laisse le viewer par defaut (tel que lorsque je l’ai telecharger , et l’interface de mon site que j’ai telecharger egalement) . La seule chose que j’ai fait c’est : Créer un dossier photo , un dossier et mettre mon viewer dans ce dossier. C’est tout je n’ai toucher a rien d’autre , et pour faire c’est site , j’ai simplement activé les page MySQL sur Free.
Edité le 12/08/2010 à 19:42

Tu utilises un client ftp pour mettre tes fichiers sur ton site ?
Si oui, fais une copie d’écran de l’arborescence telle que tu la vois en ftp, parce que j’ai l’impression de ce qu’on voit à l’écran à travers ton logiciel de présentation est purement virtuel.
Cela expliquerait pourquoi le index.html ne s’active pas par défaut

desolé je ne vois pas ce que tu veux que je fasse,si tu pouvais reformuler stp.

Il faudrait que tu dises de quels outils tu te sers pour concevoir tes pages, puis ensuite pour les mettre en ligne sur ton serveur

FTP expert 3

Et quand tu regardes le contenu de ton serveur avec FTP expert 3, tu vois exactement les mêmes fichiers/répertoires que ceux qui s’affichent quand on tape l’adresse du site ?

Dans les dossier oui (vu que mon index.html ne fonctionne pas dans mon dossier .A la racine du site, je ne vois qu’un dossier sur le site alors que dans FTP Expert je vois plein de fichier .php…etc

Ca doit provenir du contenu de ton fichier index.php
Vérifie tes lignes de code

Honnetement je ne penses pas, je n’ai pas codé moi même le fichier, c’est enfète SimpleViewer , un petit “programme” qui permet de mettre un lecteur de photos en flash sur mon site, et le lecteur marche parfaitement puisque si je clic sur le index.html il se lance et fonctionne correctement, c’est juste qu’il ne se lance pas seul…

Effectivement, ce n’est pas une erreur de code à proprement parler, c’est que le programme que tu utilises n’est pas fait pour ce que tu en attends.
Quand tu lances en tapant juste ton adresse, tu te déplaces ensuite à travers le logiciel et non directement à travers l’arborescence du site.
Et ton logiciel ne semble pas conçu pour lancer directement les index.html quand il les rencontre (ou alors, tu as raté une option quelque part)

Tu peux facilement le vérifier en entrant sur ton site non pas à la racine, mais directement dans le répertoire root :
http://noizet.damien.free.fr/root/
Comme celui-ci n’a pas de index.html (ni .php) tu vas avoir l’arborescence réelle du site et tu vas pouvoir naviguer avec les liens par défaut. Là tu verras que le http://noizet.damien.free.fr/root/photos/keylia_leyna/index.html se lance bien automatiquement

Effectivement tu as raison, donc si je change de programme je résouds mon probleme ? si oui peux tu m’en conseiller un ?

Merci beaucoup en tout cas de ta précieuse aide .