Forum Clubic

Fichier client openvpn

bonjour a tous

j’ai creer un vpn avec openvpn avec une cle static en 2048bits (par la suite je passerai par certificats mais une etape a la fois)

cependant du coté du client, je n’arrive pas a faire reconnaitre la clé
openvpn me dit que le fichier est introuvable
pourtant ce fichier static.key (en format .txt codage ANSI) est bien mis dans le fichier c:\program files\openvpn\config

j’avoue que j’en perds mon latin …
voici le log du cote client :

Use the following for simple connections:

remote XXXX.dyndns.org
port 1194
dev tap
secret static.key
proto udp
comp-lzo

merci pour vos futures reponses
Edité le 02/02/2010 à 21:54

Salut,

la ligne: secret static.key

static.key dois etre en fait l’emplacement du fichier key.
exemple:
secret c:\mesclés\static.key
ou par exmple
secret /tmp/static.key

:yeux4:

ah bon

je croyais que c’etait dans c:\program files\openvpn\config

bon je vais essayer

merci

ce n’étais que des exemples.

après il est possible que si ton fichier contenant la clé est dans le meme repertoire que le fichier de config il n’y ai pas besoin de lui spécifier le chemain mais juste le nom.

merci en fait ca viendrait de mon petit portable
j’ai essaye sur un autre et la ca marche

et il fallait rajouter static.key.txt

merci bien

oui le nom du chier ^^

je pensais que tu savais ca :stuck_out_tongue:

l’ extention fait partie du nom d’un fichier.
tu peux modifier l’extention mais pour ca faut aller dans panneau de config\option des dossier\affichage\afficher les extentions

et la en renommant un fichier tu peux aussi changer l’extention.

Bein c’est cool que ca marche, tu passera le bonjour a hugodu13 :wink:

euh en fait ca ne marche pas

mais effectivement hugodu13 essaye de m’aider
il a bien du courage …:):slight_smile:

et dans le tuto de dd wrt c pas marque static.key.txt

www.dd-wrt.com…

merci encore

edit : message transmis a hugodu13

cordialement
Edité le 02/02/2010 à 12:50

dans ce cas fait comme j’ai dit, tu renomme ton fichier en static.key tout court !

va dans options des dossiers decoche masquer les extentions dont le type est connu, renomme ton fichier static.key.txt en static.key

dans le fichier de conf du client met juste
secret static.key

et roule ma poule :slight_smile:

en fait non je me suis mal exprimé cote client ca marche

mais a priori c du coté du routeur que ca ne fonctionnait pas (en fait hier)

mais la j’ai lance mon client depuis mon pc principal avec le fichier client

Use the following for simple connections:
remote 192.168.1.1
port 1194
dev tap
secret static.key.txt
proto udp
comp-lzo

comme ca juste pour voir et la mes 2 carres sont vert:ouch::ouch::ouch:

donc la je vais essayer avec mon pc portable en me connectant via le freewifi

EDIT ca n’a pas marche

mais j’ai utilisé une autre syntaxe et

LA CA MARCHE

voici donc la syntaxe pour le serveur ici le wrt54gs

openvpn --mktun --dev tap0
brctl addif br0 tap0
ifconfig tap0 0.0.0.0 promisc up
echo "
-----BEGIN OpenVPN Static key V1-----

TA CLE SSL ICI(confidentielle)

-----END OpenVPN Static key V1-----
" > /tmp/static.key
ln -s /usr/sbin/openvpn /tmp/myvpn
/tmp/myvpn --dev tap0 --secret /tmp/static.key --comp-lzo --port 443 --proto tcp-server --verb 3 --daemon

save startup

pour le firewall

iptables -I INPUT 1 -p tcp --dport 443 -j ACCEPT

pour le client
remote xx.xx.xx.xx
port 443
dev tap
secret key.txt
proto tcp-client
comp-lzo

voila si ca peut aider les autres
merci a Mc Kagan sur un autre forum

cordialement
Edité le 02/02/2010 à 21:53