Forum Clubic

FC5 : voir sa partition XP - Help requested please !

Je dédie ce post à tous ceux comme moi qui se lancent dans l’aventure linux et qui sont des véritables burnes avec l’informatique

Etape 1 : Installer le truc qui fait lire les partititions !

=> 2 cas : les partitions, c’est du NTFS ou c’est du FAT32

Apparement, si c’est du NTFS, il faut suivre la procédure suivante pour installer un driver
(on peut d’ailleur se demander pourquoi il n’est pas installé en natif… mais bref…)

on ben c’est parti alors !!
J’ouve un terminal et je me lance !!!

[root@linux ~]# yum -y install kmod-ntfs
Je tape entree…
et voici ce que me sort le systeme

Loading “installonlyn” plugin
Setting up Install Process
Setting up repositories
core [1/3]
core 100% |=========================| 1.1 kB 00:00
updates [2/3]
updates 100% |=========================| 1.2 kB 00:00
extras [3/3]
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: kmod-ntfs
Nothing to do

Personellement… Nothing to do est peu clair
Ca signifie qu’il a fait le boulot ? ou bien qu’il a planté ???

Bon… on va dire qu’il a fait le taff

Bon…
Etape 2bis : Une fois le module chargé, tu modifie ton fstab avec les bons point de montage

Alors la… des questions en voila :
On le trouve ou ce fstab ?
On le modifie comment ? (on rajoutte des lignes ?)
On les récupère ou les points de montage ? (perso c’est pas le genre de truc que je connais de tete…)

Merci de vos réponses… pour l’étape 3 !

1- Avec des source bien configurées : c’est fait ? -> cf les liens que je t’avais donné.

2- fstab : si tu ne connais pas ce terme, tu me sembles un peu limite en connaissance linux ;).
Le fstab, c’est le fichier qui se trouve à l’endroit /etc/fstab et c’est lui qui possède les infos utiles pour monter tes partitions.
Mount donne les partitions montées, comme je te l’ai déjà dit.

Bref, tu devrais faire un tour sur Léa (lea-linux, cf Google), pour revoir 2/3 notions fondamentales, sinon, tu risques de ne pas comprendre les indications que l’on pourraient te donner.

Ensuite, tu configures proprement tes sources (cf les faqs et docs FC5), puis concernant les services et leur activation, c’est sûrement dans le doc de FC (en tout cas, sous Gentoo, ça fonctionne différemment, donc je ne peux pas t’aider sur ce point, mais, ça se trouve très facilement à mon avis).

Voilà, bon potassage :wink: (qui est utile à la bonne compréhension de ce que tu fais, n’aie pas de doutes là-dessus).

edit : pour modifier des fichiers (en root pour le fstab), j’utilise vim, mais bon, il est utile de connaître 2/3 commandes :
:q : pour sortir sans sauvegarder (quit)
:qw : en sauvegardant (write)
touche inser pour insérer du texte (normal quoi), etc de façon générale, man:vim dans konqueror donne les infos (ou man vim en console, mais c’est plus moche :D).

Oui, effectivement, suis tres limite en Linusque
j’ai perdu pas mal de temps à installer des trucs qui n’étaient visiblement pas compatibles avec mon Laptop Sony…

Bref, j’ai un peu de temps la et du coup je “potasse”
=> j’ai trouvé ca qui est plutot bien fait !
http://www.fedora-france.org/modules/wiwim…e&back=WiwiHome

J’ai quand même une question !
Ca signifie quoi ca :
No Match for argument: kmod-ntfs
Nothing to do

Je dirais, comme cela, qu’aucune de tes sources configurées ne contient le paquet voulu.

Merci !!
Il faut que je configure mes sources ?

…hum… un peu de recherches et de mon coté j’ai trouvé ca :

Evidement ca marche pas et j’ai droit a un nouveau jeu de piste :
configurer YUM vers le dépôt livna ???
:pt1cable: :pt1cable: JE CRAAAAQUE !!! :pt1cable: :pt1cable:

Bon… du coup je cherche… et je trouve ca :

Ca fonctionne !
Je lance donc la ligne de code que tu m’as donné :

yum --enablerepo=livna install kmod-ntfs

je dis Yes aux 2 prompts pendant l’install…

ET CA MARCHE !!! Merci :super:

Maintenant passons à l’étape 2 !

Etape 2 : modif du fstab avec les "bons" points de montage

phase 1 : je me fend d’un mount dans un terminal
[root@linux ~]# mount
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/hda6 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
automount(pid2005) on /net type autofs (rw,fd=4,pgrp=2005,minproto=2,maxproto=4)

bon… j’y pige que dalle…
enfin… un peu si… apparement le bouzin reconnait des trucs… un hda6… mais pas ma partition XP :neutre:
(déja si j’arrivais a voir celle en FAT32 !!)

Bon… je me reprend en main et je regarde dans le Gestionnaire de Volumes Logiques (Bureau -> Administration)
La je repère :
[i]Groupes de volumes
Partition7 /dev/hda7 c’est du linux 9Go ok

Entités non Initialisées
Partition1 /dev/hda1 c’est du vfat23
Partition2 /dev/hda2 nofile system !??? Extended W95
Partition5 /dev/hda1 c’est NTFS (mon autre HD)
Partition6 /dev/hda1 c’est du linux /boot[/i]

Je décide de creer un repertoire windows sous /mnt

Ensuite, je vais dans /etc avec le navigateur de fichier et j’ouvre fstab pour le modifier
J’ajoute à la fin du fichier :
/dev/hda1 /mnt/windows vfat user 0 0
/dev/hda2 /mnt/windows vfat user 0 0
/dev/hda5 /mnt/windows ntfs user 0 0

Reboot…
et la !!!
Youpi dans Mnt j’ai access à ma partition FAT32
et le Systeme reconnait bien mon disque VAIO dans poste de travail
MAIS… impossible en cliquant dessus d’y acceder -> pas les droits
(merde… suis root pourtant !??)

Qqun a une solution ???
ca chie visiblement pour le hda2 car dmesg me donne :
VFS: Can’t find a valid FAT filesystem on dev hda2.