Forum Clubic

Faire fonctionner les ports usb sous vmware ?

Bonjour,

J’utilise vmware pour « tester » linux et windows vista/XP.

Problème: je n’arrive pas à « activer » ma clé usb dans ces systèmes. (pourtant, ma souris microsoft usb fonctione bien).

J’ai bien regardé dans le menu de la machine virtuelle VM\removables devices J’ai « USB Device » qui indique « empty » et je ne peux pas le cocher.

Quelqu’un saurait-il comment activer les périphériques usb sous vmWare ?

Par avance, merci.

Julien.

as-tu installé les WMtools ?

Bonjour et merci Le_Poilu pour ta réponse.

Oui, j’ai bien installé les WMTools.

j’utilise la dernière version de VMWare Server. (version gratuite). Je me demandais… la version gratuite n’autorise peut-être pas les périphériques USB ?

Pour info, dans le menu VM\Removable devices\Usb devices lorsque je mets ma clé, un périphérique apparaît sous le nom: Anonymous USB Device (Vendor:13fe Product: 1d00)

Mais même ce périphérique, je ne peux pas l’activer…
Edité le 27/01/2008 à 01:55

Bonsoir,

J’ai le même problème : ma machine virtuelle en route, je branche une clef usb DiskOnKey 128MB sur l’hôte. Elle apparaît alors dans l’explorateur Windows de l’hôte mais n’apparaît pas dans la liste Removable Devices qui reste Empty.

Qu’est-ce que je peux faire ?

Configuration de l’hote :
Windows Vista 32b Ultimate + mises à jour
Configuration de la machine virtuelle :
Windows Server 2003 + mises à jour

a+, =)
-=Finiderire

Bonjour,

En fait, je me suis apercu en faisant le test sur mon ordinateur de bureau (XP) que mes cles usb sont parfaitement bien reconnues dans VMWare.

Le probleme vient donc de ma config sur mon ordinateur portable.

La config de mon ordinateur portable est un HP Pavillon dv9000series Intel Core2Duo T7250 .

VMWare n’est-il pas entierement “compatible” avec les configs des pc portables ? Mon portable est quasi-neuf. Peut-etre trop recent ?

Qu’en pensez-vous ?

ps: finiderire: ton ordinateur hôte est-il une configuration Bureau ou Portable ?

Par avance, merci de votre aide.

Julien.

Bonjour attention par défaut dans vmware serveur les ports usb ne sont pas présents il faut les rajouter dans les settings WM. As tu rajouté tes ports USB ?

Sinon est ce que ta WM ne serait pas elle aussi sur un des ports USB ce qui provoquerait un petit bug ?

A vérifier tout cela

Bonjour et merci pour ta reponse KIKI24D2.

J’avai bien ajouté le composant “USB Controller” dans la config de ma machine virtuelle.

Par contre, je ne comprends pas trop ce que tu veux dire lorsque tu me dis:

“est ce que ta WM ne serait pas elle aussi sur un des ports USB ce qui provoquerait un petit bug ?”

De quoi parles-tu ? Je ne vois pas… (car je ne suis pas une expert de vmWare :wink: )

si tu pouvais me donner plus d’infos, ce serait sympa de ta part.

ps: a moins que tu veuilles dire: est-ce que ma machine virtuelle est installee sur un disque dur externe connecte a l’ordinateur par port usb. Auquel cas, non, ce n’est pas le cas. La machine virtuelle est sur le disque dur de mon ordinateur. Le seul port usb du portable utilise est la souris. Mais j’ai essaye en debranchant ce port aussi et en utilisant a la place le touchpad, le probleme persiste.

En tous les cas, merci de ta reponse.

Julien.
Edité le 29/02/2008 à 21:15

Bonsoir,

Je crois que c’était une machine de bureau (qui est passée sous Windows Vista 64bits depuis).
Aux dernières nouvelles, VMware n’est pas supporté sous Windows Vista, ce qui explique que les ports USB virtuels ne fonctionnent pas.
Voir mon post de février 2008 sur le site de VMware : http://communities.vmware.com/thread/101227

a , =)
-=Finiderire=-