Forum Clubic

EXCEL simples opérations sous excel

Bonjour à tous.
Je souhaite réaliser quelques bidouilles sur excel

voila ma première toute simple je pense avec fonction SI

J’ai 2 colonne sur 2 feuilles différentes ( je crois que cela influe peu)

Les deux colonnes ne comportent que des V ou des D (victoires défaites, 1 page par joueur)

Ainsi la fameuse colonne d’une page doit être inversée sur l’autre

Comment faire que excel inverse automatiquement cette lettre en fction des résultats

Merci beaucoup d’avance
Etienne

  • soit avec la fonction SI() dans ta seconde colonne
  • soit avec un format de cellule personnalisé, en rentrant des 1 et des 0 (ou -1) dans la cellule et en leur attribuant un format littéral du genre “V”;“D”;“N”

la colonne A de la feuille1 comporte des V et des D
Tu veux que la colonne A de la feuille2 comporte l’inverse, et rien, si ni V, ni D :
=SI(Feuille1.A1=“V”;“D”;SI(Feuille1.A1=“D”;“V”;""))

Merci beaucoup
J’ai juste eu à changer les point de la formule par des ! et mettre des ‘feuille1’ à la formule et ça marche
super merci encore

Une autre petite question

Comment totaliser le nombre de lettres d’une colonne ? ( nbre de V , de D , afin de faire une statistique )
merci
Etienne

Pour les V dans la colonne A, par exemple :
=nb.si(A:A;“V”)

Tes remarques sur ! sont justes. C’est parce que j’ai testé la formule sous openoffice… et il y a de très petites différences.
Pour totaliser et pour compléter la réponse de gcc :
Exemple :
tu souhaites que le champ B1 contienne le nombre de V (les V et D sont dans la colonne A et sur 17 lignes, (A1 à A17)).

En B1 :
=NB.SI(A1:A17;“V”)