Forum Clubic

Excel Nombre décimal

Bonjour à tous
voila j’ai créer un tableau excel (2007) avec dedans des valeurs
mon souci est quand j’entre mes valeurs ( 1 et 0.5) elles s’affichent toutes les deux à “1”
si je vais dans nombre et que je dis mettre en décimal avec un chiffre après la virgule
là j’ai bien mon 0.5 qui apparait mais sa me mais 1.0

ce que je voulais savoir s’est comment laisser afficher 0.5 et que sa m’affiche 1 et non 1.0

Tu peux réexpliquer ton problème en français correct ?

dans office excel 2007 il y a un onglet nombre dans la catégorie accueil ( le 4eme onglet)
dans mon tableau excel lorsque je tape 0,5 sa m’affiche 1
si dans nombre je dit que je veux mes chiffres en décimal avec nombre de décimal “1”
mon 0,5 apparait correctement
mon souci est que mon 1 lui apparait 1,0
je ne veux pas le 1,0 mais 1
tout en gardant mon 0,5

Là c’est clair, mais pas forcément simple à résoudre
Ce qui va s’en rapprocher le plus, c’est l’utilisation d’un format personnalisé de type “0,?”
Par contre, tu vas avoir une virgule, même pour les nombres sans partie décimale

T’as essayé de mettre en format “standard” ?

J’allais le dire. Il suffit de rester sur “standard” et “1” restera “1” tandis que “0.5” sera “0.5”, et ainsi de suite :stuck_out_tongue:

Effectivement …
Personnellement, j’étais parti sur l’idée que le but recherché c’était de faire des colonnes bien ordonnées, avec les décimales sous les décimales, les unités sous les unités etc., mais c’est vrai que rien ne le précise dans la question

merci bien
le souci c’est que même en standard sa ne marche pas
se que j’ai peut être omit de vous dire c’est que j’utilise la virgule sous excel et non le point
avec le point sa marche
mais la virgule non

Ca veut dire qu’Excel reconnaît le point comme séparateur de décimale, autrement dit lorsque tu tapes 1,0, il considèrera ça comme du texte. Si tu veux que le format standard s’adapte aux virgules, il faut aller dans les options du programme (Option Excel > Options Avancées > Décocher “Utiliser les séparateurs systèmes”, remplacer la virgule par un point)

merci boret sa marche pour le point a la place de la virgule mais si je mets en standard sa me mets toujours 1 au lieu de 0.5
Edité le 09/04/2010 à 08:44

Oops pardon il faut remplacer le point par une virgule (je travaille sur une version anglaise):

http://blogs.lessthandot.com/media/blogs/DesktopDev/FixedDecimals.png

Décocher Use system separator
Decimal separator:
Thousands separator :
(jte laisse traduire si tu utilises une version FR)

Et après il faut du coup que tu mettes tes cellules en format standard

désolé je reviens de vacance
je réponds donc seulement a ton message
j’ai fait comme tu dit mais toujours rien
j’ai recopier les même option excel que toi
[Photo supprimée]

POur utiliser les operateurs systeme (,) tu dois aussi etre en français dans “options régionales et linguistiques”

[Photo supprimée]

merci dji dji mais je suis sous un office 2007
peut tu me dire ou se trouve cette option linguistique

Cest dans la conf de XP

démarrer–>panneau de configuration–>options régionales ou linguistiques

ou

démarrer–>paramètres–>panneau de configuration–>options régionales ou linguistiques

et si j’ai un win 7 sa se trouve ou

Tu veux pas 100 balles et un mars ?

démarrer–>panneau de configuration–>horloge, langue et région–>région et langue–>administration–>modifier les paramètres régionaux–> choisir français (France)

Puis vérifier dans l’onglet démarrer–>panneau de configuration–>horloge, langue et région–>région et langue–>Format–>paramètres supplémentaires -->
que le symbole décimal soit bien la virgule