Forum Clubic

Excel - compter les majuscules dans une colonne

Bonjour,
J’ai une colonne Excel remplie avec des j et J.
Je souhaite savoir le nombre de j de cette colonne, mais avec toutes les formules que j’ai utilisées, à chaque fois, les j et J ne sont jamais différenciés…
Est-ce que quelqu’un a une idée ?!?
Merci d’avance de votre collaboration.

:stuck_out_tongue:
Voici une petite macro qui te permettra de faire ce decomptage
Si tu n’es pas familiarisé avec les macros je te detaillerais la marche à suivre
Il te faut selectionner la colonne entiere ou les j sont à compter et lancer ensuite la macro
Sub Macro1()
n = 0
For Each c In Range(Selection.Address)
If c.Value = “j” Then n = n + 1
Next
reponse = MsgBox(“Il y a " & n & " j dans la selection”, vbDefaultButton1)
End Sub
:slight_smile:

Essaye cela :
=SOMME(NBCAR(A1:A100)-NBCAR(SUBSTITUE(A1:A100;“j”;"")))
Attention : Tu valides cette formule en appuyant sur Ctrl+Shift+Enter (c’est une formule matriciel)
Cela donnera :
{=SOMME(NBCAR(A1:A100)-NBCAR(SUBSTITUE(A1:A100;“j”;"")))}

Bonjour et merci beaucoup pour vos solutions.
Je connaissais les macros et ça fonctionne parfaitement bien.

Merci beaucoup pour votre aide.