Forum Clubic

Eviter l'activation de Windows XP - Après une image Sysprep par Altiris

Bonjour,

Ma question est simple avec un détail le plus complet sur l’activation de Windows après une image Sysprep via Altiris.

Dans ma société, nous utilisons un progiciel de déploiement Altiris. Le module RDeploy permet la création et la restauration d’image disques.
Pour la création d’une image qui sera sauvegardée sur notre serveur, je fais en sorte que lors d’une prochaine restauration, je restaure l’image grâce à la mini-installation que j’aurai resceller grâce à Sysprep. Ce fichier sysprep.inf contient toutes les infos : clés de Windows, login et password pour intégration immédiate à un domaine, liste des périphériques ([SysprepMassStorage]), et d’autres fonctions complémentaires.

Avant de faire une image, des PC (bureau et portables de marque DELL) ont été installé avec succès ainsi que le reste des logiciels. Même si on reformate le PC, on peut passer par le CD de Windows XP Pros SP2 fournit par DELL.
La particularité de l’installation de Windows XP Pro SP2 de DELL est que nous n’avons nul besoin de nous enregistrer et d’activer auprès de Micro$oft.

Lorsque je souhaite effectuer une image disque via sysprep, ce dernier me casse pas mal de choses. Certes mineurs tel que les lecteurs nommés M:\, P:\, … Le gros point noir pour nous est qu’aparaît le module d’activation de Windows XP.
Pourquoi ???

J’ai essayé plusieurs façon pour empêcher l’activation de Windows :

  • enregisterment en ligne : ok mais au bout de 3 ou 5 fois, on est bloqué car une utilise la même clé de Windows dans le fichier Sysprep (à savoir que nous avons un parc de +100 postes)
  • soit d’après un magasine informatique, pour récupérer les clés d’activation et les remplacer après une réinstallation, ce dernier nous demande de copier 3 fichiers situés dans “c:\windows\system32”. Avant image, on copie les 3 fichers “wpa.dbl”, “wpa.bak” et “wpabaln.exe”. Après image on recopie ces fichiers que nous écrasons sur ceux existant après l’image sysprep : on demande toujours une activation de Windows. Autre fait, si notre image disque créée date de +30 jours, il bloque Windows pour une demande d’activation.
  • soit on a mis en place un logiciel d’anti-activation de XP. La ça marche mais on a un souçis pour les mises à jours de Windows. Ces mises à jours se font grâce à notre serveur WSUS mais est impossible à mettre une mise à jour du PC correctement. Pourtant j’ai vu le fonctionnement de l’anti-activation du patch anti-activation : le dossier caché dllcache du system32 doit avoir les droits d’écriture. On lance un exe pour que ce dernier modifier des données des fichiers. Puis on supprime un dossier temporaire et on rajoute une clé dans le regedit.

Alors, je ne sais pas comment on peut faire pour éviter cette anti-activation à cause de sysprep.
Est-ce que j’ai omis quelque chose pour l’anti-activation ???
Avez-vous connu le même problème et possédez-vous une solution ?

Ma démarche de sysprep avant création image.

  1. copie du dossier i386 du disque DELL et on le colle à la racine du disque c:\
  2. modification dans la base de registre : exécution de regedit puis se rendre "HKLM\Software\Microsoft\Windows\CurrentVersion\Setup\SourcePath" : changer la valeur par "C:\i386"
    "HKLM\Software\Microsoft\Windows\CurrentVersion\Setup\ServicePackSourcePath" : changer la valeur par "C:\i386"
  3. création d’un dossier DRIVERS à la racine de c:\ et ce dossier contiendra un ensemble de sous dossiers (01_CHIPSET ; 02_VIDEO ; …)
  4. exécute sysprep.exe. Choix de mini installation puis "Resceller".

Merci de l’attention que vous aurez apporter à ce message.
Cordialement,
MFWorld :sol:

Simple !!!! Il y en a 2 pages !!!! :ouch:

Les patch anti-activations sont illégaux, donc il est interdit d’en parler ici !

Est-ce que tu as demandé conseil à Altiris ? Après tout, c’est leurs boulots !!!!

Sinon, vu le nombre de postes que tu as, tu peux peut être acheter des licenses “Corporate”, ce qui t’eviterais ce problème.

Les CD récents de Dell ont la facheuse habitude de ne fonctionner qu’avec des Dell ! :smiley:

:lol: AdminOfPlaygroup > je m’attendais à une réflexion du genre.

Je sais fort bien que les patches “anti-activation” sont illégaux. Mais le Sysprep n’a rien à voir avec Altiris puisque Sysprep est inclus dans chaque CD de Windows.

On m’avait expliquer le moyen par la sauvegarde de fichiers d’activation mais sans succès. Or sauvegarder les fichiers comprenant les activations de Windows ne sont pas illicites ?!
Je sais fort bien que d’avoir une coporate voir une licence Open serait l’idéale mais déjà qu’on achète plus de 100 licences Windows XP Pro, ça nous fouterait à mal de payer qqch à Micro$oft :riva: :smiley:

Alors help si vous avez une info sur ce problème de Sysprep.
Merci :sol:

C’est mon boulot, je suis modérateur ! :wink:

sysprep permet de créer des CD bootable d’installation prêt à l’emploi, qui t’evite de taper sans arrêt les mêmes paramètres, information de l’entreprise, mot de passe administrateur, … et même de changer le SSID, mais tu ne penses quand même pas qu’un outils de Microsoft va te permettre d’eviter l’activation ! [:yeoh]

Une vieille doc : http://www.laboratoire-microsoft.org/artic…etwork/sysprep/

Quant tu fait l activation, il te crée un fichier WBA.quelquechose
il faut juste creer un script pour le sauvegarder pour chaque poste. Il faut que ton WBA soit celui qui correspond a ta clé de license

Oui les fichiers wpa, c’est ce que nous avons fait. Apparement ça passe pas.
Soit parce qu’on copie les fichiers trop tôt.
Même après ça, un copier coller par dessus : sans succès :??:
Il doit y avoir une méthode pour qu’il refuse de me demander une activation si j’insère ces fichiers d’activation.

Pour info, comme c’est des PC Dell avec licence OEM de DELL, on a tendance à utiliser une seule clé unique qui fonctionne sur toutes les stations.
Et oui, nous avons la flemme de se faire les 100 postes :pt1cable: :smiley:

Si ca marche pas, c est que ton WPA ne correspond pas a la license.
j ai fait deja le teste chez moi pour un CD de XP automatisé
j avai copié le fichier dans $$\system32\oobe et apres plusieurs reboot (du a l install de programmes) il me fait plus chier avec l activation.

Pour verifier, fait une installe propre, sur un poste, et active le, une fois que c est fait, utilise ce fichier WPA.
bon courage :jap:

Exact : cette manip est devenue depuis longtemps obsolète.

C’est pour ça que je ne l’ai pas modéré ! [:superguipom]

Salut MFWorld !

As-tu essayé la commande suivante lors de la réalisation de ton sysprep ?

sysprep.exe -reseal -mini -activated

Normalement “-activated” permet d’éviter la réactivation … maintenant dans quelle limite de changement … ??

Quand on a 100 PC et qu’on veux eviter l’activation, on achete les licenses Open et pas les licenses OEM ! :ane:

Mais folo, tu as remarqué que ce sujet à presque 4 mois … tu crois qu’il est encore d’actualité … qu’il attends pour installer ses 100 machines [:siffle]

Lien : http://support.microsoft.com/default.aspx?scid=kb;FR;302577

Bonjour,

Quand je lis les réponses je suis MDR

Attendez ont vous demande de l’aide pas des leçons de moral, dans ce que veux faire cette
Personne il n’y a rien d’illégal sinon dell aurais des soucis à se faire

Donc moi je vais te répondre car j’ai la solution

En fait quand dell te livre des ordis il te les livre en mode usine ou SYSPREP pour les connaisseurs
C’est la que je m’inquiète sur tes connaissances du sysprep

Tu a la réponse dans ta question, dans ton sysprep tu lui insère quel License WINDOWS celle fourni sur l’ordi ?
Si c’est le cas revois ta copie car cette clée est une OEM et non VLK

Donc cogite un peu et tu trouveras car si je te donne tout de suite la soluce c’est po marrant

COMMENT DELL fais pour livrer des ordis en sysprep sans activation ?
Tout simplement .en …

Demain la suite si tu réponds à ce poste et si tu ne trouves pas

@++

Dis le pro : as-tu vu de quand date la question ? [:siffle]

Je doit être top bête car à part utiliser une licence VLK je vois pas de solution

Tu pourrai donner la suite SVP

Pour le Modo : j’ai vu que le post date un peu mais le thread est pas encore tout à fait mort il bouge encore un peu :wink:

Je sais que le sujet date de longtemps mais si quelqu’un a eu des news ou des avancés sur ce problème je suis preneur :slight_smile:

Tu as une licence Corporate prévu pour plusieurs postes ?

Bonjour,

Non sinon je ne posterais pas sur ce topic et ne prendrais pas la tête . Je viens juste voir si la personne qui a réussi pouvait me transmettre l’info ou si d’autres avaient avancé sur le sujet .

Car même si je comprends que les licences OEM ne sont pas fait pour cela , je pensais que le fait de rentrer la clé Cd à chaque fois ne me causerait pas de problème d’activation .

Je suis quand même écœuré qu’a final même en rentrant le clé cd de chaque pc je sois limité en terme d’activation de licence .

Merci en tous cas de t’intéréssé à mon souci :slight_smile:

Tu peux le faire avec un XP SP3 intégré ou avec Vista, qui autorise une installation sans clef, mais pas avec les “vieux” XP.