Forum Clubic

Erreur de syntaxe lors de la création des backups

Bonjour,

j’ai un soucis de compatibilité avec les backups effectués en local sous easyphp. En effet, même les backups crées avec easyphp et ré-injectés dans les bases que le soft gère, ben ça me fait des misères et c’est la même chose quand je veux transférer mes backup sur mon serveur chez ovh.
En fait, lors de la commande “create table” en local, easy php ajoute la mention “ENGINE=MyISAM DEFAULT CHARSET=latin1 AUTO_INCREMENT=2” contraire à ovh (cf ci dessous) sauriez vous m’indiquer quel réglage effectuer pour que les backups effectués en local correspondent à ceux effectués sous ovh ? Le pb c’est que, les backups réalisés sous easyphp et injecté sous ovh engendrent un message d’erreur indiquant une erreur de syntaxe sql… donc je suis paumé (j’utilise easyphp 2.0beta)

CREATE TABLE phpboost_articles (
id int(11) NOT NULL auto_increment,
idcat int(11) NOT NULL default ‘0’,
title varchar(100) NOT NULL default ‘’,
contents text NOT NULL,
icon varchar(255) NOT NULL default ‘’,
timestamp int(11) NOT NULL default ‘0’,
visible tinyint(1) NOT NULL default ‘0’,
start int(11) NOT NULL default ‘0’,
end int(11) NOT NULL default ‘0’,
user_id int(11) NOT NULL default ‘0’,
views mediumint(9) NOT NULL default ‘0’,
users_note text NOT NULL,
nbrnote mediumint(9) NOT NULL default ‘0’,
note smallint(6) NOT NULL default ‘0’,
nbr_com int(11) unsigned NOT NULL default ‘0’,
lock_com tinyint(1) NOT NULL default ‘0’,
PRIMARY KEY (id),
KEY idcat (idcat)
) ENGINE=MyISAM DEFAULT CHARSET=latin1 AUTO_INCREMENT=2 ;

et chez ovh, les backups donnent un truc du genre:

CREATE TABLE phpboost_articles (
id int(11) NOT NULL auto_increment,
idcat int(11) NOT NULL default ‘0’,
title varchar(100) NOT NULL default ‘’,
contents text NOT NULL,
icon varchar(255) NOT NULL default ‘’,
timestamp int(11) NOT NULL default ‘0’,
visible tinyint(1) NOT NULL default ‘0’,
start int(11) NOT NULL default ‘0’,
end int(11) NOT NULL default ‘0’,
user_id int(11) NOT NULL default ‘0’,
views mediumint(9) NOT NULL default ‘0’,
users_note text NOT NULL,
nbrnote mediumint(9) NOT NULL default ‘0’,
note smallint(6) NOT NULL default ‘0’,
nbr_com int(11) unsigned NOT NULL default ‘0’,
lock_com tinyint(1) NOT NULL default ‘0’,
PRIMARY KEY (id),
KEY idcat (idcat)
) TYPE=MyISAM AUTO_INCREMENT=1 ;
Edité le 07/10/2008 à 19:18

Tu le fais via phpmyadmin?

Car dans les options des exports, tu peux changer le mode d’export pour exporter en mode compatible XXX.

bonjour,

oui, j’ai tenté plusieurs modes de compatibilité mais le problème persiste. On m’a parlé quelque part d’un soucis avec les jeux de caractère ou je ne sais quoi, mais aucune réponse claire et précise… j’y comprends vraiment rien

Tu as quelle version de mySQL sur ton serveur distant?
Edité le 07/10/2008 à 19:33

mysql 5 chez ovh mais le problème se présente aussi lors de la restauration de backup en local (Easyphp v2.0b)