Forum Clubic

Erreur 403 sur mon Apache 1.3.9 sous Linux

j’ai un soucis sur mon apache fraichement installé, quant je veux me logger sur le serveur http, Bim: Erreur 403 (forbidden). Comment faire ?


Voici ma conf httpd:

ServerType standalone
ServerRoot "/root/apache"
PidFile /root/apache/logs/httpd.pid
ScoreBoardFile /root/apache/logs/httpd.scoreboard
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 15
MinSpareServers 5
MaxSpareServers 10
StartServers 5
MaxClients 150
MaxRequestsPerChild 0
Listen XX.XX.XX.XX:80
LoadModule php4_module        libexec/libphp4.so
Port 80
User apache
Group apache
ServerAdmin root@srvexpweb
ServerName XX.XX.XX.XX
DocumentRoot "/root/apache/htdocs"

<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>

<Directory "/root/apache/htdocs">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

<IfModule mod_userdir.c>
    UserDir public_html
</IfModule>

<IfModule mod_dir.c>
    DirectoryIndex index.html
</IfModule>

AccessFileName .htaccess

<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
    Satisfy All
</Files>

UseCanonicalName On

<IfModule mod_mime.c>
    TypesConfig /root/apache/conf/mime.types
</IfModule>

DefaultType text/plain

<IfModule mod_mime_magic.c>
    MIMEMagicFile /root/apache/conf/magic
</IfModule>

HostnameLookups Off
ErrorLog /root/apache/logs/error_log
LogLevel warn
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %b" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent
CustomLog /root/apache/logs/access_log common
ServerSignature On
<IfModule mod_alias.c>
    Alias /icons/ "/root/apache/icons/"

    <Directory "/root/apache/icons">
        Options Indexes MultiViews
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>

    Alias /manual/ "/root/apache/htdocs/manual/"

    <Directory "/root/apache/htdocs/manual">
        Options Indexes FollowSymlinks MultiViews
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>

    ScriptAlias /cgi-bin/ "/root/apache/cgi-bin/"

    <Directory "/root/apache/cgi-bin">
        AllowOverride None
        Options None
        Order allow,deny
        Allow from all
    </Directory>

</IfModule>

<IfModule mod_autoindex.c>

    IndexOptions FancyIndexing
    AddIconByEncoding (CMP,/icons/compressed.gif) x-compress x-gzip

    AddIconByType (TXT,/icons/text.gif) text/*
    AddIconByType (IMG,/icons/image2.gif) image/*
    AddIconByType (SND,/icons/sound2.gif) audio/*
    AddIconByType (VID,/icons/movie.gif) video/*

    AddIcon /icons/binary.gif .bin .exe
    AddIcon /icons/binhex.gif .hqx
    AddIcon /icons/tar.gif .tar
    AddIcon /icons/world2.gif .wrl .wrl.gz .vrml .vrm .iv
    AddIcon /icons/compressed.gif .Z .z .tgz .gz .zip
    AddIcon /icons/a.gif .ps .ai .eps
    AddIcon /icons/layout.gif .html .shtml .htm .pdf
    AddIcon /icons/text.gif .txt
    AddIcon /icons/c.gif .c
    AddIcon /icons/p.gif .pl .py
    AddIcon /icons/f.gif .for
    AddIcon /icons/dvi.gif .dvi
    AddIcon /icons/uuencoded.gif .uu
    AddIcon /icons/script.gif .conf .sh .shar .csh .ksh .tcl
    AddIcon /icons/tex.gif .tex
    AddIcon /icons/bomb.gif core

    AddIcon /icons/back.gif ..
    AddIcon /icons/hand.right.gif README
    AddIcon /icons/folder.gif ^^DIRECTORY^^
    AddIcon /icons/blank.gif ^^BLANKICON^^

	DefaultIcon /icons/unknown.gif

    ReadmeName README.html
    HeaderName HEADER.html

    IndexIgnore .??* *~ *# HEADER* README* RCS CVS *,v *,t

</IfModule>

<IfModule mod_mime.c>

    AddLanguage da .dk
    AddLanguage nl .nl
    AddLanguage en .en
    AddLanguage et .ee
    AddLanguage fr .fr
    AddLanguage de .de
    AddLanguage el .el
    AddLanguage he .he
    AddCharset ISO-8859-8 .iso8859-8
    AddLanguage it .it
    AddLanguage ja .ja
    AddCharset ISO-2022-JP .jis
    AddLanguage kr .kr
    AddCharset ISO-2022-KR .iso-kr
    AddLanguage nn .nn
    AddLanguage no .no
    AddLanguage pl .po
    AddCharset ISO-8859-2 .iso-pl
    AddLanguage pt .pt
    AddLanguage pt-br .pt-br
    AddLanguage ltz .lu
    AddLanguage ca .ca
    AddLanguage es .es
    AddLanguage sv .sv
    AddLanguage cs .cz .cs
    AddLanguage ru .ru
    AddLanguage zh-TW .zh-tw
    AddCharset Big5         .Big5    .big5
    AddCharset WINDOWS-1251 .cp-1251
    AddCharset CP866        .cp866
    AddCharset ISO-8859-5   .iso-ru
    AddCharset KOI8-R       .koi8-r
    AddCharset UCS-2        .ucs2
    AddCharset UCS-4        .ucs4
    AddCharset UTF-8        .utf8

    <IfModule mod_negotiation.c>
        LanguagePriority en da nl et fr de el it ja kr no pl pt pt-br ru ltz ca es sv tw
    </IfModule>

    AddType application/x-tar .tgz

    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps

   
    AddEncoding x-compress .Z
    AddEncoding x-gzip .gz .tgz
   

</IfModule>

<IfModule mod_setenvif.c>

    BrowserMatch "Mozilla/2" nokeepalive
    BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0

 
    BrowserMatch "RealPlayer 4\.0" force-response-1.0
    BrowserMatch "Java/1\.0" force-response-1.0
    BrowserMatch "JDK/1\.0" force-response-1.0

</IfModule>


Voici mes dossiers:


drwxr-xr-x  2 root   root   4096 déc 20 11:25 bin
drwxr-xr-x  2 root   root   4096 déc 20 11:25 cgi-bin
drwxr-xr-x  2 root   root   4096 déc 20 13:42 conf
drwxr-xr-x  3 apache apache 4096 déc 20 12:03 htdocs
drwxr-xr-x  3 root   root   4096 déc 20 11:25 icons

et enfin l’interieur:



-rw-r--r--  1 apache apache 6268 jan  6  2005 index.html.ru.ucs4
-rw-r--r--  1 apache apache 2318 jan  6  2005 index.html.ru.utf8
-rw-r--r--  1 apache apache 1700 jan  6  2005 index.html.se
-rw-r--r--  1 apache apache 1062 jan  6  2005 index.html.zh-tw.big5
drw-r--r--  8 apache apache 4096 déc 20 11:25 manual
-rw-r--r--  1 apache apache   17 déc 20 12:03 phpinfo.php

Edité le 20/12/2007 à 14:17

Peux tu donner l’url, ou le script auquel tu essais d acceder ? (eventuellement un ps auxw|grep httpd) et pourqu oi pas le log correspondant.

c’est un site intranet, desoler …
En fait j’ai trouvé le probleme, c’est que tout les dossiers pointant vers le ServerRoot doivent avoir le chmod 775
hors mon /root est en r-xr-xr–
Tout simplement, merci quant meme :slight_smile: